Announcement

Collapse
No announcement yet.

Question about installing Movies off of HS update..

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    #31
    Pete,
    I think that all that needs to be done is delete the periodic event that runs movies.wsf each day. There is likely a few tables created in a database that will not disturb anything, but you can delete them. They all have Theater or Movie type names. I include the install.txt file with the package I send Rich, but I do not know if it is downloaded. This will itemize all files that were installed. I'll attach it here. I believe the default ini configuration is to not use virtual devices so they should not of been created. They will be T1, T2, etc and can be deleted. All the "creation" damage is done with moviesInstall.txt. You can look in there to see if anything else is affected.

    jcannon,
    I cannot quickly think of a dependency between having good Theaters, Movies, and MovieTimes data but no MovieDevices or Virtual Devices containing data. The easiest thing for me is to get a copy of your mcsMovies.ini file. The database would also be useful so see what was actually retrieved at your end.

    Some common problems with the movies package in the past that you may want to check:
    1. The TheaterIds.txt items selected are not within the nearest "n" theaters of your selected zip code. Increase the zip=n value for n.
    2. MoviesInstall.txt was not run after an update to mcsMovies.ini was made and movies update event run after the moviesInstall.txt was run.
    3. Do install the patch near the end of this thread so you will get the icons correctly.
    Attached Files

    Comment


      #32
      Noticed a Virtual device labeled "V1" , Location "Tasks" with no name. Is this a virtual device created when installing Movie Update or one of your other scripts? Thanks again for your help Michael.
      - Pete

      Auto mator
      Homeseer 3 Pro - 3.0.0.548 (Linux) - Ubuntu 18.04/W7e 64 bit Intel Haswell CPU 16Gb- Mono 6.12.X - HSTouch on Intel tabletop tablets
      Homeseer Zee2 (Lite) - 3.0.0.548 (Linux) - Ubuntu 18.04/W7e - CherryTrail x5-Z8350 BeeLink 4Gb BT3 Pro - Mono 6.12.X
      HS4 Pro - V4.1.10.0 - Ubuntu 18.04/VB W7e 64 bit Intel Kaby Lake CPU - 32Gb - Mono 6.12.x
      HS4 Lite -

      X10, UPB, Zigbee, ZWave and Wifi MQTT automation-Tasmota-Espurna. OmniPro 2, Russound zoned audio, Smartthings hub, Hubitat Hub, and Home Assistant

      Comment


        #33
        Pete, Chuck V1. I forgot about that one.

        Comment


          #34
          I used the updater to install the most recent version of Movies ( .asp, .txt, .vbs, .wsf ). After customizing the mcsMovies.ini file, I ran MoviesInstall.txt ( no errors, so I assume it did what it was supposed to ). I also deleted the line containing the IEgetURL.inc reference from movies.wsf. Now when I attempt to run the "Update Movies" event, which spawns movies.wsf, I get a Windows Script Host error message ( see attachment )



          Any ideas what is causing this ?

          Thanks for the awesome script and asp pages !
          Attached Files

          Comment


            #35
            There is a moviesPatch about about 10 posts back on this same thread. This should be used until Rich uploads the version 4.1.2 to the updater. Let me know if it still does not work after installing it.

            Comment


              #36
              I applied the patch from this thread, and when I execute the Update Movies event, the spawn of movies.wsf now appears to be doing something...cursor flashes for a while, HD activity, etc. There are no entries in HS log, so I'm not sure if the script is completing successfully. The Homeseer.mdb tables appear to have all the requested theater and movie data in them. When I try to launch the Movies.asp page, I get the following error in the browser window :

              Script error: Syntax errorHTTP/1.1 404 OK
              Server: HomeSeer

              HomeSeer internal error File: C:\PROGRAM
              FILES\HOMESEER\html\/../Scripts/includes/DatabaseUtilities.inc

              Same result for Theater_List.asp...

              Thanks again for your support

              Comment


                #37
                This looks like something from a version of homeseer earlier than 1.5.2 B57. Before this time the approach was to use two copies of the includes for asp files. You can try this if you wish.

                Copy databaseUtilities.inc from the \Scripts\includes area to databaseUtilities.asp in the \HTML\includes area. Edit the top of movies.asp to replace the following:
                <%
                <!--#include virtual= "/../Scripts/includes/DatabaseUtilities.inc"-->
                %>

                with

                <!--#include virtual= "/includes/DatabaseUtilities.asp"-->


                If it works for you then do the same for Theater_List.asp.

                Yet another approach is to past the contents of DatabaseUtilities.inc in place of the include statement I identified above. In this case, however, you will need to retain the <% and %> around the group.

                A third is a little debug hs.writelog statement at the start of the asp file, but I suspect it never gets to the point of trying to execute with the "internal error" message being generated.

                Comment


                  #38
                  Excite no longer carries Carmike theaters in Huntsville. Anyone else getting Carmike listings? I still use the old theather2 script. Does this script run STAND ALONE or does it require other downloads. Also is it available from another place other than the installer. I want to know exactly what it installs and would rather do it my self.

                  -Rupp
                  ...it was a holy night.
                  -Rupp
                  sigpic

                  Comment

                  Working...
                  X