Announcement

Collapse
No announcement yet.

[plugin] Network Monitor Plugin Discussion

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Guest's Avatar
    Guest replied
    Steve,

    I have a request for your excellent plug-in. I would love to have the ability to a) have specific network-type device images (routers, internet, printers, Audrey, ePods, servers, etc) or b) have the ability to choose image pairs (online/offline) for each device.

    Thanks for considering my suggestion!

    Leave a comment:


  • RAM
    replied
    <BLOCKQUOTE class="ip-ubbcode-quote"><font size="-1">quote:</font><HR>Originally posted by Steve Hill:
    1) Can it be set to have different icons for devices instead of the online/offline default?
    --------------------------------------------------------------------------------
    One of these days I'm going to finish and release my status manager plugin that would handle that for you.. until then, you can replace the icons with your own, but it's all or nothing.

    ==============================================
    and
    ==============================================
    --------------------------------------------------------------------------------
    I tried removing a device from the list that is being montiored. Selecting the &lt; button does nothing.
    --------------------------------------------------------------------------------

    Oops. Maybe that button didn't get finished...
    --------------------------------------------------------------------------------
    <HR></BLOCKQUOTE>

    These are from back in July. Any chance any work can be done on these requests/bug fixes?

    Dick

    Leave a comment:


  • jonas.hellgren
    replied
    Thanks Rupp,
    works perfectly in the web view.

    / Jonas

    Leave a comment:


  • Rupp
    replied
    Yes. Try online.gif and offline.gif and put them in the html directory.

    -Rupp


    {{{{{{{{{{ Remember the reason for the season }}}}}}}}}}

    Leave a comment:


  • jonas.hellgren
    replied
    I cant't get icons for online / offline to display on the device view.
    The only to icons is hard_disk and warning_hard_disk located in "C:\Program\HomeSeer\html\images\hspi_network_monitor"
    What should the icons be namned offline.gif ?

    Thanks,

    Jonas, Sweden

    Leave a comment:


  • MFULLER
    replied
    Hi There,

    Great plugin, but I have a possible bug for you

    Devices with code z1 won't work. I've tried and tried, but no luck. As soon as I changed it to A21, it worked no problem

    Oh, and a question. In the option settings for Online and Offline.. I've tried using HTML code so when it's online etc, it's in bold, but it doesn't seem to change in the web interface, so I am assuming that it strips the html ?

    Thanks

    Marc

    [This message was edited by Marc Fuller on Wed, 23 July 2003 at 11:34 AM.]

    Leave a comment:


  • csmith
    replied
    Steve, Thanks for the nice plug-in.

    Its seeing all of my computers, routers and access points. But, I have a SliMP3 player (networked mp3 player) that always shows "offline". I can ping it from the command line, but the Network Monitor keeps reporting offline

    Any ideas?

    Leave a comment:


  • shill
    replied
    The devices can be removed by editing the hspi_network_monitor.ini file in the config directory and taking them out. One of these days life will slow down enough (ha ha) for me to fix that remove button!

    Leave a comment:


  • Guest's Avatar
    Guest replied
    <BLOCKQUOTE class="ip-ubbcode-quote"><font size="-1">quote:</font><HR>Originally posted by tards:
    <BLOCKQUOTE class="ip-ubbcode-quote"><font size="-1">quote:</font><HR><BLOCKQUOTE class="ip-ubbcode-quote"><font size="-1">quote:</font><HR>I tried removing a device from the list that is being montiored. Selecting the &lt; button does nothing.<HR></BLOCKQUOTE>

    Oops. Maybe that button didn't get finished... <HR></BLOCKQUOTE>

    Me too. I've got some "phantom" network devices that I can't delete. The remove button does not work. If I delete the actual devices, they keep coming back!! Removing and reinstalling the plugin does not fix it either.

    Help!!<HR></BLOCKQUOTE>

    Leave a comment:


  • Guest's Avatar
    Guest replied
    <BLOCKQUOTE class="ip-ubbcode-quote"><font size="-1">quote:</font><HR><BLOCKQUOTE class="ip-ubbcode-quote"><font size="-1">quote:</font><HR>I tried removing a device from the list that is being montiored. Selecting the &lt; button does nothing.<HR></BLOCKQUOTE>

    Oops. Maybe that button didn't get finished... <HR></BLOCKQUOTE>

    Me too. I've got some "pahnot" network devices I can't delete. The remove button does not work. If I delete the actual devices, they keep coming back!! Removing and reinstalling the plugin does not fix it either.

    Help!!

    Leave a comment:


  • shill
    replied
    <BLOCKQUOTE class="ip-ubbcode-quote"><font size="-1">quote:</font><HR>1) Can it be set to have different icons for devices instead of the online/offline default?<HR></BLOCKQUOTE>

    One of these days I'm going to finish and release my status manager plugin that would handle that for you.. until then, you can replace the icons with your own, but it's all or nothing.

    <BLOCKQUOTE class="ip-ubbcode-quote"><font size="-1">quote:</font><HR>2) Is there any variables that can be put into an email when an event is setup to send an email for a low drive space or offline condition?<HR></BLOCKQUOTE>

    I need to make sure the devices collection is exposed. If/when it is, you'd have access to hs.plugins("Network Monitor").Devices().Drives() objects. I'll check it out and post an update if I need to. If you have VB6 or .NET, you can start a blank project and add a reference to the exe; then object browser will help you view the methods and properties exposed by the plugin for scripting.

    <BLOCKQUOTE class="ip-ubbcode-quote"><font size="-1">quote:</font><HR>3) I would like to setup a tickler email when something happens, like when any device goes offline send an email every 15 mins. Currently I can setup an event to run every 15 mins but I need to add each device i. Could there be a way to do all devices?<HR></BLOCKQUOTE>

    You could setup one event that occurs every 15 minutes with a list of "OR" conditions based on each device... or I could add a condition that allowed "Any Device" or "Any Drive". I'll look into it.

    Leave a comment:


  • tyke
    replied
    Steve--

    Thanks for the free plug-in!!

    I have a couple of comments or ideas.

    1) Can it be set to have different icons for devices instead of the online/offline default?

    2) Is there any variables that can be put into an email when an event is setup to send an email for a low drive space or offline condition?

    3) I would like to setup a tickler email when something happens, like when any device goes offline send an email every 15 mins. Currently I can setup an event to run every 15 mins but I need to add each device i. Could there be a way to do all devices?

    tyke

    Leave a comment:


  • shill
    replied
    <BLOCKQUOTE class="ip-ubbcode-quote"><font size="-1">quote:</font><HR>Duuhh... OK, I've setup recurring events and some things are starting to work. I can get the computers to report their on/off-line status but instead of showing the computer name in the HS Devices "Name" field, it shows the device code (yes, the plug-in name has the computer name, not the device code).<HR></BLOCKQUOTE>

    Strange.. I'll look at the code around this section. Also, if you could post (or email me) your xml config file that would help as well.

    <BLOCKQUOTE class="ip-ubbcode-quote"><font size="-1">quote:</font><HR>As for the drive space recurring event, that reports on/off-line status. Shouldn't it report remaining disk space?<HR></BLOCKQUOTE>

    The event doesn't "report" anything. It simply executes the action you have selected. Perhaps you could recheck the action you selected for that event? It also only changes a device status if it really changes; i.e., if the disk was ok last time and is ok this time, you won't see the device change. I debugged the changing of status codes by raising and lowering my threshhold for the disk device to dramatic levels, so you could try that if you want to test an event that triggers off of low disk space...

    <BLOCKQUOTE class="ip-ubbcode-quote"><font size="-1">quote:</font><HR>I've obviously messed up the set-up. But as Bill D reports, the "&lt;" does not remove the monitored device from the set-up. I'll next try to delete the config file and start over, but I suspect I'll make the same mistakes again (whatever they were).<HR></BLOCKQUOTE>

    Deleting the XML file from the config directory will suffice (or you can edit it manually if you've got some data in there and are familiar with the basics of XML docs.

    <BLOCKQUOTE class="ip-ubbcode-quote"><font size="-1">quote:</font><HR>Speaking of set-up, I originally created my own virtual devices. Is this necessary? Don't plug-ins create their own virtual devices with special characters like _ ] ' and # so you don't burn up the A-to-Z virtual devices?<HR></BLOCKQUOTE>

    Plugins can do that, and as I stated in the readme, it's on the list of future enhancements that I (or anyone else interested...) would like to get into the plugin.

    Leave a comment:


  • shill
    replied
    <BLOCKQUOTE class="ip-ubbcode-quote"><font size="-1">quote:</font><HR>The Options window does not show up in the windows task bar when its open, if I switch to another window, I can't get back to it. Also sometimes when it opens, it isn't the top window, same issue, can't get to it.<HR></BLOCKQUOTE>

    This is an issue between HomeSeer and ActiveX EXE plugins. The fact that it is an ActiveX EXE plugin, however, is what helps offload the ping/check disk space process from HomeSeer's thread... there are a couple of things I can try to improve this, but no promises.

    <BLOCKQUOTE class="ip-ubbcode-quote"><font size="-1">quote:</font><HR>I added a device with just a name, that didn't resolve, so I went back in and added the IP address. It still does not see it, says its offline, but its not.<HR></BLOCKQUOTE>

    I'll test this scenario next time I get in the code.. if you go to a command prompt and manually ping the computer name, does everything resolve correctly? Do you have any strange Active Directory or DNS configuration settings?

    <BLOCKQUOTE class="ip-ubbcode-quote"><font size="-1">quote:</font><HR>I tried removing a device from the list that is being montiored. Selecting the &lt; button does nothing.<HR></BLOCKQUOTE>

    Oops. Maybe that button didn't get finished...

    Leave a comment:


  • Guest's Avatar
    Guest replied
    Duuhh... OK, I've setup recurring events and some things are starting to work. I can get the computers to report their on/off-line status but instead of showing the computer name in the HS Devices "Name" field, it shows the device code (yes, the plug-in name has the computer name, not the device code).

    As for the drive space recurring event, that reports on/off-line status. Shouldn't it report remaining disk space?

    I've obviously messed up the set-up. But as Bill D reports, the "&lt;" does not remove the monitored device from the set-up. I'll next try to delete the config file and start over, but I suspect I'll make the same mistakes again (whatever they were).

    Speaking of set-up, I originally created my own virtual devices. Is this necessary? Don't plug-ins create their own virtual devices with special characters like _ ] ' and # so you don't burn up the A-to-Z virtual devices?

    Thanks for putting up with all my questions!

    Leave a comment:

Working...
X