Announcement

Collapse
No announcement yet.

Discussion for GamePort+ Plugin Version 2.7.0......New!

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • ldragon99
    replied
    No Updates, How about source code.

    I really miss this app. All of my doors and windows have been silent since the chage to HS2. In the winter I more or less "live" in the basment. My office and HS Computer are down there. I really miss knowing when the door has been opened upstairs.
    If there has been no work on this or no plans to update it, what are the chances of posting the source code. I am sure that besides me there are alot of people that would be willing to get this running again.

    Leave a comment:


  • Guest's Avatar
    Guest replied
    I cannot seem to find the link to this plugin...could anyone post it for me?
    Thanks

    Leave a comment:


  • StePhan
    replied
    Gameport stop after 2-3 days

    Have Gameport 2.70
    homeseer 1.7.44
    windows 2000
    USB to gamepad


    have it wired to the garage door it works o.k
    but after a 2-3 days the stop working interface that is
    after I reboot computer (only then) does it start working again

    for a other 2-3 days and reboot computer it start again

    ????

    Leave a comment:


  • flagg
    replied
    Malarcy HID Plugin 1.2.1 Hat Switch added.

    Check out the Plugins section for a HID based joystick plugin. Doesn't require polling and supports as many joysticks as you can plug in. Also supports up to 8 axes and hat switches each.

    Here is link.

    Plugin and source code at bottom of page 4

    http://ubb.homeseer.com/showthread.p...light=joystick

    Leave a comment:


  • ldragon99
    replied
    anyone have this happen

    I love this plugin, and more importantly the wife loves it as well. We hav all doors windows and a bunch of other things on it. I have events setup that speak if a door or window is opened or closed based on the alarm status. However for some reson all events that function with calls from devices on gameport 3 stoped working. HS still shows the change with the device. Open or closed shows beside the device. but I cannot get hs to speak. It was working.

    Any ideas?

    Leave a comment:


  • Guest's Avatar
    Guest replied
    Electron.

    Are you the current author of the Gameport 2.7.0 plugin (I ask as the thread was originally started by Jebus).

    Anyway the reason I ask is that I was wondering what development is happening on this. I use the plugin for 2 gameports and it works great, however I have a small feature request. It would be nice if the plugin logged information to the Homeseer log so that we could see what actions are being triggered.

    For example I use the plugin to monitor 3 doors. I would like to be able to configure it so that whenever a door is opened or closed, the name associated with the device is logged to the log along with the configurable "on" and "off" values.

    What do you think ?

    Thanks

    Phill

    Leave a comment:


  • srodgers
    replied
    Can anyone else confirm if they also have this problem. I am trying to use the GUI to build an event that triggers from X,Y,Z, or R axix changes.

    Leave a comment:


  • srodgers
    replied
    How do I setup an event to trigger on changes in the Axis values? I see the Script examples to check for a value. Using Device Value Change or Device Status Change does not work. I am using the Gameport Plugin 2.7.0. I can see the GUI update when one of the axis change just want to use this as an event trigger.

    I have the buttons working fine. Thanks

    Leave a comment:


  • electron
    replied
    Kirk, I have the same issue with these ports disappearing etc, but I don't have any errors with the drivers, it works fine (except it confuses the joystick API which affects my program).

    Bruce, I am only using the 4 buttons right now (digital inputs?), as I am not too familiar with electronics and didn't feel like screwing around with that to get a few more buttons as I have 9 gameports right now.

    The OS thinks a joystick is there when certain pins are closed, so that part works fine, it's just that it will load the ports as a joystick, eventho there might not be ajoystick connected to it. This isn't a big deal, but when you reboot, these empty ports disappear, screwing up the gameport configuration. I still have to do some more research, worst case, follow smee's instructions (Eventho I would love to use the analog inputs too eventually).

    Leave a comment:


  • Guest's Avatar
    Guest replied
    Do you need to plug in a "dummy" joystick to make sure the ports are recognized? This was discussed (indirectly) in
    gameport thread

    The fake joystick is discussed here:

    fake joystick

    The fake joystick would replace your analog inputs. But if this is the reason Windows doesn't think you've got a joystick connected, this should be sufficient to allow you to recognize button presses.

    Leave a comment:


  • bruce l
    replied
    Sounds like the "drivers" are built into windows as it supports standard USB joysticks without extra drivers. I bet the OS checks for a joystick plug in before it allows any calls to that interface. Now to figure out how to force it to recognize a joystick on each port.

    Dan if I remember right to get 8 inputs you are using the 4 standard buttons and the 4 analog inputs. Have you noticed if it recognizes the ports with resistors on the analog inputs all the time and not the ones that are open ? That would be the most logical way to detect if a joystick was really plugged in.

    Maybe just rambling but something to think about.

    Leave a comment:


  • ldragon99
    replied
    I get five devices showing up, however only one works. and sometimes not at all. I have to plug in a joystick and restart, then one port works. I plug in my stuff and it works for a while then stops. I cannot get the other three working. the devce manages says that the drivers are not properly installed?

    Leave a comment:


  • electron
    replied
    The device doesn't require any drivers, eventho I ran into strange problems myself, both units on different machines. When I first plugged them in, each port showed up in the game control panel, even if there was no joystick plugged in (so 5 ports would show up, 1 onboard, 4 from the usb device), so my software would pick those up of course.

    But now for some strange reasons, only 1 shows up, the one that has a joystick plugged in (the way it should have been), but it is confusing the gameport software, I am trying to figure out what happened.

    Leave a comment:


  • ldragon99
    replied
    Sory I forgot to post.

    I did and that stoped the polling problem. However My system is not playing nice, the status does not change in HS. I think that it is my 4 port usb to gameport unit though. The systme says the drivers are not installed, however I have installed them about three times.

    Has anyone had this problem with the USB to Gameport device? Any fixes known. I am using windows 2000 pro.

    Leave a comment:


  • electron
    replied
    did you check "Update on status change only"?

    Leave a comment:

Working...
X