Announcement

Collapse
No announcement yet.

HS4 Device Changes Value But Actual Device Does Nothing

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    HS4 Device Changes Value But Actual Device Does Nothing

    I have a thermostat that I am (trying) to control via scripts. In my script I call hs.SetDeviceValueByRef(id, value, true). When I look at the HS4 thermostat device I can see that the value updated as expected. However, the value displayed on the screen of the physical thermostat has not changed. Interestingly, if I change the value through the HS4 thermostat device then the value on the screen of the physical thermostat changes. So the communication between HS4 and the physical thermostat works. But for some reason if I modify the HS4 thermostat then the physical thermostat doesn't get updated.

    #2
    Originally posted by mulu View Post
    I have a thermostat that I am (trying) to control via scripts. In my script I call hs.SetDeviceValueByRef(id, value, true). When I look at the HS4 thermostat device I can see that the value updated as expected. However, the value displayed on the screen of the physical thermostat has not changed. Interestingly, if I change the value through the HS4 thermostat device then the value on the screen of the physical thermostat changes. So the communication between HS4 and the physical thermostat works. But for some reason if I modify the HS4 thermostat then the physical thermostat doesn't get updated.
    That would be expected as SetDeviceValueByRef function only sets the value of the HS device, which is OK for a virtual device but not for a device that is representing a physical device owned by a plug-in. To control the physical device you use CAPI functions, the pi that owns the device will receive the command act on it and then if necessary change the HS device.

    Steve

    Comment


      #3
      To add to Steve's comment, you should try tenScriptAid. It will show you the proper CAPI commands.
      Don

      Comment


        #4
        SteveMSJ Thanks for the explanation.That makes sense now.

        Comment


          #5
          donstephens I downloaded the program but it crashes. Maybe it doesn't work with HS4?

          Click image for larger version

Name:	tenScriptAid.png
Views:	40
Size:	25.4 KB
ID:	1386483

          Comment


            #6
            Is it possible tenScriptingAid isn't aimed at the correct IP? Looks like it couldn't find HomeSeerAPI, which it needs.
            Don

            Comment


              #7
              Duh, I forgot to copy the dlls into the same directory. It works now. Wow!! This program is cool!!! I know I am going to love it!

              Comment

              Working...
              X