Announcement

Collapse
No announcement yet.

Modification History Discussion

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Modification History Discussion

    Any questions or thoughts, please post them here.
    -Tom

    Visit Kernhome
    Kern Theater Gallery

    (User: guest / Pass: guest)

  • #2
    Nice job as always Tom. Thanx.
    I just had to delete the WebWrapper code from the top and bottom of the code for it to work here. Already have 4 updates since installing it 10 minutes ago.
    Thanx.

    Comment


    • #3
      nice, simple and clean.... I like it... Impressive.

      I give it 4 stars....

      Comment


      • #4
        Many thanks for this great page.

        Jari

        Comment


        • #5
          Thanks guys.

          BTW, does anyone know how to set focus to the description field? Also, I can't seem to get AM or PM to show up in the date field. If you respone.write the value of sTime after line 49, you'll see that it's there. Why doesn't it show up in the default value of the textbox?
          -Tom

          Visit Kernhome
          Kern Theater Gallery

          (User: guest / Pass: guest)

          Comment


          • #6
            Tom,
            For the focus change this line :
            PHP Code:
            response.write "<BODY>" 
            to:
            PHP Code:
            response.write "<BODY onload=""document.ModHistory.MD.focus();"">" 
            Change this line :
            PHP Code:
            response.write "<td class='tablerowodd'>Modification Description<br><TEXTAREA NAME='Descr' ROWS=2 COLS=80></TEXTAREA></td>" 
            To:

            PHP Code:
            response.write "<td class='tablerowodd'>Modification Description<br><TEXTAREA NAME='Descr' ROWS=2 COLS=80 id=MD></TEXTAREA></td>" 
            For the AM/PM problem. You can not have a space in a value field change. Try this line. Note the inclusion of the ' :
            PHP Code:
            response.write "<td class='tablerowodd'>&nbsp;Date <INPUT TYPE='TEXT' NAME='Date' VALUE='" Date "&nbsp;&nbsp;" sTime "'></td>" 
            Last edited by Rupp; December 6th, 2004, 08:12 AM.
            -Rupp
            sigpic

            Comment


            • #7
              Rupp,

              The setfocus still does not seem to work though I added the id attribute. Can you take another peek and let me know? The fix for AM/PM works great. Thanks for that.

              Everyone,

              I failed to optimize for 1024x768, so I made a change in the width of the description field to accomodate. Download the latest or just change COLS=72 on line 56.
              -Tom

              Visit Kernhome
              Kern Theater Gallery

              (User: guest / Pass: guest)

              Comment


              • #8
                Tom, It working perfectly here. What browser are you using? I'm using IE.
                -Rupp
                sigpic

                Comment


                • #9
                  Rupp,

                  IE 6.0 sp2 at work and at home. Doesn't work for me either place. I wonder what the difference could be?

                  If I start typing, the text goes nowhere, so I know that its not that I can't see the cursor.
                  -Tom

                  Visit Kernhome
                  Kern Theater Gallery

                  (User: guest / Pass: guest)

                  Comment


                  • #10
                    What is this setfocus thing?

                    Jari

                    Comment


                    • #11
                      Jari,

                      It's no big deal really, but I would rather not have to click into the description field before typing. It would be nice for the cursor to be sitting there automatically. Rupp says the change he gave me is working for him so I don't know...have you got the latest? How does it react for you?
                      -Tom

                      Visit Kernhome
                      Kern Theater Gallery

                      (User: guest / Pass: guest)

                      Comment


                      • #12
                        Tom,

                        OK, thanks for the info. I haven't tried the focus thing.

                        Comment


                        • #13
                          Tom,

                          Focus doesn't seem to work for me either (using IE 6.0.2800.1106). It's not a big deal, the asp-page is really great.

                          Jari

                          Comment


                          • #14
                            Are you guys running the firewall of SP2? This may be preventing it. Also other popup blockers may block this as well. As soon as the page loads the cursor is blinking in the description field on my PC at work.
                            -Rupp
                            sigpic

                            Comment


                            • #15
                              Rupp,

                              I ran it from my automation server (which is still on SP1) and got the same result. There is a popup blocker on it , however, and I clicked allow popups from 2.3 but it didn't help.
                              -Tom

                              Visit Kernhome
                              Kern Theater Gallery

                              (User: guest / Pass: guest)

                              Comment

                              Working...
                              X