No announcement yet.

Run Rachio Zone for Less Than a Minute

  • Filter
  • Time
  • Show
Clear All
new posts

    Run Rachio Zone for Less Than a Minute

    I've been looking to run one of my zones to keep my dog out of my flowerbed by running my Rachio sprinkler. The challenge I have is the Rachio natively does not run a zone for less than a minute, and I want to run it for 10secs or so when my dog gets into the flowerbed.

    I've found this Perl script created by someone else that works perfectly, but not sure how to get it to work with my HS3-Pi controller. Any thoughts?

    Perl Script here:


    You can run the script from an event action.

    Use event action 'Run Another Program or Process'.
    Program to run is /usr/bin/perl
    Set the command parameters to the script name (followed parameters needed by the script, if any).

    Attached Files


      Thank you. I modified to this:

      I ran the event and nothing happened. So I putty'd into the HS and ran the command and it complained about the LWP:UserAgent. So I tried to update, but it didn't like that either...

      Any ideas?


        Install LWP::UserAgent on the Raspberry Pi via this command:
        sudo apt -y install libwww-perl
        Edit: it looks like you already tried this, but if failed? I can't really read the image you posted.


          Yep that's what I did, fails with the error:

          Err:1 stretch/main armhf libtimedate-perl all 2.3000-2
          404 Not Found [IP: 80]
          E: Failed to fetch 404 Not Found [IP: 80]
          E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?


            What OS is installed?
            more /etc/os-release
            Perhaps try
            sudo apt update
            and then retry the install


              Was running
              PRETTY_NAME="Raspbian GNU/Linux 9 (stretch)"
              NAME="Raspbian GNU/Linux"

              so I ran sudo apt update, then the perl update worked.

              I then tried the script again and then got this error:

              Can't locate in iNc

              So I ran: sudo perl -MCPAN -e 'install JSON'. Came across some warning along the way and accepted the risk it mentioned. Installed the rest just fine.

              Ran the script and it works. Thanks for the help