Announcement

Collapse
No announcement yet.

[SCRIPT] SpeakPhoneMessages

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • [SCRIPT] SpeakPhoneMessages

    dwoolridge,
    Thanks for sharing your SpeakPhoneMessages script. Just what I was looking for. For some reason, I can't get the script to speak my actual messages. I'm using the HSP 2.0.154. I have the following in the command line
    "SpeakPhoneMessages-DDW.txt("SpeakPhoneMessages", "[All]|[Play]|All")" minus the outer quotes. It does announce all of the messages, the time and the CID. It doesn't however play any message, whether it is a list message or from an outside call. Any ideas?

    Thanks,
    -Shane

  • #2
    Has anyone else tried this script or have any experience? dwoolridge, are you still around?

    -Shane

    Comment


    • #3
      SORRY!!

      I must've been a bit unobservant the past month or so. I never noticed that this Script Library Discussion group was created!! Thanks, Shane, for creating this discussion.


      Shane,
      Try removing the square brackets from your options:
      SpeakPhoneMessages-DDW.txt("SpeakPhoneMessages", "All|Play|All")

      I was using the square brackets to indicate a set of options. I can understand how it could be confusing.

      Comment


      • #4
        Link to the script...

        Link to the script

        Comment


        • #5
          I just installed HS Phone (latest release) and a HS Modem. I want to be able to play messages upon deactivation of the alarm system. i have an event to do that but needed this script for the message part.

          I am using the following command line:
          SpeakPhoneMessages-DDW.txt("SpeakPhoneMessages", "All|Play|All")
          And I get method "~' of object "~" failed when I manually execute this script to test.

          Can you help?

          Comment


          • #6
            I have been using this script for ages now, one of my most used too.. just checked my setup and I only have "SpeakPhoneMessages-DDW.txt" . I use NO other options, the script defaults to playing NEW messages only.

            In my setup I have the script called when the house has been set to unoccupied, then the outside sensor is ON and the porch sensor changes to ON and the hall sensor is ON, ie, Im coming in... i also have a messages left flag which has to be set to on by an incoming message.

            Try the script without the options.. it may be what you want.

            TrOjAn

            Comment


            • #7
              Thanks, I was able to get it to run by using "main" last night so I will try your method today. As long as it reads the message I will be Ok, the main method just tells you about the messages.

              Comment


              • #8
                Kevingib,

                Do you also have the file "VoicemailIncludes-DDW.txt" in your script directory? This file has several functions used by the SpeakPhoneMessages subroutine.

                This file is available in the zip file for the SpeakPhoneMessages-DDW script.

                Hope this helps!

                --Doug

                Comment


                • #9
                  I had all of the files. The issue was the variables, if I ran it using "main" it worked so I am simply executing the script with no variables and I modified the defaults to match what I needed.

                  Thanks

                  Comment


                  • #10
                    Kevingib,

                    I copied the command listed in your previous message...
                    SpeakPhoneMessages-DDW.txt("SpeakPhoneMessages", "All|Play|All")

                    ...into the script for a new event and it ran fine (it read through about 50 old messages---time to clean out the mailbox!). I don't seem to be able to duplicate your problem. But if there is an issue with my script, I'd like to get it fixed.

                    Are you using the latest version of both scripts (v0.4)? Otherwise, I'm out of ideas on this one.

                    --Doug

                    Comment


                    • #11
                      I am running the latest scripts with the latest HSP version. Just calling the script name by itself and changing the defauts in the script got it working fine for me...

                      Comment


                      • #12
                        Getting error

                        I am getting the following error after my change to hsp2:

                        8/14/2005 9:39:47 PM - Error - Running script, script run or compile error in file: SpeakPhoneMessages-DDW.txt13:Type mismatch: 'Temp2(...)' in line 312 More info: Type mismatch: 'Temp2(...)'

                        The thing that confuses my is there is no line 312

                        anyone else getting this? Any ideas what it is
                        Kirk

                        http://cleverhouseautomation.ca
                        http://southcoastwebsitedesign.ca

                        Comment


                        • #13
                          I am getting that error.

                          Anyone?

                          Comment


                          • #14
                            No response

                            I have had no luck with this yet. I think that is a language thing. Peoples attention are on hs2 right now by the looks of it. If anyone has any ideas, please jump in
                            Kirk

                            http://cleverhouseautomation.ca
                            http://southcoastwebsitedesign.ca

                            Comment


                            • #15
                              I think this stopped working in HS2.. or are you still running hs1?

                              Comment

                              Working...
                              X