Announcement

Collapse
No announcement yet.

Speak CNN Breaking News

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Speak CNN Breaking News

    Sorry if this has been repeated..

    Can't seem to get my CNN Breaking news to announce ..
    It writes to my virtual devices fine and even get the emails
    I've got the ini file set to announce, speak, etc-
    Tried the "Speak","Main" syntax as well when calling the script..

    Had it working awhile ago -

  • #2
    Mine not working either under 2.0

    You guys will probably hear from me a lot as I get 2.0 running!
    Latest problem seems to be Breaking News announce:
    1/21/2006 4:17:33 PM CNNAlerts [debug] breaking news detected
    1/21/2006 4:17:33 PM CNNAlerts [debug] [variable:strOldAlert][No Breaking News]
    1/21/2006 4:17:33 PM CNNAlerts [debug] breaking news:[The script is now running in test mode. This is a CNN breaking news test alert]
    1/21/2006 4:17:33 PM CNNAlerts [debug] email notification has been sent
    1/21/2006 4:17:33 PM CNNAlerts [debug] updating virtualdevice string with the news alert
    1/21/2006 4:17:33 PM CNNAlerts [debug] turning virtualdevice ON
    It will not speak it even though it is set to. Same thing happening with my Weather Alerts. I know TTS is working thru my other events, but neither of these will fire. Any thoughts anyone?

    Comment


    • #3
      Do you see a speak line in the HS log?
      -Rupp
      sigpic

      Comment


      • #4
        No Sir Rupp!
        Which is particularly puzzling. I have re-run the ini settings, tested tts to make sure it works, and tried everything I can think of except de-re installing. That's the debug log above.
        Here's a dumb question - Is the Media Player plug-in required for HS2 to play wav files and do tts?

        Comment


        • #5
          I wonder if the script is supposed to speak in the debug mode? There are no lines that indicate that is should it the previous post.
          -Rupp
          sigpic

          Comment


          • #6
            I'm not sure about that either. I DO know all other functions, including sending a page to Audrey do work. I kind of figured it parses the test message to speak out since it does it everywhere else.

            Comment


            • #7
              I fired up my old machine with 1.7 and tested it, and it does announce and play the wave when in test mode. Not sure what to do now.

              Comment


              • #8
                Al,
                Post the version of the script that you have and I'll have a look.
                -Rupp
                sigpic

                Comment


                • #9
                  Thanks Rupp,
                  Here it is. It's the same one I'm using with 1.7.
                  Attached Files

                  Comment


                  • #10
                    Al,
                    I'm not sure what happened but the script you posted doesn't have any quotes around variables at all so it fails miserable. Do you have a link to the original.
                    -Rupp
                    sigpic

                    Comment


                    • #11
                      I inadvertently stripped all special characters when I copied it. OOPS. Try this one.
                      Attached Files

                      Comment


                      • #12
                        I have also discovered I cannot seem to upload wav files from HS2. I tried to create an event to play the cnn wave file that was manually fired and when I go to upload I get a page of gibberish. I have tried a repair of HS2, as well as a Media Player update. TTS does work properly from other events.

                        Comment


                        • #13
                          Ah Ha. This is a known problem with HS version 2041
                          -Rupp
                          sigpic

                          Comment


                          • #14
                            I just saw that searching the board.

                            So I changed the play wave file to False in the CNN ini settings, thinking maybe that was mucking up the tts part. No joy yet.

                            Comment


                            • #15
                              Here's my debug log:
                              Still not announcing or playing the wav file.

                              1/25/2006 6:58:44 PM Info Event Trigger "CNN Breaking News"
                              1/25/2006 6:58:44 PM Info Running script in background: custom_cnn.txt("main","debug")
                              1/25/2006 6:58:44 PM CNNAlerts [debug] [variable:strIniFileName] CNNsettings.ini
                              1/25/2006 6:58:44 PM CNNAlerts [debug] [variable:bEdit] False
                              1/25/2006 6:58:44 PM CNNAlerts [debug] [variable:virtualdevice] v12
                              1/25/2006 6:58:44 PM CNNAlerts [debug] [variable:speak] True
                              1/25/2006 6:58:44 PM CNNAlerts [debug] [variable:announceschedule] 08:00--20:00
                              1/25/2006 6:58:44 PM CNNAlerts [debug] [variablelaywav] True
                              1/25/2006 6:58:44 PM CNNAlerts [debug] [variable:wavfile] c:\Program Files\HomeSeer 2\cnn.wav
                              1/25/2006 6:58:44 PM CNNAlerts [debug] [variable:notify] True
                              1/25/2006 6:58:44 PM CNNAlerts [debug] [variable:notifyschedule] 08:00-20:00
                              1/25/2006 6:58:44 PM CNNAlerts [debug] [variable:subject] CNN News Alert
                              1/25/2006 6:58:44 PM CNNAlerts [debug] [variable:TOaddress] alconnell@adelphia.net
                              1/25/2006 6:58:44 PM CNNAlerts [debug] [variable:FROMaddress] alconnell@adelphia.net
                              1/25/2006 6:58:44 PM CNNAlerts [debug] [variable:turnoff] True
                              1/25/2006 6:58:44 PM CNNAlerts [debug] [variable:newsicon]
                              1/25/2006 6:58:44 PM CNNAlerts [debug] [variable:iDaysToKeep] 7
                              1/25/2006 6:58:44 PM CNNAlerts [debug] [variable:strTriggerEvents]
                              1/25/2006 6:58:44 PM CNNAlerts [debug] retrieving http://www.cnn.com/.element/ssi/www/...r.exclude.html
                              1/25/2006 6:58:44 PM CNNAlerts [debug] html data:
                              1/25/2006 6:58:44 PM CNNAlerts [debug] no breaking news has been detected

                              Comment

                              Working...
                              X