Announcement

Collapse
No announcement yet.

A slight error

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • A slight error

    Jon,

    This package is great! I really love it.

    I have one small error occurring - which doesn't cause a problem but thought you would want to know.

    When i call up a mailbox in the main page, there is a non destructive script error on line 53 in both readmail1.ash and readmail2.ash.

    Line 53 Char 1
    Error: Object expected
    Code 0
    URL: http://.../Readmail1.ash

    As it happens there are no mails in the mail box - maybe thats the problem?

    Anyway - thanks acellent effort.

    Regards

  • #2
    Ron,

    I found this post by accident - looks like you used new post rather than reply to post!

    Anyway, thanks for the feedback. I have not seen that error before nor has anyone else reported this. What browser are you using to view this? If it is not IE, can you try it with that browser. Also what version of Homeseer/windows are you using?
    Jon

    Comment


    • #3
      Thanks for the reply Jon..

      There are now entries in the mailbox but I still get the error.

      I am on HS 2041, using IE on Windows XP SP2.

      As I said, this reports as the innocuous "Errors on Page" and doesn't appear to affect anything - though reading a mail can take forever to load.

      This also happens no matter where I log on from.

      Regards
      Ron

      Comment


      • #4
        Ron,

        This does not sound right to me. Do you have another PC on your network you can connect to your Homeseer server and bring the page up on that?
        Jon

        Comment


        • #5
          Yep,

          Page comes up fine - but there is still that little yellow triangle in the bottom left corner of the browser which reports "Errors on page"

          It's always the same error on line 53 Char 1

          This honestly isn't a big deal Jon - the package seems to run fine.

          Regards

          Comment


          • #6
            Thanks for the feedback on this. Although I do not see this on any of my machines, I suspect it is a Java issue. With this new version, I added some java script to the < head > which relates to the message display size.

            Could you both confirm which Java installation you have. i.e. do you see a coffee cup in the system tray (Sun Java) when Java applets are running or nothing at all (Microsoft implementation)?
            Jon

            Comment


            • #7
              No coffee cup here - they are all Microsoft.

              Comment


              • #8
                Just in case you have subscribed to this thread, I have posed a fix at http://board.homeseer.com/showpost.p...5&postcount=71
                Jon

                Comment


                • #9
                  Frank,

                  I cannot see how the change I did could cause that problem (1 line in the html code).

                  That message should only appear if the mailbox is disabled in the checkpop.ini file.

                  Reinstall the readmailX.ash pages

                  Under [Data] in the checkpop.ini file, make sure all of the following are set to 0

                  DisableMB1=0
                  DisableMB2=0
                  etc
                  Jon

                  Comment


                  • #10
                    Hold on... the only other thing is that you may still be on the beta. You will need to d/l the release version as I did make a few more changes including this disable function.
                    Jon

                    Comment

                    Working...
                    X