Announcement

Collapse
No announcement yet.

Wunderground Script (Weather) Version 1.00 Discussion

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    #16
    This is not my web site. If you go to wunderground.com enter your zip and scroll to the bottom you should have hopefully several personnel weather stations to chose from. I had five and two of them had this new feature.
    I've been looking for something new to show my local weather and ran across this. Yes the backgrounds change when you reload the page. It works fine for me in FF and in IE at work but then I brought up IE at home and have the same problem as you.
    Then I saw this at the bottom of the weather station page and now it also loads on IE at home.

    Having trouble displaying weather station data?
    You may need to upgrade your browser's Flash plug-in to version
    ( the link for the upgrade is on the Wunderground page)
    John

    Comment


      #17
      Originally posted by d-smes
      John,
      On FF I was missing all the detail in the buttons and wind direction compass (I only know what this "should" have been because I've been trying to capture it in my web pages forever). When I fired up IE, the buttons and frames still don't fill in with background data. Speaking of backgrounds, they were different in both windows... one was clouds below and above and the other was of a sunset. Is this your page or Wunderground's doing? Oh... the graph part does work; just no units or scale.
      The image changes with nearly every view.
      -Rupp
      sigpic

      Comment


        #18
        Just came accross your script.

        Is it possible to get this script to work with the Global weather?

        In the ini file it asks for the city code, in the global display you only have a number in the address bar, ie: for myself it is 03160.
        sigpic
        A founder member of "The HA Pioneer Group" otherwise known as the "Old farts club!"

        Comment


          #19
          Originally posted by Gogs View Post
          Just came accross your script.

          Is it possible to get this script to work with the Global weather?

          In the ini file it asks for the city code, in the global display you only have a number in the address bar, ie: for myself it is 03160.
          Unfortunately I just dont have the time to work on re-writing for global weather service. Feel free to re-code as necessary on your own though...
          HS 3.0.0.199 Pro/Insteon 3.0.5.20/3 Venstar Insteon Therms / Insteon Thermostat 3.0.2.2 / DirecTV 3.0.0.14 / OpenSprinkler 2.0.5.21 / ITunes DAAP 3.0.0.23/ UltraM1G3 3.0.5437.37424/ UltraWeatherbug3 /HSTouch Svr 3.0.0.68/Zwave 3.0.1.25/Ultramon3/Global Cache 5.0.0.17/Various BLXXX Plugins.

          Comment


            #20
            johnnybwis,

            Thanks for the tip about the graphics under personal stations. I used the URL address in the Maestro Awareness Module to bring the data in as a Camera.

            Thanks,
            Dave
            Attached Files

            Comment


              #21
              Nice work Dave. How did you get it to size correctly?

              Comment


                #22
                It is a swf file (flash movie) so it resized itself.

                Here is the URL I am using for Cedar Park, TX:
                http://www.wunderground.com/swf/Rapi...tion=KTXCEDAR4

                You can find out the right URL for your area by doing the following:
                Go to Wunderground.com
                Select Personal Weather stations
                Select your state from the dropdown
                Press View by State
                Find the location closest to you and select its link (some locations may not have images)
                Beneath the image will be HTML to embed the image in a webpage
                Just copy the portion in quotes following Value= (It will start with http://)
                Use that URL as the your Maestro custom camera URL

                Let me know if you have any questions.

                Thanks,
                Dave

                Comment


                  #23
                  I just started getting this error lately.
                  !~Error~!~Running script, script run or compile error in file: wunderground.txt5:Invalid procedure call or argument: 'mid' in line 13 More info: Invalid procedure call or argument: 'mid'

                  Have any idea why?
                  Thanks
                  Tim

                  EDIT- aw never mind they changed the location code from KIASPIRI2 to KIASPIRI1
                  FB Page - https://www.facebook.com/pages/Capt-Tim/209398425902188

                  HSTouch Layouts - https://www.facebook.com/media/set/?...5902188&type=3

                  Comment


                    #24
                    Originally posted by fungun View Post
                    I just started getting this error lately.
                    !~Error~!~Running script, script run or compile error in file: wunderground.txt5:Invalid procedure call or argument: 'mid' in line 13 More info: Invalid procedure call or argument: 'mid'

                    Have any idea why?
                    Thanks
                    Tim

                    EDIT- aw never mind they changed the location code from KIASPIRI2 to KIASPIRI1
                    This is likely caused because the data file downloaded from wunderground does not containing any data. Check wunderground website using the id that you have supplied to see if the weather station is valid and reporting results. If not available, you will need to select an alternative weather station code for the plugin to use.

                    -Toby
                    HS 3.0.0.199 Pro/Insteon 3.0.5.20/3 Venstar Insteon Therms / Insteon Thermostat 3.0.2.2 / DirecTV 3.0.0.14 / OpenSprinkler 2.0.5.21 / ITunes DAAP 3.0.0.23/ UltraM1G3 3.0.5437.37424/ UltraWeatherbug3 /HSTouch Svr 3.0.0.68/Zwave 3.0.1.25/Ultramon3/Global Cache 5.0.0.17/Various BLXXX Plugins.

                    Comment


                      #25
                      Same Problem

                      I am having the same problem. I just cant find where I find the information for these slots.
                      <TABLE><TBODY><TR class=tablerowodd><TD>Location Code</TD><TD><INPUT class=formtext size=25 value=KPKB name=CodeArea></TD></TR><TR class=tableroweven><TD>PartnerID</TD><TD><INPUT class=formtext size=25 name=PartnerID></TD></TR><TR class=tablerowodd><TD>License</TD><TD><INPUT class=formtext size=25 name=License></TD></TR></TBODY></TABLE>
                      KPKB, for Parkersburg WV 26101. This is all I have entered, and I get the error. Could someone give me some help with this? Thanks for any help, looks like a great script.
                      Dan
                      danielbo

                      Comment


                        #26
                        Originally posted by danielbo View Post
                        I am having the same problem. I just cant find where I find the information for these slots.
                        <TABLE><TBODY><TR class=tablerowodd><TD>Location Code</TD><TD><INPUT class=formtext size=25 value=KPKB name=CodeArea></TD></TR><TR class=tableroweven><TD>PartnerID</TD><TD><INPUT class=formtext size=25 name=PartnerID></TD></TR><TR class=tablerowodd><TD>License</TD><TD><INPUT class=formtext size=25 name=License></TD></TR></TBODY></TABLE>
                        KPKB, for Parkersburg WV 26101. This is all I have entered, and I get the error. Could someone give me some help with this? Thanks for any help, looks like a great script.
                        Dan

                        seems like weather.com... you need to register and get all your info that they will provide you about your location...
                        HW - i5 4570T @2.9ghz runs @11w | 8gb ram | 128gb ssd OS - Win10 x64

                        HS - HS3 Pro Edition 3.0.0.435

                        Plugins - BLRF 2.0.94.0 | Concord 4 3.1.13.10 | HSBuddy 3.9.605.5 | HSTouch Server 3.0.0.68 | RFXCOM 30.0.0.36 | X10 3.0.0.36 | Z-Wave 3.0.1.190

                        Hardware - EdgePort/4 DB9 Serial | RFXCOM 433MHz USB Transceiver | Superbus 2000 for Concord 4 | TI103 X-10 Interface | WGL Designs W800 RF | Z-Net Z-Wave Interface

                        Comment


                          #27
                          I sent them a trouble ticket about it and waiting for an answer. I am registered with wunderground weather and looked all over for this information and even did searches of the web site and no luck. So I will see what the trouble ticket does. I cant believe no one else has had he problem or give ideas on where you find the answers you need.
                          Well we will see what happens with the trouble ticket and share my information with others.
                          danielbo

                          Comment


                            #28
                            You guys do realize this is the wunderground plugin, not the weatherxml plugin right? Maybe you're posting in the wrong thread...

                            You dont need to register anything to access wunderground stations. You can pull the weather station id info right off the url for the station...

                            Here's all stations for WV:

                            http://www.wunderground.com/weathers...=United+States

                            The station id goes in the plugin config... (See instructions earlier in thread for how to use it).
                            HS 3.0.0.199 Pro/Insteon 3.0.5.20/3 Venstar Insteon Therms / Insteon Thermostat 3.0.2.2 / DirecTV 3.0.0.14 / OpenSprinkler 2.0.5.21 / ITunes DAAP 3.0.0.23/ UltraM1G3 3.0.5437.37424/ UltraWeatherbug3 /HSTouch Svr 3.0.0.68/Zwave 3.0.1.25/Ultramon3/Global Cache 5.0.0.17/Various BLXXX Plugins.

                            Comment


                              #29
                              receiving error

                              Hi,

                              This script was working until sometime last evening and the log entry shows this:
                              Running script, script run or compile error in file: wunderground.asp5:Invalid procedure call or argument: 'instrRev' in line 11 More info: Invalid procedure call or argument: 'instrRev'

                              Any ideas?

                              Thx

                              Comment


                                #30
                                Same error script run or compile error 'instrRev' line 11

                                I am getting the same error.

                                8/21/2008 7:52:25 PM - Error - Running script, script run or compile error in file: wunderground.asp5:Invalid procedure call or argument: 'instrRev' in line 11 More info: Invalid procedure call or argument: 'instrRev'

                                Any ideas?

                                Comment

                                Working...
                                X