Announcement

Collapse
No announcement yet.

VonageInfo Dashboard Scraper

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • #46
    Matrix,

    I missed your response
    I am using v1.0.4 of the script and have added the following to my settings.ini file:

    ScriptingReferences=System.Web;System.Web.dll,System.Data;Sy stem.Data.dll


    I am running v2.2.0.11 of Homeseer. Any Ideas?


    Thanks

    Comment


    • #47
      Madmax,

      I'll upgrade to HS 2.2.0.11 and attempt to replicate the problem.

      It may also help to have your vonageinfo.ini file (from the config folder). Can you post or send it to me. You'll want to edit out your personal info like the username, passwd and phone number in the file before sending it. You may send it to ps_busterNOSPAM@yahoo.com (remove the NOSPAM) or post it here.

      -Phil

      Comment


      • #48
        Could someone please tell me how I enable and disable call forward.
        Thanks,
        Bob M.

        Comment


        • #49
          You can call vonageinfo.vb from a script action and put the following in the optional parameters line:

          ("SetCallFwd","true;5;true;1360XXXXXXX") for forward

          and use a second parameter of "false" to set back to normal

          -Rob

          Comment


          • #50
            And if you are using the multi-line beta version 1.0.4, then the optional parameters would include the phone number that you want to enable/disable call forwarding for (say it was 18005552222):

            ("SetCallFwd","18005552222;true;5;true;1360XXXXXXX")

            or this to disable:

            ("SetCallFwd","18005552222;false;;;")

            Enjoy,
            Phil

            Comment


            • #51
              Thanks guys, that worked very nice. Is there a DND optional.
              Bob M.

              Comment


              • #52
                The Vonage web page for Do Not Disturb appears to be quite similar to the Call Waiting web page so it may not be too tough to add this in.

                I'll see about adding it as a new feature.

                -Phil

                Comment


                • #53
                  Thanks!

                  Comment


                  • #54
                    Attached Files
                    Last edited by Simonk; August 12th, 2008, 06:43 AM.

                    Comment


                    • #55
                      Simon,

                      I'm not having any issues with the billing info here in the states. I'd bet that there is something different about the web page in the UK that it's having an issue with. To solve this, I'd need to see the source behind the page. Using your browser, can you use the View->Source menu item while on the Vonage billing page, save this to a file and send it to me at ps_busterNOSPAM@yahoo.com (remove the NOSPAM). You'll want to search/replace your account number, phone number and name before you send it.

                      Once I have this, I should be able to see what is going on.

                      Thanks,
                      Phil

                      Comment


                      • #56
                        Still working?

                        Anyone still using this script? My updates (in the USA) stopped a few weeks ago. I've attached the errors that are logged.

                        Thanks
                        Owen
                        Attached Files

                        Comment


                        • #57
                          Aggh! Help please lots of red writing.

                          Hi all, I have installed the vonage script but cannot get it to work, something to do with cookies I think, I am sure that some else has had this problem and knows just how to fix it, alas not me. Any help would be greatly appreciated. This is version 1.0.4, version 1.0.1 only gave me something similar to the first line.
                          Here is the log extract. Thanks in advance Peter

                          <table border="0" cellpadding="0" cellspacing="2" width="100%"><tbody><tr><td colspan="8" class="LOGEntry1" align="left">Running script in background: vonageinfo.vb</td></tr> <tr> <td colspan="1" class="LOGDateTime0" align="left" nowrap="nowrap">14/12/2012 19:01:03 </td><td colspan="3" class="LOGType0" align="left"> VonageInfo Error </td><td colspan="8" class="LOGEntry0" align="left">GetCookies::Error while retrieving cookies: System.Net.WebException: The underlying connection was closed: Could not establish trust relationship for the SSL/TLS secure channel. ---> System.Security.Authentication.AuthenticationException: The remote certificate is invalid according to the validation procedure. at System.Net.Security.SslState.StartSendAuthResetSignal(Protoc olToken message, AsyncProtocolRequest asyncRequest, Exception exception) at System.Net.Security.SslState.CheckCompletionBeforeNextReceiv e(ProtocolToken message, AsyncProtocolRequest asyncRequest) at System.Net.Security.SslState.StartSendBlob(Byte[] incoming, Int32 count, AsyncProtocolRequest asyncRequest) at System.Net.Security.SslState.ProcessReceivedBlob(Byte[] buffer, Int32 count, AsyncProtocolRequest asyncRequest) at System.Net.Security.SslState.StartReadFrame(Byte[] buffer, Int32 readBytes, AsyncProtocolRequest asyncRequest) at System.Net.Security.SslState.StartReceiveBlob(Byte[] buffer, AsyncProtocolRequest asyncRequest) at System.Net.Security.SslState.CheckCompletionBeforeNextReceiv e(ProtocolToken message, AsyncProtocolRequest asyncRequest) at System.Net.Security.SslState.StartSendBlob(Byte[] incoming, Int32 count, AsyncProtocolRequest asyncRequest) at System.Net.Security.SslState.ProcessReceivedBlob(Byte[] buffer, Int32 count, AsyncProtocolRequest asyncRequest) at System.Net.Security.SslState.StartReadFrame(Byte[] buffer, Int32 readBytes, AsyncProtocolRequest asyncRequest) at System.Net.Security.SslState.StartReceiveBlob(Byte[] buffer, AsyncProtocolRequest asyncRequest) at System.Net.Security.SslState.CheckCompletionBeforeNextReceiv e(ProtocolToken message, AsyncProtocolRequest asyncRequest) at System.Net.Security.SslState.StartSendBlob(Byte[] incoming, Int32 count, AsyncProtocolRequest asyncRequest) at System.Net.Security.SslState.ProcessReceivedBlob(Byte[] buffer, Int32 count, AsyncProtocolRequest asyncRequest) at System.Net.Security.SslState.StartReadFrame(Byte[] buffer, Int32 readBytes, AsyncProtocolRequest asyncRequest) at System.Net.Security.SslState.StartReceiveBlob(Byte[] buffer, AsyncProtocolRequest asyncRequest) at System.Net.Security.SslState.CheckCompletionBeforeNextReceiv e(ProtocolToken message, AsyncProtocolRequest asyncRequest) at System.Net.Security.SslState.StartSendBlob(Byte[] incoming, Int32 count, AsyncProtocolRequest asyncRequest) at System.Net.Security.SslState.ForceAuthentication(Boolean receiveFirst, Byte[] buffer, AsyncProtocolRequest asyncRequest) at System.Net.Security.SslState.ProcessAuthentication(LazyAsync Result lazyResult) at System.Net.TlsStream.CallProcessAuthentication(Object state) at System.Threading.ExecutionContext.runTryCode(Object userData) at System.Runtime.CompilerServices.RuntimeHelpers.ExecuteCodeWi thGuaranteedCleanup(TryCode code, CleanupCode backoutCode, Object userData) at System.Threading.ExecutionContext.RunInternal(ExecutionConte xt executionContext, ContextCallback callback, Object state) at System.Threading.ExecutionContext.Run(ExecutionContext executionContext, ContextCallback callback, Object state) at System.Net.TlsStream.ProcessAuthentication(LazyAsyncResult result) at System.Net.TlsStream.Write(Byte[] buffer, Int32 offset, Int32 size) at System.Net.PooledStream.Write(Byte[] buffer, Int32 offset, Int32 size) at System.Net.ConnectStream.WriteHeaders(Boolean async) --- End of inner exception stack trace --- at System.Net.HttpWebRequest.GetResponse() at scriptcode3.scriptcode3.GetCookies(String url)



                          </td></tr> </tbody></table>

                          Comment


                          • #58
                            Still waiting for somebody!

                            Well I did think that someone would give me little help with this but I would gues not as no replies! Peter

                            Comment


                            • #59
                              Last update to this script was 6 years ago. I will guarantee Vonage has changed their webpage format since then thus this is a dead project.


                              ~Bill

                              Comment

                              Working...
                              X