Announcement

Collapse
No announcement yet.

BackeRupp Question

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    BackeRupp Question

    I created a backup set and ran it. Worked great. (like I would have expected any less from the Rupp man!)

    However, after that I thought it would be better to have the executable in its own directory, it was in the root HS directory. I moved it and the named ini file for my backup to its own directory under HS. Will that cause any problems? I figured as long as the ini is in the same directory as the exe and the event referenced the right path it would work? Yes/no/maybe?

    Great script, and thanks.
    Later, Terry

    #2
    Tman, thanks for posting this question. I down loaded the zip to my desktop, but I dont really known how to install it and now that you stated about the location of the file, this puts me in a black hole. Can somebody explain what is the correct way of doing this? I appreciate simple terms. thanks
    Hector
    ____________________________________
    Win.2003 OS, HS3
    BLDSC,BLstat,BLRadar,BLRamdom,BLOccupied
    BLups,BLrain8,HSTouch,Ultrajones Weatherbug,
    MyTrigger,ACRF2,W800,Zwave
    AP800,Honeywell Stat

    Comment


      #3
      Originally posted by tman1 View Post
      I created a backup set and ran it. Worked great. (like I would have expected any less from the Rupp man!)

      However, after that I thought it would be better to have the executable in its own directory, it was in the root HS directory. I moved it and the named ini file for my backup to its own directory under HS. Will that cause any problems? I figured as long as the ini is in the same directory as the exe and the event referenced the right path it would work? Yes/no/maybe?

      Great script, and thanks.
      Later, Terry
      You need to insure that the BackupSetName.txt file and all .ini's were moved. So for each entry in the BackupSetName.txt file you should have a like named .ini file.
      -Rupp
      sigpic

      Comment


        #4
        That's what I thought (and did), Thanks Sir.

        Comment


          #5
          Originally posted by Rotech View Post
          Tman, thanks for posting this question. I down loaded the zip to my desktop, but I dont really known how to install it and now that you stated about the location of the file, this puts me in a black hole. Can somebody explain what is the correct way of doing this? I appreciate simple terms. thanks
          Create a new directory ie c:\Program Files\BackeRupp
          Copy the contents of the Zip file to this directory and then have a look at the .doc file. It explains how to use the .exe
          -Rupp
          sigpic

          Comment


            #6
            Guys,
            Are you seeing a "greenish" background on your .exe?
            -Rupp
            sigpic

            Comment


              #7
              Rotech, lets see if I can pay it forward.

              I followed the directions in Rupp's docs that came with the zip file.

              Create a directory under HomeSeer 2 called BackeRupp.
              Place the BackeRupp.exe there.
              If you have not created a backup set it will place the Ini file that will be created when you run the BackeRupp file for the first time by double clicking it from the dir you place it in.
              If you already created a backup set file it will end with .ini, place it in the same directory you put the Exe file in.
              As per the doc in the zip file put the dll file in the \windows\system32 directory of your HomeSeer server machine.
              I put the doc file in the regular directory in HomeSeer2 for docs. Typically \HomeSeer2\docs directory.

              Hope that helps, Later Terry

              oops looks like fleet fingered Rupp beat me to it.
              Last edited by tman1; February 18, 2008, 10:00 PM. Reason: The man is quick.

              Comment


                #8
                Yup, a big 10-4 on the green background.

                (Oops Sorry, channeling my CB days)

                Thanks again, Later
                Terry

                Comment


                  #9
                  guys, I still dont understand how you do this, can you clarify some more please...
                  Hector
                  ____________________________________
                  Win.2003 OS, HS3
                  BLDSC,BLstat,BLRadar,BLRamdom,BLOccupied
                  BLups,BLrain8,HSTouch,Ultrajones Weatherbug,
                  MyTrigger,ACRF2,W800,Zwave
                  AP800,Honeywell Stat

                  Comment


                    #10
                    Originally posted by Rotech View Post
                    guys, I still don't understand how you do this, can you clarify some more please...
                    I would suggest you run BackeRupp from the Crive, or whatever you call it, not from within the HS directory, or it will try and backup itself which can lead to interesting results.

                    If you are backing up to a different computer Map the connection.

                    Do not hold back when backing up HS, just back up the whole directory.

                    If you are still having problems try a manual backup which you have to do anyway to set the directories, paths etc.
                    sigpic
                    A founder member of "The HA Pioneer Group" otherwise known as the "Old farts club!"
                    HomeSeer 3 V 3.0.0.318 with ALEXA (AKA Amazon Echo)
                    BL Radar V2.0.217; BLRF V2.0.85.0; HS Touch V3.0.0.1034 X10 V3.0.0.42; PHLocation V3.0.0.38; Zwave V3.0.1.110; X10 V3.0.0.42
                    BLBackup V2.0.39;ImperiHome3.0.0.20 All on Windows XP Pro

                    Comment


                      #11
                      How long does it take?

                      Rupp

                      I think I installed it rigth, but I got a question. When I first hit the "go" button on the green page, it starts saying in the bottom of the page "adding...." and a file name. But It got to a point where it stopped at a file named Blicon and it just sits there, is this normal, Ive waited around 5 min. is this normal?
                      Hector
                      ____________________________________
                      Win.2003 OS, HS3
                      BLDSC,BLstat,BLRadar,BLRamdom,BLOccupied
                      BLups,BLrain8,HSTouch,Ultrajones Weatherbug,
                      MyTrigger,ACRF2,W800,Zwave
                      AP800,Honeywell Stat

                      Comment


                        #12
                        Rupp

                        disregard, it finished backing up,I think depending on the size of your data it will take a while.But just to make sure, how do I verify if it did it correctly? and also I would like to known your advice about what files should be backup and the frequency it should be done. thank you.
                        Hector
                        ____________________________________
                        Win.2003 OS, HS3
                        BLDSC,BLstat,BLRadar,BLRamdom,BLOccupied
                        BLups,BLrain8,HSTouch,Ultrajones Weatherbug,
                        MyTrigger,ACRF2,W800,Zwave
                        AP800,Honeywell Stat

                        Comment


                          #13
                          Yes it takes a while. I backup my entire HomeSeer folder every night as well as a few other folders and it takes about 45 minutes.

                          As far as verification. Just open the zip file and have a look. Try opening a few of the files in the zip file and ensure they are ok.
                          -Rupp
                          sigpic

                          Comment


                            #14
                            Rupp

                            I opened up the zip file and it seems that everthing there, I will try the files Later. But now I have a diferent problem. I created a event as per the instruccions but I get this error:

                            2/25/2008 9:17:21 PM - Info - Event Trigger "Automatic backup"
                            2/25/2008 9:17:21 PM - Error - Launching application: The system cannot find the file specified
                            2/25/2008 9:17:21 PM - Error - (continued) File name: "C:\VB\BackeRupp\BackeRupp.exe", Params: "Homeseer Backup"
                            Hector
                            ____________________________________
                            Win.2003 OS, HS3
                            BLDSC,BLstat,BLRadar,BLRamdom,BLOccupied
                            BLups,BLrain8,HSTouch,Ultrajones Weatherbug,
                            MyTrigger,ACRF2,W800,Zwave
                            AP800,Honeywell Stat

                            Comment


                              #15
                              Originally posted by Rotech View Post
                              Rupp

                              I opened up the zip file and it seems that everthing there, I will try the files Later. But now I have a diferent problem. I created a event as per the instruccions but I get this error:

                              2/25/2008 9:17:21 PM - Info - Event Trigger "Automatic backup"
                              2/25/2008 9:17:21 PM - Error - Launching application: The system cannot find the file specified
                              2/25/2008 9:17:21 PM - Error - (continued) File name: "C:\VB\BackeRupp\BackeRupp.exe", Params: "Homeseer Backup"
                              Rupp, have any idea what aim doing wrong?
                              Hector
                              ____________________________________
                              Win.2003 OS, HS3
                              BLDSC,BLstat,BLRadar,BLRamdom,BLOccupied
                              BLups,BLrain8,HSTouch,Ultrajones Weatherbug,
                              MyTrigger,ACRF2,W800,Zwave
                              AP800,Honeywell Stat

                              Comment

                              Working...
                              X