Announcement

Collapse
No announcement yet.

SnevlCID Package Discussions

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • snevl weather

    I am sure I am in the wrong Thread, and if so I am sorry. If someone would direct me to the right one I will go there, but I have looked and this is the only thing close enough.

    I am having a problem with the snevl weather warning, it it repeating it over 20 or 30 times at one event.

    When I get a weather warning the tone goes on and on, then the message goes on and on, one right after the other. Then I get a mess of emails. I am trying to find out how to make it run just one time. I am not finding out why this is going on.
    Thank you in advance for any help, or directions to the right Thread if I am not in the right one.
    danielbo

    Comment


    • Originally posted by danielbo View Post
      I am sure I am in the wrong Thread, and if so I am sorry. If someone would direct me to the right one I will go there, but I have looked and this is the only thing close enough.

      I am having a problem with the snevl weather warning, it it repeating it over 20 or 30 times at one event.

      When I get a weather warning the tone goes on and on, then the message goes on and on, one right after the other. Then I get a mess of emails. I am trying to find out how to make it run just one time. I am not finding out why this is going on.
      Thank you in advance for any help, or directions to the right Thread if I am not in the right one.
      Daniel,

      Yes, this is the wrong thread. Let's take it over here: http://board.homeseer.com/showthread.php?t=147338

      Steve

      Comment


      • All of a sudden I am getting an error message:

        2/26/2013 8:22:36 AM Event Event Trigger "New CID"
        2/26/2013 8:22:36 AM Event Running script in background: SnevlCID_Check4_Steves_Cell.vb
        2/26/2013 8:22:36 AM Event Waiting 0 minute(s) 30 second(s) 0 millisecond(s)
        2/26/2013 8:22:36 AM SnevlCID Call from House Line 2 at 2xx-xxx-xxxx
        2/26/2013 8:23:29 AM Error Sending email using SMTP: The transport failed to connect to the server.

        I checked my smtp port and it was 587 for Comcast. I tried 465 and still the error message.

        Here is the caller id debug log:

        2013-02-26 08:19:32Z ... Reseting modem
        2013-02-26 08:19:34Z ... Raw data from COM port = [ATZ
        ]
        2013-02-26 08:19:34Z ... Ignoring 'ATZ
        '
        2013-02-26 08:19:34Z ... Raw data from COM port = [OK]
        2013-02-26 08:19:34Z ... Raw data from COM port = [
        at+vcid=1
        ]
        2013-02-26 08:19:34Z ... Ignoring '
        at+'
        2013-02-26 08:19:34Z ... Raw data from COM port = [OK]
        2013-02-26 08:19:37Z ... Raw data from COM port = [
        ]
        2013-02-26 08:19:37Z ... Raw data from COM port = [RING]
        2013-02-26 08:19:37Z ... RING detected; last ring was at 8:19:32 AM
        2013-02-26 08:19:37Z ... Got RING; ring count = 2
        2013-02-26 08:19:43Z ... Raw data from COM port = [RING]
        2013-02-26 08:19:43Z ... RING detected; last ring was at 8:19:37 AM
        2013-02-26 08:19:43Z ... Got RING; ring count = 3
        2013-02-26 08:22:35Z ... Raw data from COM port = [RING]
        2013-02-26 08:22:35Z ... RING detected; last ring was at 8:19:43 AM
        2013-02-26 08:22:35Z ... Ring more than 7 seconds after last one. New call.
        2013-02-26 08:22:35Z ... Got RING; ring count = 1
        2013-02-26 08:22:36Z ... Raw data from COM port = [DATE = 0226]
        2013-02-26 08:22:36Z ... Ignoring 'DATE'
        2013-02-26 08:22:36Z ... Raw data from COM port = [TIME = 0822]
        2013-02-26 08:22:36Z ... Ignoring 'TIME'
        2013-02-26 08:22:36Z ... Raw data from COM port = [NMBR = 2xxxxxxxx1]
        2013-02-26 08:22:36Z ... Got Number: '2243654401'
        2013-02-26 08:22:36Z ... Raw data from COM port = [NAME = Northbrook IL]
        2013-02-26 08:22:36Z ... Got Name: 'Northbrook IL'
        2013-02-26 08:22:36Z ... process_ncid_data: starting, Name='Northbrook IL', Number='2243654401'
        2013-02-26 08:22:36Z ... Line=1, After reverse, Name = |IL Northbrook|
        2013-02-26 08:22:36Z ... In search_phonebook(), about to search for Number=2xxxxxxxx1
        2013-02-26 08:22:36Z ... returned from search_phonebook(), i_ret=0, phone_list_name='House Line 2', blocked=False
        2013-02-26 08:22:36Z ... Text message sent: [House Line 2
        2243654401
        2/26/2013
        8:22 AM]
        2013-02-26 08:22:36Z ... Email message sent: [A new call was received from House Line 2 (2xxxxxxxx1) on 2/26/2013 at 8:22 AM]
        2013-02-26 08:22:36Z ... Reseting modem
        2013-02-26 08:22:38Z ... Raw data from COM port = [ATZ
        ]
        2013-02-26 08:22:38Z ... Ignoring 'ATZ
        '
        2013-02-26 08:22:38Z ... Raw data from COM port = [OK]
        2013-02-26 08:22:38Z ... Raw data from COM port = [
        at+vcid=1
        ]
        2013-02-26 08:22:38Z ... Ignoring '
        at+'
        2013-02-26 08:22:38Z ... Raw data from COM port = [OK]
        2013-02-26 08:22:41Z ... Raw data from COM port = [
        ]
        2013-02-26 08:22:41Z ... Raw data from COM port = [RING]
        2013-02-26 08:22:41Z ... RING detected; last ring was at 8:22:36 AM
        2013-02-26 08:22:41Z ... Got RING; ring count = 2
        2013-02-26 08:22:47Z ... Raw data from COM port = [RING]
        2013-02-26 08:22:47Z ... RING detected; last ring was at 8:22:41 AM
        2013-02-26 08:22:47Z ... Got RING; ring count = 3

        Any suggestions? Using 1.34 of the plugin.

        Comment


        • If nothing else changed, I would suspect your email provider changed something. SnevlCID doesn't do anything with email itself, but rather simply uses the Homeseer email stuff. The error you got is from Homeseer trying to send the mail, not from SnevlCID. I would double check the email setup tab and make sure stuff is still correct there, but - like I said - I would suspect that something changed on the email server side.

          Steve

          Comment


          • Thanks Steve.

            You were correct. I had to put the port 587 after the smtp settings because comcast is blocking the default port (25). Now it is working great.

            Steve

            Comment


            • Hey guys, just starting to look into this and this script sounds very close to exactly what I am looking for. I have a Way2Call and HS picks up my CallerID, but what I want to do is have the caller ID sent to my XBMC devices via their HTTP/JSON notification system.

              Is that method of output something this script is capable of?

              Comment


              • Originally posted by chewie View Post
                Hey guys, just starting to look into this and this script sounds very close to exactly what I am looking for. I have a Way2Call and HS picks up my CallerID, but what I want to do is have the caller ID sent to my XBMC devices via their HTTP/JSON notification system.

                Is that method of output something this script is capable of?
                Chewie,

                I don't know anything about XBMC, but I would think it would be easy. SnevlCID can trigger an event called "New CID" (it will create it if you set up the config that way), and that event can have a script which will pull the Caller ID Name and/or number and do whatever you want with it. Sending something to an HTTP server would not be difficult. The key is a script will have to be written.

                Steve

                Comment


                • Speaking of callerid several times (fixed)

                  I stumbled across the cause of the speaking of the caller id several times. I use the SqueezeBox plugin and configured it with the speech part to be above zero on all active players of which I usually have 3-6 depending of the day of the week and time of day.

                  Yesterday the author of the SqueezeBox plubin posted a new version and as I was reading through the changes I noticed that you are only to use one as the master for speech. Configured all players to 0 for speech except the master and now everything is working properly.
                  Originally posted by jimbrandon View Post
                  I've just installed this plugin using YAC for the source. YAC is needed for another information pop-up. If I try to share the modem with the plugin it causes a failure in the other program.

                  Everything works correctly, callerid is displayed, SqueezeBox speaks the caller information. However what is annoying is the callerid information is spoken 4-6 times, there are also 4-6 event entries in the log file named Event Trigger "New CID". Also the same mumber of entries appear in the CallerID log.

                  Using the modem I get only one announcement and one entry in the HomeSeer log.

                  I have a fresh Snevl_CID_debug.txt using YAC and another one using the modem YAC uses (not shared) I will share but not publicly due to phone numbers in there.

                  I've tried to limit the New CID event not to trigger for 1 second but does not help. Any suggestions. If not I'll purchase another modem but rather use what I have.

                  Comment


                  • Originally posted by jimbrandon View Post
                    I stumbled across the cause of the speaking of the caller id several times. I use the SqueezeBox plugin and configured it with the speech part to be above zero on all active players of which I usually have 3-6 depending of the day of the week and time of day.

                    Yesterday the author of the SqueezeBox plubin posted a new version and as I was reading through the changes I noticed that you are only to use one as the master for speech. Configured all players to 0 for speech except the master and now everything is working properly.
                    That's a relief Jim - Your problem had me really stumped. Glad you got it working ok.

                    Steve

                    Comment


                    • delay before tts

                      Loving the script and has been working a treat. The only thing I'd like to improve is the time it takes before it makes the TTS announcement. Currently it's coming through between the 3rd and 4th ring which starts getting a bit late to decide whether I can be bothered getting up out of my chair to go answer the phone .

                      Looking through the logs it's consistently getting the number information on ring 1 but appears to wait for ring two 3 seconds later before running an event. Is there any way of getting it to run after it's captured the data in the 1st ring?

                      I saw some similar comments about tts occuring during rings 3&4 back around page 20 of this thread, but never saw an answer.

                      2013-03-23 10:34:34Z ... Reading config file NCID.ini
                      2013-03-23 10:34:34Z ... Raw data from COM port = [RING]
                      2013-03-23 10:34:34Z ... RING detected; last ring was at 10:33:42 AM
                      2013-03-23 10:34:34Z ... Ring more than 7 seconds after last one. New call.
                      2013-03-23 10:34:34Z ... Got RING; ring count = 1
                      2013-03-23 10:34:34Z ... Raw data from COM port = [DATE=0323]
                      2013-03-23 10:34:34Z ... Ignoring 'DATE'
                      2013-03-23 10:34:34Z ... Raw data from COM port = [TIME=1033]
                      2013-03-23 10:34:34Z ... Ignoring 'TIME'
                      2013-03-23 10:34:34Z ... Raw data from COM port = [NMBR=2748xxxxx]
                      2013-03-23 10:34:34Z ... Got Number: '2748xxxxx'
                      2013-03-23 10:34:37Z ... Raw data from COM port = [RING]
                      2013-03-23 10:34:37Z ... RING detected; last ring was at 10:34:34 AM
                      2013-03-23 10:34:37Z ... Ring count >= 2 with no NAME info, but got a NMBR.
                      2013-03-23 10:34:37Z ... Got RING; ring count = 2
                      2013-03-23 10:34:37Z ... process_ncid_data: starting, Name='unknown', Number='2748xxxxxx'
                      2013-03-23 10:34:37Z ... Line=1, After reverse, Name = |unknown|
                      2013-03-23 10:34:37Z ... In search_phonebook(), about to search for Number=2748xxxxxx
                      2013-03-23 10:34:37Z ... returned from search_phonebook(), i_ret=0, phone_list_name='xxxxxxx', blocked=False
                      2013-03-23 10:34:37Z ... Announcing: Call from xxxxxxxx

                      Comment


                      • -Rick

                        Comment


                        • Rick,

                          At 55, I'm right behind you, and sympathize. Now, what's this SnevlCID thing you are talking about? (Just kidding!!!)

                          First off, you can download the most recent version with all the docs and such here: http://board.homeseer.com/showthread...395#post855395

                          I don't think you should need a com port mapper (not sure even what that would be, but then again I'm 55... ). When you install a USB modem it should include some drivers that install a pseudo-COM port that allows a normal serial comms program (like SnevlCID) to talk to the modem. My guess is you already have these ports but it may not be obvious.

                          Once you figure out what ports you need to use to talk to the USB modems, you should be able to go into the SnevlCID config web page and put them in for each of the phone lines.

                          So, my guess is that you are closer than you think. Chances are there are COM ports that directly interface with your USB modems, and you just need to be able to identify them and put them in the config for SnevlCID. There is some chance that you will need to give some specific INIT strings for the modems, but I think I provide a couple of suggested strings in the config page. Once you get at least some comms going, you can turn on debug (checkbox on the config page) and gather some data so that I can help you get over the last hump. The debug file will be in your root Homeseer directory, I think named Snevl_CID_debug.txt or something like that. Once you get to that point you can ZIP it up and email it to me (snevl at msn dot com) and I'll try and give you the last few items to get it working.

                          I'm here for ya!

                          Snevl

                          Comment


                          • Thanks Steve,

                            Went and found the com ports with device manager - simple. So I think in the AM I will be good to go as at my advanced its way past my bed time....

                            -rick
                            -Rick

                            Comment


                            • All done and working fine or so I think. I did me moment to figure why all of sudden the windows msg and the store caller id into device quit working but it all became apparent once I went looking and found two new empty events one for each line and adding the rights scripts to the events seems good. Any issues with using the same hs device codes for the most recent caller?

                              thanks again

                              -rick
                              -Rick

                              Comment


                              • Originally posted by rmorton27 View Post
                                All done and working fine or so I think. I did me moment to figure why all of sudden the windows msg and the store caller id into device quit working but it all became apparent once I went looking and found two new empty events one for each line and adding the rights scripts to the events seems good. Any issues with using the same hs device codes for the most recent caller?

                                thanks again

                                -rick
                                Rick,

                                I'm not sure exactly how you mean. If you mean having multiple lines going to the same devices, I don't think that will cause a problem except if / when you get call from multiple lines at the same time, in which case one call will get overwritten before your scripts can do anything with it. If that is what you mean and you want to give it a try, it won't do any harm.

                                Steve

                                Comment

                                Working...
                                X