Announcement

Collapse
No announcement yet.

Snevl Latitude discussion thread

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • +1, yes please

    Comment


    • Originally posted by Gogs View Post
      Steve, it's a perfectly workable version, albiet BTraced bits don't do anything. Especially if the leave the Bouce in the tracking screen.

      I think you should release it as a pre-Btraced version, and hopfully Btraced will release a new version soon and we will all be ready.

      I also think you should release your notes/instructions for setting BTraced up so that when they do release it you should have less posts about "what do I do"
      Gordon,

      Good points. I think you are right that there is some other benefits besides the BTraced mods.

      You have been my only Beta tester so far (well, besides me), so I guess if Michael is willing to be a lab rat I'd like to get a little more testing before I post it.

      Also, if I could find the screen space I'd like to have the "active" map replace the static map on the main web page, rather than have a separate pop-up web page. It probably isn't a big deal though, and I don't know how long it would take me given how much else I have going on.

      So, I'll send something to Michael and have him run it for a bit, then try and post v2.0.

      Steve

      Comment


      • Originally posted by stevea View Post
        Gordon,

        Good points. I think you are right that there is some other benefits besides the BTraced mods.

        You have been my only Beta tester so far (well, besides me), so I guess if Michael is willing to be a lab rat I'd like to get a little more testing before I post it.

        Also, if I could find the screen space I'd like to have the "active" map replace the static map on the main web page, rather than have a separate pop-up web page. It probably isn't a big deal though, and I don't know how long it would take me given how much else I have going on.

        So, I'll send something to Michael and have him run it for a bit, then try and post v2.0.

        Steve
        I'd be happy to try it as well Steve.

        Comment


        • Originally posted by jayman13 View Post
          I'd be happy to try it as well Steve.
          Sounds good. I think I have your email address, but just in case can you re-send me a message: snevl at msn dot com. Thanks for offering to test.

          Steve

          Comment


          • Originally posted by stevea View Post
            ..........Also, if I could find the screen space I'd like to have the "active" map replace the static map on the main web page, rather than have a separate pop-up web page. It probably isn't a big deal though, and I don't know how long it would take me given how much else I have going on...................
            Steve, I see where you are coming from here and it is a good idea.

            My concern would be the effect that would have on smaller displays such as a Kindle Firefox, Ipad and iPhone as you will be cramming a lot of info and options into that one page, no?

            Personally I like the tracker map opening in a separate window, but others may not - problem is they have not seen it yet so cannot really comment.
            sigpic
            A founder member of "The HA Pioneer Group" otherwise known as the "Old farts club!"
            HomeSeer 3 V 3.0.0.318 with ALEXA (AKA Amazon Echo)
            BL Radar V2.0.217; BLRF V2.0.85.0; HS Touch V3.0.0.1034 X10 V3.0.0.42; PHLocation V3.0.0.38; Zwave V3.0.1.110; X10 V3.0.0.42
            BLBackup V2.0.39;ImperiHome3.0.0.20 All on Windows XP Pro

            Comment


            • Originally posted by Gogs View Post
              Steve, I see where you are coming from here and it is a good idea.

              My concern would be the effect that would have on smaller displays such as a Kindle Firefox, Ipad and iPhone as you will be cramming a lot of info and options into that one page, no?

              Personally I like the tracker map opening in a separate window, but others may not - problem is they have not seen it yet so cannot really comment.
              Gordon,

              I think you are right. In addition, I really don't think I'm going to have any time to make that kind of change for a while. So, I'll probably release v2.0 with it in a separate window.

              Steve

              Comment


              • Originally posted by stevea View Post
                Gordon,

                I think you are right. In addition, I really don't think I'm going to have any time to make that kind of change for a while. So, I'll probably release v2.0 with it in a separate window.

                Steve
                And a seperate Forum to avoid confusion.
                sigpic
                A founder member of "The HA Pioneer Group" otherwise known as the "Old farts club!"
                HomeSeer 3 V 3.0.0.318 with ALEXA (AKA Amazon Echo)
                BL Radar V2.0.217; BLRF V2.0.85.0; HS Touch V3.0.0.1034 X10 V3.0.0.42; PHLocation V3.0.0.38; Zwave V3.0.1.110; X10 V3.0.0.42
                BLBackup V2.0.39;ImperiHome3.0.0.20 All on Windows XP Pro

                Comment


                • Strange error message

                  I lost my internet connect today for a while.

                  The error message from this script was interesting:

                  <TABLE cellSpacing=2 cellPadding=0 width="100%" border=0><TBODY><TR><TD class=LOGDateTime1 noWrap align=left>24/10/2012 15:37:39 </TD><TD class=LOGType1 colSpan=3 align=left>Error </TD><TD class=LOGEntry1 colSpan=8 align=left>SnevlLatitude failed to retrieve XML from Google 0 consecutive times.</TD></TR><TR><TD class=LOGDateTime0 noWrap align=left>24/10/2012 15:37:39 </TD><TD class=LOGType0 colSpan=3 align=left>Error </TD><TD class=LOGEntry0 colSpan=8 align=left>SnevlLatitude failed to retrieve XML from Google 0 consecutive times.</TD></TR><TR><TD class=LOGDateTime1 noWrap align=left></TD></TR></TBODY></TABLE>
                  zero times? is that an error [smile]? it was also interesting to me that there were two messages at the same time (and then a break until the next which I have omitted as it says the same thing).

                  Simon

                  Comment


                  • Simon,

                    I'm not sure what would cause that. I'm not able to see the code right now, but I recall that whole section is part of an error trap (try/catch), so that the script doesn't simply fail when Google doesn't respond. I've seen it work correctly when my Internet was down. Do you have the "silent errors" config item (very first thing on the config page) set to something other than 0?

                    I'll look at it and try to understand what is going on.

                    Steve

                    Comment


                    • Just checked. Set to zero so it's not that.

                      Comment


                      • Originally posted by simonog View Post
                        Just checked. Set to zero so it's not that.
                        Actually, it turns out that is the reason. Obviously some explanation is required, and I probably should change the code a bit. Here's the deal:

                        When an error occurs while trying to get data from Google, I compare the number of errors to what you picked in the config page. If the number of errors is greater than or equal to the menu selection, I print the error message. If it isn't greater than or equal to the menu selection yet, I increment the count, store it, and move on without printing an error.

                        So there are a number of things kinda screwy here. I don't increment the number of errors until AFTER I print the message. A choice of zero should mean that error message is printed in the log every time it fails, which is what it is doing. I should increment the error count BEFORE I print the message, and print the message only if the error count is greater than whatever was selected on the config page.

                        So I can fix it so that the error message makes a bit more sense, but the fact that you are getting the error message is correct.

                        Steve

                        Comment


                        • The perils of >= comparisons and when to do them! Thank you, very clear.

                          The message would make more sense if you had increased the count before at least you reported so that it would report 1 error rather than zero.

                          One for the next release (it's not a serious issue preventing the system working)?

                          Simon

                          Comment


                          • I have already fixed it, so it will be in v2.0. I also fixed the same issue with the Reverse Geo stuff, which also tries to pull data from the Internet.

                            As has been suggested here, I'll probably start a new thread with v2.0.

                            Steve

                            Comment


                            • Comment


                              • Originally posted by simonog View Post
                                I lost my internet connect today for a while.

                                The error message from this script was interesting:

                                <TABLE border=0 cellSpacing=2 cellPadding=0 width="100%"><TBODY><TR><TD class=LOGDateTime1 noWrap align=left>24/10/2012 15:37:39 </TD><TD class=LOGType1 colSpan=3 align=left>Error </TD><TD class=LOGEntry1 colSpan=8 align=left>SnevlLatitude failed to retrieve XML from Google 0 consecutive times.</TD></TR><TR><TD class=LOGDateTime0 noWrap align=left>24/10/2012 15:37:39 </TD><TD class=LOGType0 colSpan=3 align=left>Error </TD><TD class=LOGEntry0 colSpan=8 align=left>SnevlLatitude failed to retrieve XML from Google 0 consecutive times.</TD></TR><TR><TD class=LOGDateTime1 noWrap align=left></TD></TR></TBODY></TABLE>
                                zero times? is that an error [smile]? it was also interesting to me that there were two messages at the same time (and then a break until the next which I have omitted as it says the same thing).

                                Simon
                                I have seen this if I have not updated my position to Google that day ie midnight to midnight.

                                V2 should solve that little problem if you bypass Google.
                                sigpic
                                A founder member of "The HA Pioneer Group" otherwise known as the "Old farts club!"
                                HomeSeer 3 V 3.0.0.318 with ALEXA (AKA Amazon Echo)
                                BL Radar V2.0.217; BLRF V2.0.85.0; HS Touch V3.0.0.1034 X10 V3.0.0.42; PHLocation V3.0.0.38; Zwave V3.0.1.110; X10 V3.0.0.42
                                BLBackup V2.0.39;ImperiHome3.0.0.20 All on Windows XP Pro

                                Comment

                                Working...
                                X