Announcement

Collapse
No announcement yet.

Chromoflex RGB LED Lighting Driver/Controller PlugIn

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Chromoflex RGB LED Lighting Driver/Controller PlugIn

    In response to various messages and questions. Here's a discussion thread for this plug-in.

    For anyone looking to buy the Chromoflex controller you can try:

    UK: http://www1.conrad-uk.com
    Europe: http://www.conrad.com/
    US: TBC

    The plug-in is written to use the serial port of the Chromoflex controllers and as such it has been written to work with the "standard" Chromoflex controller: http://www.xeroflex.com/html/chromoflex__standard.html

    The RC version of the Chromoflex ha a USB connection. I'm not sure if this presents itself to the PC as a Com port and I have not had a chance to test if this works with the plug in. The RC version is this one here: http://www.xeroflex.com/html/chromoflex_rc.html
    Nicolai L

  • #2
    I've just posted a new version of this plug-in which removes the error messages around trial license expiration.

    http://board.homeseer.com/showthread.php?t=152187

    NicolaiL
    Nicolai L

    Comment


    • #3
      Nicolail,

      What is de command line for starting the control of a chromoflex?
      On the homeseer page there are buttons like off controle reset and a ID number.
      In a device controller there is just a device ID or All.
      When I pick ID 1 and set a number for RED (255) red leds go on and switch of again!
      When I click on controll in homeseer webpage it works??
      Is there a script commando for controlle of one ID?

      Comment


      • #4
        Hi pklijnjan

        There is no command line per-se, but if you read the manual you will not a couple of actions you can call as well as a few scripting commands.

        However, it sounds like your problem is that you are not retaining control over the Chromoflex (CF). As you might know the CF runs its own lighting scheme UNLESS you take control. This is why you see your colour changes overwritten by the CF.

        On the config page there are settings for "Take Control On StartUp" This will let the plugin take control of configured CFs when HS starts.

        You also need to make sure you set the ID of your CF by using the dip switch settings as described in the CF manual and then set the corresponding ID in HS on the device (as you refer to).

        The way to control the devices by script is simply by changing the device value of the corresponding HS colour device using the standard hs.setdevicevalue command.

        Hope this helps.
        Nicolai L

        Comment


        • #5
          Hi Nicolail

          Take control on startup is on, it works wel by using the webinterface of homeseer.
          But when I make a script device command chromoflex group controller value set set to 1
          and the Chromoflex Red Value set set to 255. The color Red turns on but after 2 seconds the
          chromoflex turns off (not the power supply!) But the colors.

          When I klik on control in the webinterface de controller turns on again without going off
          The ID is OK I use 2 chromoflex and one is on ID 1 and the other on 2.

          Comment


          • #6
            That is very strange. Could you share the script and I will try it out on my own setup?
            Nicolai L

            Comment


            • #7
              Originally posted by NicolaiL View Post
              That is very strange. Could you share the script and I will try it out on my own setup?

              Hi Nicolai I like to use &hs.SetDeviceValue("'1","control") in a event.
              If I use &hs.SetDeviceValue("'3",255) The LEDs turn red en turn off again afther 1 or 2 second. When I use the control button it works fine.

              Comment


              • #8
                Originally posted by pklijnjan View Post
                Hi Nicolai I like to use &hs.SetDeviceValue("'1","control") in a event.
                If I use &hs.SetDeviceValue("'3",255) The LEDs turn red en turn off again afther 1 or 2 second. When I use the control button it works fine.
                Hi pklijnjan

                I'm assuming you are trying to use the "&hs.SetDeviceValue("'1","control")" on your Controller device? (i.e. not the RGB devices). This will not work. Currently you would need to either manually take control via the device in HS or on start-up via the ini settings.

                The second command &hs.SetDeviceValue("'3",255) works, but because control has not been taken (as the prior does not work) the Chromoflex will return to it's internal programming.

                As a workaround could you try taking control manually and then running the &hs.SetDeviceValue("'3",255) command?

                When I get a chance I will add some API scripting calls to allow you to take control/release control from script commands as well.

                Cheers
                NicolaiL
                Nicolai L

                Comment


                • #9
                  Hi Nicolai,

                  I think I know whats wrong. The power supply of the chromoflex is switcht off when I start Homeseer. When I run the script I first switch on the power supply. I try it with the power on when i start homeseer and than it works
                  The problem is that I want to switch of the power When I do after the firts time it work then its wrong again.
                  So If you can change the API it it whoot be greate.

                  Peter

                  Comment


                  • #10
                    Hi Peter

                    Download the latest plugin from the library. I've added two script options now that you can call from events:

                    &hs.plugin("izChromoflex").TakeControl(n)

                    &hs.plugin("izChromoflex").ReleaseControl(n)

                    Replace n with the GroupID (0 for all) of the controller you want to manage. I've not had much time to test so let me know how you get on with it, but I hope this helps.

                    Regards
                    Nicolai
                    Nicolai L

                    Comment


                    • #11
                      TakeControl

                      Hi Nicolai,

                      I use &hs.plugin("izChromoflex").TakeControl(1) in a event but it won't work! Afther I power off only the button control in de webinterface can take control again.

                      Regards

                      Peter

                      Comment


                      • #12
                        Hi Peter

                        Are there any errors in the logfile?

                        Regaads
                        NicolaiL
                        Nicolai L

                        Comment


                        • #13
                          Hi NicolaiL,

                          I am using the Chromoflex for a while to control my lights and found your plugin.
                          I have tested it and it is working good.
                          I have only one problem.
                          I use 9 Chromoflex controllers, 5 for my RGB led strips and 4 for my 12 LED spots.
                          I divided them into 2 serial groups on com 7 and com 9.
                          Is it possible to use your plugin for 2 serial ports?

                          Best regards,
                          Peter

                          http://ohh.pcgsm.nl

                          Comment


                          • #14
                            Hi Peter

                            Glad to hear you like the plugin! That's a nice big installation you got there! Unfortunately the plugin doesn't support more than one COM port at the moment.

                            It would probably be quite a rewrite to incorporate additional COM ports so not something I could quickly do. When HS3 comes out I will take a look at this as part of the required rewrite though.

                            Cheers
                            Nicolai
                            Nicolai L

                            Comment


                            • #15
                              Hi,

                              Im just installed HomeSeer HS2 on my computer (test system) to see if i can get Chromoflex going. But when i select the config of the plugin nothing happens.

                              The plugin seems to be loading fine (although it is complaining about the com port but this is because it did not set it yet)

                              I running HS2 2.5.0.55

                              And this is some logging

                              Code:
                               
                              20-7-2012 21:23:28  - Plug-In - Initializing Plug-in: izChromoflex on COM port 1
                              20-7-2012 21:23:28  - izChromoflex - Debug On
                              20-7-2012 21:23:28  - Error - In OpenComPort, error opening port: Unable to obtain a handle to the COM port
                              20-7-2012 21:23:28  - izChromoflex Error - Error opening Chromoflex COM port: 1 Error message: Error: Unable to obtain a handle to the COM port
                              20-7-2012 21:23:28  - Error - Initializing interface: izChromoflex->Can't open COM port izChromoflex
                              20-7-2012 21:23:28  - Plug-In - Finished initializing plug-in izChromoflex
                              When i push the config button

                              Code:
                              20-7-2012 21:23:43  - ConfigIO - Calling ConfigIO for izChromoflex
                              Update:

                              I just found out that it is working when i change my com port to com1 in the control panel of the system. Is it possible to add the posibility to change the comport ?

                              Comment

                              Working...
                              X