Announcement

Collapse
No announcement yet.

Event Execution Delay Measurement Script discussion

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Wadenut
    replied
    You've defined the run frequency as 2 minutes. Your event needs to run every two minutes as well. I can't tell if this is the case or not from your info.
    I do suggest that one minute would be a better choice.

    If everything IS set up properly, then you probably do have the delay as it's been reported. IE. The script is doing its job.

    Leave a comment:


  • fungun
    replied
    I don't know why or what I am doing wrong. I went through everything, twice, and it just doesn't look right.
    Here is from the log file -
    Code:
    5/27/2013 8:42:53 AM ~!~Event~!~Running script in background: Event Delay Measurement.vb("Main","2")
    5/27/2013 8:42:53 AM ~!~EventDelay~!~Current delay: 53.062 seconds [Delta: 0 Min: 21.265 Max: 53.109 @ 5/27/2013 12:16 AM] Last Event: EventDelayMsrmnt.  Scripts running: SnevlWeatherWarnings.vb,Event Delay Measurement.vb
    This is the latest file from your post and on a new machine with a new setup running HS .80.

    Thanks,
    Tim

    Leave a comment:


  • Loup
    replied

    Leave a comment:


  • Wadenut
    replied
    My bad.
    I had corrected the negative MinTime back in late September, but had forgotten to post the new version 1.12.1. Posted today.
    This also will require a small change to your existing event. Documentation is updated accordingly.

    Leave a comment:


  • fungun
    replied
    I do have the latest, 1.12, in your post in the Script Library.

    Thanks,
    Tim

    Leave a comment:


  • Wadenut
    replied
    You may have an older version. I thought I'd fixed that.

    Do make sure you're running the script at the same frequency as you've provided in the parameter.

    For instance, my event frequency is 1 minute ::: Run script: Event Delay Measurement.vb("Main","1")

    Leave a comment:


  • fungun
    replied
    Just a question.
    Does this look normal to you guys?
    Why would my "Min" be a negative number?

    Code:
    12/4/2012 6:18:00 PM ~!~Info~!~Running script in background: Event Delay Measurement112.vb
    12/4/2012 6:18:08 PM ~!~EventDelay~!~Current delay: 1.593 seconds [Delta: 0.437 Min: -58.938 Max: 6.828 @ 12/2/2012 11:00 AM] Last Event: EventDelayMeasurment.  Scripts running: Jon00RCCNM_A.vben,Event Delay Measurement112.vb
    Thanks,
    Tim

    Leave a comment:


  • Wadenut
    replied
    Originally posted by Pete View Post
    Thank you Greg.

    What "me" read the docs?



    Adjusted. Working well.
    I know... it's a man thing.

    Leave a comment:


  • Pete
    replied
    Thank you Greg.

    What "me" read the docs?



    Adjusted. Working well.

    Leave a comment:


  • Wadenut
    replied
    Originally posted by Pete View Post
    Thanks Greg. Updated to V1.09.

    Renamed it to Event Delay Check.vb and enabled the TTS sound for spikes. Running fine.

    Just now found a disabled plugin (CumulusR) still running. It started to error out last night so I disabled it; but it still ran all night (with VB SQL errors).

    Just noticed that there is no space or line return on the text for seconds for the updated script V1.09?
    Did you read the updated doc?
    Your caption is showing the "seconds" twice. You can turn that off in Jon's config for the graph. ShowCurrentValue=0, ShowLowHighValues=0. Looks much better.

    Leave a comment:


  • Pete
    replied
    Thanks Greg. Updated to V1.09.

    Renamed it to Event Delay Check.vb and enabled the TTS sound for spikes. Running fine.

    Just now found a disabled plugin (CumulusR) still running. It started to error out last night so I disabled it; but it still ran all night (with VB SQL errors).

    Just noticed that there is no space or line return on the text for seconds for the updated script V1.09?
    Attached Files

    Leave a comment:


  • Wadenut
    replied
    Originally posted by Pete View Post
    So script went from 1.08.2 to 1.09. Is it a drop in that I can do chaning only the dim variable statements stuff?
    Yup.

    Leave a comment:


  • Pete
    replied
    So script went from 1.08.2 to 1.09. Is it a drop in that I can do chaning only the dim variable statements stuff?

    Leave a comment:


  • Wadenut
    replied
    Several improvements with 1.09.

    Leave a comment:


  • Pete
    replied
    5:10 PM script doing well.

    Leave a comment:

Working...
X