Announcement

Collapse
No announcement yet.

Snevl Latitude Version 2 Discussion

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • jbbtex
    replied
    Originally posted by simonog View Post
    Thank you - I had misunderstood - I have both set on. What do you think the second one means? I take it to mean upload anything not yet sent if tracking is turned off, but I may be wrong.
    I think, though I haven't tested, that it will upload any waypoints that haven't already been uploaded once the phone stops moving.

    Leave a comment:


  • stevea
    replied
    Originally posted by Raptor View Post
    Hi tried searching and couldn't find an answer but i wiped out the old data and replaced everything and i am getting this error now.

    any ideas?
    <TABLE border=0 cellSpacing=2 cellPadding=0 width="100%"><TBODY><TR><TD class=LOGDateTime0 noWrap align=left>2/1/2013 4:07:28 PM </TD><TD class=LOGType0 colSpan=3 align=left>Error </TD><TD class=LOGEntry0 colSpan=8 align=left>SnevlLatitude: Error while trying to upgrade DB to version 4: Field 'UseLatitude' already exists in table 'BADGES'.</TD></TR><TR><TD class=LOGDateTime1 noWrap align=left>2/1/2013 4:07:28 PM </TD><TD class=LOGType1 colSpan=3 align=left>Error </TD><TD class=LOGEntry1 colSpan=8 align=left>SnevlLatitude: Error while trying to check fields in Badges table: Operation is not allowed when the object is closed.</TD></TR></TBODY></TABLE>
    Raptor,

    The suggestions I gave earlier will probably work. However, in order to help me find what is going on, can you tell me what else Snevl Latitude sent to your HS log, right before these two error lines?

    Steve

    Leave a comment:


  • simonog
    replied
    Thank you - I had misunderstood - I have both set on. What do you think the second one means? I take it to mean upload anything not yet sent if tracking is turned off, but I may be wrong.

    Leave a comment:


  • jbbtex
    replied
    Originally posted by simonog View Post
    Where did you set these server settings please?

    Simon
    In the app touch Settings on the bottom right. Then Upload Server. They are at the bottom of the page.

    Leave a comment:


  • simonog
    replied
    Originally posted by jbbtex View Post
    I started the app and a new trip about 6 hours ago and it is still working. I'll try it through the rest of the weekend and see.

    Settings

    Server
    • Real Time Uploads ON
    • Upload all when Stops OFF
    Where did you set these server settings please?

    Simon

    Leave a comment:


  • jbbtex
    replied
    Btraced

    Originally posted by jayman13 View Post
    Make sure you turn off the trip and then completely close the app, with the x-box. Restart the app and then start a new trip. Does that do it?
    I started the app and a new trip about 6 hours ago and it is still working. I'll try it through the rest of the weekend and see.

    Settings
    Server
    • Real Time Uploads ON
    • Upload all when Stops OFF

    GPS
    • Run in Background ON
    • Add Point on Turn ON
    • Include points with accuracy < 330 ft
    • Distance Update Interval to 1.2 miles
    • Time Update Interval to 30 minutes

    Leave a comment:


  • jayman13
    replied
    Snevl Latitude Version 2 Discussion

    Originally posted by jayman13 View Post
    I can change the settings to whatever. Seems to update too frequently but continuously works unless I reboot. Iphone 5 with the latest os.
    Make sure you turn off the trip and then completely close the app, with the x-box. Restart the app and then start a new trip. Does that do it?

    Leave a comment:


  • stevea
    replied
    Originally posted by Raptor View Post
    Hi tried searching and couldn't find an answer but i wiped out the old data and replaced everything and i am getting this error now.

    any ideas?
    <TABLE border=0 cellSpacing=2 cellPadding=0 width="100%"><TBODY><TR><TD class=LOGDateTime0 noWrap align=left>2/1/2013 4:07:28 PM </TD><TD class=LOGType0 colSpan=3 align=left>Error </TD><TD class=LOGEntry0 colSpan=8 align=left>SnevlLatitude: Error while trying to upgrade DB to version 4: Field 'UseLatitude' already exists in table 'BADGES'.</TD></TR><TR><TD class=LOGDateTime1 noWrap align=left>2/1/2013 4:07:28 PM </TD><TD class=LOGType1 colSpan=3 align=left>Error </TD><TD class=LOGEntry1 colSpan=8 align=left>SnevlLatitude: Error while trying to check fields in Badges table: Operation is not allowed when the object is closed.</TD></TR></TBODY></TABLE>
    I guess my logic for trying to test the database version is messed up. A couple of things to try:

    First, make a backup copy of your SnevlLatitude.ini file (in \config), and edit the file. I don't remember what the item name is, but it is something like "dbversion". Delete that line and try to run the script again.

    Second: If you are really wiping everything out, you could download the v1.X ZIP, pull only the SnevlLatitude.MDB file (put it in \data\SnevlLatitude), and try again. The v2.X script should correctly upgrade a v1.X database to v2.X.

    I guess I need to look again at what I'm doing in the database upgrade to mess stuff up.

    Steve

    Leave a comment:


  • Raptor
    replied
    Hi tried searching and couldn't find an answer but i wiped out the old data and replaced everything and i am getting this error now.

    any ideas?
    <table border="0" cellpadding="0" cellspacing="2" width="100%"><tbody><tr><td colspan="1" class="LOGDateTime0" align="left" nowrap="nowrap">2/1/2013 4:07:28 PM </td><td colspan="3" class="LOGType0" align="left"> Error </td><td colspan="8" class="LOGEntry0" align="left">SnevlLatitude: Error while trying to upgrade DB to version 4: Field 'UseLatitude' already exists in table 'BADGES'.</td></tr> <tr> <td colspan="1" class="LOGDateTime1" align="left" nowrap="nowrap">2/1/2013 4:07:28 PM </td><td colspan="3" class="LOGType1" align="left"> Error </td><td colspan="8" class="LOGEntry1" align="left">SnevlLatitude: Error while trying to check fields in Badges table: Operation is not allowed when the object is closed.</td></tr></tbody></table>

    Leave a comment:


  • stevea
    replied
    Originally posted by simonog View Post
    I was rather hoping (unfairly!) to be able to get a clean record of the incoming data rather than all the other workings of this wonderful script.

    my wife and I went out with our phones to a place 50 miles away late this morning. mine updated its location with our return home a few minutes after we arrived home; hers still shows its last location as the remote place. I can't work out why it won't send the data - unless there was something wrong with it and the script rejected it.

    I will report this to the BTraced developers.
    Simon,

    I could probably insert debug into a custom version and send it to you if it will help. I realize that turning on debug gives you lots of stuff that doesn't have anything to do with Btraced.

    When I was developing the Btraced changes, I think I hit some problems where I couldn't put much debug into the ASPX page that the phone calls or it would time out. However, that may have been caused by other problems that I have sinced worked out.

    Do I have your email address? Send me a note at snevl at msn dot com and I'll try and send you something.

    Steve

    Leave a comment:


  • simonog
    replied
    I was rather hoping (unfairly!) to be able to get a clean record of the incoming data rather than all the other workings of this wonderful script.

    my wife and I went out with our phones to a place 50 miles away late this morning. mine updated its location with our return home a few minutes after we arrived home; hers still shows its last location as the remote place. I can't work out why it won't send the data - unless there was something wrong with it and the script rejected it.

    I will report this to the BTraced developers.

    Leave a comment:


  • stevea
    replied
    Originally posted by simonog View Post
    I am having a definite issue with both the household iPhone 5s (with recent OS upgrade so latest version 6.1 iOS).

    the phones seem to be collecting data, and just not transmitting it to HS regularly. they may go for hours with no communication and then suddenly dump a load of points.

    if I read the View Data section on the phone correctly, however, some points are never uploaded.

    Is there any way to track what Snevl-Latitude is receiving as the btraced stream? if I could i'd like to compare the raw stream with the log stored on the phone - and it would be good to know when each item is received to see if there's any pattern
    You can turn on debug and every time your phone contacts Snevl Latitude there will be a log entry. I don't remember now if I preserve the data points that are received in XML. I'll have to look at the code when I get home.

    Steve

    Leave a comment:


  • simonog
    replied
    I am having a definite issue with both the household iPhone 5s (with recent OS upgrade so latest version 6.1 iOS).

    the phones seem to be collecting data, and just not transmitting it to HS regularly. they may go for hours with no communication and then suddenly dump a load of points.

    if I read the View Data section on the phone correctly, however, some points are never uploaded.

    Is there any way to track what Snevl-Latitude is receiving as the btraced stream? if I could i'd like to compare the raw stream with the log stored on the phone - and it would be good to know when each item is received to see if there's any pattern

    Leave a comment:


  • jayman13
    replied
    Snevl Latitude Version 2 Discussion

    Originally posted by jbbtex View Post
    Jayman,

    Like Simon, I was never able to get it to run more than about 36 hours. I too have the 1.1.2 ver. running on iOS6/iPhone4s.

    What are your GPS Settings?
    I can change the settings to whatever. Seems to update too frequently but continuously works unless I reboot. Iphone 5 with the latest os.

    Leave a comment:


  • Gogs
    replied
    Originally posted by 8r1an View Post
    Don't think there was a V2 of BTraced app
    Thanks, I stand corrected, it's 1.1.2 I was thinking of which as Steve says has not been released yet.

    Leave a comment:

Working...
X