Announcement

Collapse
No announcement yet.

Snevl Latitude Version 2 Discussion

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Originally posted by stevea View Post
    Gordon,
    That change was made by FollowMee quite a while ago. It broke all support for FollowMee, until I put up version 2.7 last May. Before there was a back-door free way to get your location from FollowMee. They apparently figured out what people were doing. Now you have to pay for a subscription to use their API. When you do so, they will give you an API key, which is required with the device ID to continue to use FollowMee. I don't remember exactly, but I think they charge something like $15 for the year.

    I'm a little surprised you are just seeing this. Did you stop using FollowMee sometime before May of last year?

    Steve
    Steve,

    What has happened is that \I have riolled HS2 back to an eaerlier installation obviously before Followmee changed I am subscribed.

    I'll go look for version 2.7

    thanks.
    sigpic
    A founder member of "The HA Pioneer Group" otherwise known as the "Old farts club!"
    HomeSeer 3 V 3.0.0.318 with ALEXA (AKA Amazon Echo)
    BL Radar V2.0.217; BLRF V2.0.85.0; HS Touch V3.0.0.1034 X10 V3.0.0.42; PHLocation V3.0.0.38; Zwave V3.0.1.110; X10 V3.0.0.42
    BLBackup V2.0.39;ImperiHome3.0.0.20 All on Windows XP Pro

    Comment


    • Streve, thanks for jogging my memory regarding the small inconvienent change Followmee made

      re-installed and all appears to be working OK

      thanks again
      sigpic
      A founder member of "The HA Pioneer Group" otherwise known as the "Old farts club!"
      HomeSeer 3 V 3.0.0.318 with ALEXA (AKA Amazon Echo)
      BL Radar V2.0.217; BLRF V2.0.85.0; HS Touch V3.0.0.1034 X10 V3.0.0.42; PHLocation V3.0.0.38; Zwave V3.0.1.110; X10 V3.0.0.42
      BLBackup V2.0.39;ImperiHome3.0.0.20 All on Windows XP Pro

      Comment


      • Streve, thanks for jogging my memory regarding the small inconvienent change Followmee made

        re-installed and all appears to be working OK

        thanks again
        sigpic
        A founder member of "The HA Pioneer Group" otherwise known as the "Old farts club!"
        HomeSeer 3 V 3.0.0.318 with ALEXA (AKA Amazon Echo)
        BL Radar V2.0.217; BLRF V2.0.85.0; HS Touch V3.0.0.1034 X10 V3.0.0.42; PHLocation V3.0.0.38; Zwave V3.0.1.110; X10 V3.0.0.42
        BLBackup V2.0.39;ImperiHome3.0.0.20 All on Windows XP Pro

        Comment


        • Streve, thanks for jogging my memory regarding the small inconvienent change Followmee made

          re-installed and all appears to be working OK

          thanks again
          sigpic
          A founder member of "The HA Pioneer Group" otherwise known as the "Old farts club!"
          HomeSeer 3 V 3.0.0.318 with ALEXA (AKA Amazon Echo)
          BL Radar V2.0.217; BLRF V2.0.85.0; HS Touch V3.0.0.1034 X10 V3.0.0.42; PHLocation V3.0.0.38; Zwave V3.0.1.110; X10 V3.0.0.42
          BLBackup V2.0.39;ImperiHome3.0.0.20 All on Windows XP Pro

          Comment


          • Hi Steve
            I am a new user of your plugin. I have a problem because I can't run SnevlLatitude .vb script ...this is the error :
            -- Script compile error: Type 'XMLDocument' is not defined.on line 362--

            Ok. I cheked settings.ini and I have the fallowing line :

            HTML Code:
            ScriptingReferences=System.Data;System.Data.Dll,System.Web;System.Web.Dll,System.XML;System.XML.Dll
            It seems to be complying with installation specifications of your plugin . Still not working . What's wrong . Please help-me . Thanks .

            Comment


            • Originally posted by mariusb57 View Post
              Hi Steve
              I am a new user of your plugin. I have a problem because I can't run SnevlLatitude .vb script ...this is the error :
              -- Script compile error: Type 'XMLDocument' is not defined.on line 362--

              Ok. I cheked settings.ini and I have the fallowing line :

              HTML Code:
              ScriptingReferences=System.Data;System.Data.Dll,System.Web;System.Web.Dll,System.XML;System.XML.Dll
              It seems to be complying with installation specifications of your plugin . Still not working . What's wrong . Please help-me . Thanks .
              Well, first things first, since it has become a common trip-up recently: Are you using HS2 or HS3? Snevl Latitude only works with HS2. If you are using HS3, you need to find PHLocation (here).

              If you are using HS2, I'm not sure what the problem could be. I wouldn't think it would matter, but I've never seen the ".dll" capitalized like you have it (".Dll"). I wouldn't think that would cause the problem, but I don't know. It might be worth changing all the .Dll to .dll.

              Give that a try, then get back to me.

              Steve

              Comment


              • Sorry...yes, I use HS2 ...and changing all the .Dll to .dll has no effect . I have the same error .

                Comment


                • Well, that doesn't make any sense. Hmmm. Did you install the SnevlLatitude.vb file directly from what you downloaded here? The very first line of that file should be "Imports System.XML". If it is there, I don't see any way for XmlDocument to come up as an undefined type.

                  Comment


                  • Sorry ...I was in a little vacation . Yes I installed the SnevlLatitude.vb file directly from what I downloaded from here and the very first line of that file is "Imports System.XML"......and still does not work .

                    Comment


                    • Originally posted by mariusb57 View Post
                      Sorry ...I was in a little vacation . Yes I installed the SnevlLatitude.vb file directly from what I downloaded from here and the very first line of that file is "Imports System.XML"......and still does not work .
                      Argh... I'm really sorry this is turning out harder than it should be.

                      Do you have any other scripts installed that use XML? I'm thinking of weather scripts / plug-ins, RSS readers, etc. Unless the library itself is messed up or missing, I can't figure out what the problem could be.

                      Can you do a search for the System.XML.dll file? It should be in Windows\Microsoft.NET\Framework\.... If you do find it, right click on it and select "properties", then note the size of the file and the version number of the library. Let's see what that looks like.

                      Comment


                      • Yes, I have "Weather xml' wich uses XML , and this plugin works perfectly .
                        Now...I search for System.XML.dll file on C: and I found these :

                        C:\Windows\assembly\GAC_MSIL\System.Xml\2.0.0.0__b77a5c56193 4e089\System.XML.dll
                        C:\Windows\Microsoft.NET\assembly\GAC_MSIL\System.Xml\v4.0_4 .0.0.0__b77a5c561934e089\System.Xml.dll -------2.56 MB (2,694,280 bytes)
                        C:\Windows\Microsoft.NET\Framework\v2.0.50727\System.XML.dll------- 1.96 MB (2,056,192 bytes)
                        C:\Windows\Microsoft.NET\Framework\v4.0.30319\System.XML.dll -------2.56 MB (2,694,280 bytes)
                        C:\Windows\winsxs\msil_system.xml_b77a5c561934e089_6.1.7601. 17514_none_55fc822005f63b82\System.XML.dll
                        C:\Windows\winsxs\msil_system.xml_b77a5c561934e089_6.1.7601. 18523_none_55fd9b1805f5385f\System.XML.dll
                        C:\Windows\winsxs\msil_system.xml_b77a5c561934e089_6.1.7601. 18529_none_55fd126805f5d225\System.XML.dll
                        C:\Windows\winsxs\msil_system.xml_b77a5c561934e089_6.1.7601. 19091_none_5604cd4805eeb210\System.XML.dll
                        C:\Windows\winsxs\msil_system.xml_b77a5c561934e089_6.1.7601. 22733_none_3f30f47e1f9bb20d\System.XML.dll
                        C:\Windows\winsxs\msil_system.xml_b77a5c561934e089_6.1.7601. 22740_none_3f3239201f9a7e81\System.XML.dll
                        C:\Windows\winsxs\msil_system.xml_b77a5c561934e089_6.1.7601. 23290_none_3f373d2c1f95f8c6\System.XML.dll

                        Comment


                        • Well, the 4.0.30319 is the one it should find, and that matches mine.

                          I'm really stumped. There's been hundreds of people install and use this, and I don't think anyone has this problem.

                          I think we need to go back to your ScriptingReferences in settings.ini again. Because WeatherXML is a plug-in instead of a script, it doesn't really use the ScriptingReference line.

                          How about try this: Let's preserve your line, but put an exact copy of my line in there to see what happens. Put a semi-colon in front of the line you have there now, i.e. ;ScriptingReferences just to make it so it won't be found by the system. Now copy and paste this line into the file, like maybe just above the old line:
                          Code:
                          ScriptingReferences=System.Management;System.Management.dll,System.IO;System.dll,system.data;system.data.dll,ChartDirector;netchartdir.dll,System.XML;System.XML.dll,System.Drawing;System.Drawing.dll,System.Web;System.web.dll
                          Mine has some stuff you don't need, and probably is missing some stuff you need for other things. I don't think you need to restart Homeseer now, but it wouldn't hurt. Then try to run SnevlLatitude.vb again and let's see what happens. If it works, then we need to look at the formatting again.

                          Steve

                          Comment


                          • Well... I use an exact copy of your line and I have the same error.

                            Comment


                            • So, you made sure your old line didn't get used? If it used your line, pasting my line in didn't matter.

                              Comment


                              • I cut my old line and I pasted your new line ...

                                Comment

                                Working...
                                X