Announcement

Collapse
No announcement yet.

Snevl Latitude Version 2 Discussion

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • stevea
    replied
    Originally posted by prsmith777 View Post
    I must be missing something.

    How do I trigger a script based upon a change in the Near Places string? The device is always set to off. Ive tried value set to any, status set to any , etc and its not firing the trigger. I do have my.trigger plugin to check for string matches, but I was hoping there is something simple that I am missing.
    Paul,

    You are wanting to trigger of the combined near places device, not one of the individual person-to-place distance devices? I hadn't ever intended that. I guess I can change the code to turn the device ON when there are any near places, and OFF when there are none. Is that what you are looking for?

    Steve

    Leave a comment:


  • prsmith777
    replied
    I must be missing something.

    How do I trigger a script based upon a change in the Near Places string? The device is always set to off. Ive tried value set to any, status set to any , etc and its not firing the trigger. I do have my.trigger plugin to check for string matches, but I was hoping there is something simple that I am missing.

    Leave a comment:


  • Broes
    replied
    Originally posted by ShimmerNZ View Post
    Not sure if you are still having that problem, but I also experienced a similar issue. I never conclusively determined what the problem was but somewhere between making sure that each mobile device had it's own separate user/pass and also increasing the Location Polling timeout it fixed it. I suspect it was the later even though that sounds the least likely and don't understand how/why that might result in a authorization error on the backitude app.
    Thanks for the advice I just increased the Location Polling Timeout from 15 to 30 sec. See what happens...

    Leave a comment:


  • ShimmerNZ
    replied
    Originally posted by stevea View Post
    You shouldn't need a separate username / password for each device. Each device just needs its own device ID. Not sure what else was causing it. I haven't had any similar problem.

    Steve
    I had noticed that when I accessed HS externally from different PCs/IP addresses it would often prompt for a user/pass twice which I had thought might be causing the backitude app some grief. My logic was that maybe if it was a related to sessions that having two different devices authenticating with the same user/pass from separate IP addresses might be causing it. I think round the same time I also set the Inactivity Timeout setting on the Webserver to No after reading some older threads on the double http auth.

    Leave a comment:


  • ShimmerNZ
    replied
    ahh good to know. It had been driving me crazy turning of plugins and events trying to figure out what was causing the memory leak. In the end gave up and just scheduled a nightly HS restart and put it in the 'must figure out when I have some time' basket.

    Leave a comment:


  • stevea
    replied
    For everyone using either Backitude or Btraced. I think I've finally gotten some confirmation that the HS ASPX engine has a major leak. Each time your phone contacts HS via the ASPX pages for Backitude or Btraced, the handles and memory utilization will go up. Eventually your PC will run out of resources and you'll have to restart.

    Note that the leak is not in my ASPX pages. These are really simple pages that only receive the data from your device and pass it on to Snevl Latitude.

    Surprisingly, the advice from Rick T is to not use ASPX pages. A little confusing, since I thought at one time they said to stop using the older ASP. In fact, at one time they said that ASP were not going to be supported in HS3. Sigh. It's hard not to point out how silly this all is.

    Anyway, I've switched from using Backitude (and its ASPX page) to FollowMee and my HS2 Pro went from having to reboot every 1-2 days to easily going over a week (probably more than that most of the time, but I'm still gathering data).

    Steve

    Leave a comment:


  • stevea
    replied
    Originally posted by ShimmerNZ View Post
    Not sure if you are still having that problem, but I also experienced a similar issue. I never conclusively determined what the problem was but somewhere between making sure that each mobile device had it's own separate user/pass and also increasing the Location Polling timeout it fixed it. I suspect it was the later even though that sounds the least likely and don't understand how/why that might result in a authorization error on the backitude app.
    You shouldn't need a separate username / password for each device. Each device just needs its own device ID. Not sure what else was causing it. I haven't had any similar problem.

    Steve

    Leave a comment:


  • ShimmerNZ
    replied
    Originally posted by Broes View Post
    Steve,

    Occasionally it is working (also from external) but most of the time it isn't and then I get the error. So it is not a problem with the username/password.
    I have some points now in the track history log and I have a device now in the status list so this is working.

    Peter
    Not sure if you are still having that problem, but I also experienced a similar issue. I never conclusively determined what the problem was but somewhere between making sure that each mobile device had it's own separate user/pass and also increasing the Location Polling timeout it fixed it. I suspect it was the later even though that sounds the least likely and don't understand how/why that might result in a authorization error on the backitude app.

    Leave a comment:


  • Dhiren
    replied
    multiperson device question

    I'm sure this has been answered before so apologies for the double post but am unable to find so I figured i'd ask for some help.

    I'm trying to have HS turn off the sonos devices when house is armed stay and if neither my wife and I are home. I can do this by having individual rules that monitor the status of each the of the two devices but is it possible to use the multiperson device (#47) for this action ?

    Leave a comment:


  • Broes
    replied
    Steve,

    Occasionally it is working (also from external) but most of the time it isn't and then I get the error. So it is not a problem with the username/password.
    I have some points now in the track history log and I have a device now in the status list so this is working.

    Peter

    Leave a comment:


  • stevea
    replied
    Originally posted by Broes View Post
    Hi Steve,

    A while ago I asked you several questions because I didn't get it to work.
    I decided to let it rest for a little while but yesterday I re-installed Backitude and followed your Readme instruction step-by-step to install Snevl Latitude.
    I think but I am not sure that I forgot to save the initial settings (Step 8) in the SnevlLatitude.ini file
    So it is working now!
    The thing that I have to find out now is why I am getting errors from Backitude "Update failed (Authorization denied): HTTP/1.0 401".
    This error I am getting all the time when Backitude does automatically fire and now and then when I am firing manually (nothing in the HS log).
    And I don't see devices yet but maybe I have to restart HS.
    I will be back.

    Peter
    Peter,

    If you are getting Authorization denied, then Backitude isn't even getting past the log in on your HS web server. You either have the username / password entered wrong, or perhaps the web server is not even exposed to the Internet. Can you access your HS web server from the external internet? If so, try to log in from outside your home network using the username and password you set up in Backitude.

    The devices haven't been created yet because Snevl Latitude has not actually run yet. It is run once Backitude gets some data to Snevl Latitude for it to use. You can manually run the script one time to create the devices, if you wish. The more important issue is getting it so Backitude can actually log in to your server.

    Steve

    Leave a comment:


  • matt91
    replied
    Android Backitude update

    For those who use the Android Backitude app, has anyone played with this new feature?

    * import and export your configurations, open as attachments, download as custom URI from website


    I poked around in the app, but didn't see any way to export a configuration. It was a pain to deploy backitude to my wife's phone a few months ago, so having an external config file would make things much easier next time.

    (I realize this is really a Backitude, not Snevl Latitude, question, but I thought some of the folks here may have tried it already.)

    thanks as always,

    matt

    Leave a comment:


  • Broes
    replied
    Snevl Latitude working!

    Hi Steve,

    A while ago I asked you several questions because I didn't get it to work.
    I decided to let it rest for a little while but yesterday I re-installed Backitude and followed your Readme instruction step-by-step to install Snevl Latitude.
    I think but I am not sure that I forgot to save the initial settings (Step 8) in the SnevlLatitude.ini file
    So it is working now!
    The thing that I have to find out now is why I am getting errors from Backitude "Update failed (Authorization denied): HTTP/1.0 401".
    This error I am getting all the time when Backitude does automatically fire and now and then when I am firing manually (nothing in the HS log).
    And I don't see devices yet but maybe I have to restart HS.
    I will be back.

    Peter

    Leave a comment:


  • Stevieboy
    replied
    Snevl Latitude Version 2 Discussion



    Resent image as first one not very clear.

    Leave a comment:


  • Stevieboy
    replied
    Snevl Latitude Version 2 Discussion

    Hi Steve

    Started having this error occur in the log all the time. Script appears not to be generating an image. I am using Backitude/followmee

    Any suggestions ?

    Steve

    Leave a comment:

Working...
X