Announcement

Collapse
No announcement yet.

Arduino Script Testing. (Enigmatheatre)

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Morten,
    I can confirm: capacitors are solving my problem. In 2 day working no one false input reading.
    I'm using a 470nF capacitor for any input pin. No resistor added.
    You could arrive to 1uF or 10uF, but add a 47ohm resistor between pin and cable. You could have a delay of 1-5 millisecond.
    Inform me about your progress!

    Comment


    • How can I get the script for HS2 for this? I would like to try on my HS2 system before I make the leap to HS3.

      Comment


      • Originally posted by gdyrdave View Post
        How can I get the script for HS2 for this? I would like to try on my HS2 system before I make the leap to HS3.
        It is in the first post of this thread.

        Greig.
        Zwave = Z-Stick, 3xHSM100� 7xACT ZDM230, 1xEverspring SM103, 2xACT HomePro ZRP210.
        X10 = CM12U, 2xAM12, 1xAW10, 1 x TM13U, 1xMS13, 2xHR10, 2xSS13
        Other Hardware = ADI Ocelot + secu16, Global Cache GC100, RFXtrx433, 3 x Foscams.
        Plugings = RFXcom, ActiveBackup, Applied Digital Ocelot, BLDeviceMatrix, BLGarbage, BLLAN, Current Cost, Global Cache GC100,HSTouch Android, HSTouch Server, HSTouch Server Unlimited, NetCAM, PowerTrigger, SageWebcamXP, SqueezeBox, X10 CM11A/CM12U.
        Scripts =
        Various

        Comment


        • Originally posted by enigmatheatre View Post
          It is in the first post of this thread.

          Greig.
          Thanks Greig.

          Dave

          Comment


          • Well I got this working with a board we use for Christmas lighting. It has an onboard NRF board and is very small. I have 3 DS18B20's and a couple outputs and inputs. I am now reviewing the sketch so I can transmit and receive between this board and another located at HS2 system. We call the boards RF1's. The one problem is it doesn't reconnect on startup. I have to disconnect then reconnect and press the reset button for the communication. Working on that problem but otherwise working great.

            Comment


            • Arduino Script Testing. (Enigmatheatre)

              Funny to see you over here Dave. I only landed on this thread because I saw your mention of the rf1. (I'm jchuchla over on the Christmas forums). I guess great minds think alike.


              -- Jon Chuchla --

              Sent from my iPad using Tapatalk

              Comment


              • Yes thats funny. Trying to cut the cord by using 2 RF1's. I need to make a transciever out of this code and make another plain tranciever for the HS2 side. I have been using HS since 2001. And it evolved for 3 homes. This is my last home now. I want to monitor the solar heater for the pool and ultimately be able to open or close the valve to the panels and ultimately be able to monitor the pH and control the pump. After that maybe some other things too like the neighbors home across the street. Can't upgrade to HS3 yet because there are plugins I use that aren't compatable. Nice to see you here.

                Dave

                Comment


                • Is there anyway to change the baud rate in Homeseer lower. like 57600 or lower? I know I can change it in the .ino file but in the Homeseer PC.
                  I want to use it with Xbee's and I think 115200 is too fast for the radios. Is the source for the (vben) script available or can someone change it for me. From 9600 to 115200. Thanks
                  Last edited by gdyrdave; April 15th, 2014, 06:38 PM.

                  Comment


                  • Is this thread still alive????

                    Comment


                    • Originally posted by gdyrdave View Post
                      Is this thread still alive????
                      Sorry for not replying sooner but life is very busy at the moment.
                      In answer to your question No it is hard coded in to the script and I have stopped working on HS2 in replacement of my HS3 plugin found HERE. I could add this as an option in the plugin for HS3 if you would like but I cant give a time because as I said before life is taking over the Hobby.

                      Sorry,

                      Greig.
                      Zwave = Z-Stick, 3xHSM100� 7xACT ZDM230, 1xEverspring SM103, 2xACT HomePro ZRP210.
                      X10 = CM12U, 2xAM12, 1xAW10, 1 x TM13U, 1xMS13, 2xHR10, 2xSS13
                      Other Hardware = ADI Ocelot + secu16, Global Cache GC100, RFXtrx433, 3 x Foscams.
                      Plugings = RFXcom, ActiveBackup, Applied Digital Ocelot, BLDeviceMatrix, BLGarbage, BLLAN, Current Cost, Global Cache GC100,HSTouch Android, HSTouch Server, HSTouch Server Unlimited, NetCAM, PowerTrigger, SageWebcamXP, SqueezeBox, X10 CM11A/CM12U.
                      Scripts =
                      Various

                      Comment


                      • This may be a stupid question, but will the HS3 plug work with HS2 or are they totally different?

                        Comment


                        • Originally posted by gdyrdave View Post
                          This may be a stupid question, but will the HS3 plug work with HS2 or are they totally different?
                          There is not such a thing as a stupid question if you don't know the answer.
                          The script for HS2 was rewritten and converted in to a full plugin for HS3 so it is much easier to use so no it is not compatible with HS2.

                          Greig.
                          Zwave = Z-Stick, 3xHSM100� 7xACT ZDM230, 1xEverspring SM103, 2xACT HomePro ZRP210.
                          X10 = CM12U, 2xAM12, 1xAW10, 1 x TM13U, 1xMS13, 2xHR10, 2xSS13
                          Other Hardware = ADI Ocelot + secu16, Global Cache GC100, RFXtrx433, 3 x Foscams.
                          Plugings = RFXcom, ActiveBackup, Applied Digital Ocelot, BLDeviceMatrix, BLGarbage, BLLAN, Current Cost, Global Cache GC100,HSTouch Android, HSTouch Server, HSTouch Server Unlimited, NetCAM, PowerTrigger, SageWebcamXP, SqueezeBox, X10 CM11A/CM12U.
                          Scripts =
                          Various

                          Comment


                          • Thanks Greig. I would move up to HS3 but there are a few plugins I use that haven't been ported to HS3 yet or will never be ported. I just need to slow the transmission rate to the Xbees. Getting a lot of garbage transmissions between the 2 at 115200. Just wish I could change it to 9600 for a test.

                            Comment


                            • If I have time and more to the point can find the code as I have a hard drive fail a while back and am not sure what I have recovered then I will have a look and send you a changed copy.

                              But there are no promises on time or if this will happen.

                              Greig.
                              Zwave = Z-Stick, 3xHSM100� 7xACT ZDM230, 1xEverspring SM103, 2xACT HomePro ZRP210.
                              X10 = CM12U, 2xAM12, 1xAW10, 1 x TM13U, 1xMS13, 2xHR10, 2xSS13
                              Other Hardware = ADI Ocelot + secu16, Global Cache GC100, RFXtrx433, 3 x Foscams.
                              Plugings = RFXcom, ActiveBackup, Applied Digital Ocelot, BLDeviceMatrix, BLGarbage, BLLAN, Current Cost, Global Cache GC100,HSTouch Android, HSTouch Server, HSTouch Server Unlimited, NetCAM, PowerTrigger, SageWebcamXP, SqueezeBox, X10 CM11A/CM12U.
                              Scripts =
                              Various

                              Comment


                              • Thanks alot Greig. I appreciate this. I will eventually upgrade to 3 after I figure out how to bypass the plugin problem. I am redoing a system with a fresh W7 system and HS3. Will test the new version of your plugin on it. This was a fantastic idea and great plug.

                                Thanks again

                                Comment

                                Working...
                                X