Announcement

Collapse
No announcement yet.

Arduino Script Testing. (Enigmatheatre)

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • gdyrdave
    replied
    I figured it out. I moved the Baud=57600 under the settings rather than under the board settings. It initializes to 57600 as expected. Thanks. Will test it with the Xbees.

    Leave a comment:


  • gdyrdave
    replied
    As my post above I have set the Baud=57600. It still initialized to 115200. Shouldn't the log file reflect that? I also verified it is indeed set to 115200 using the posted ini file. Maybe I am not seeing something.

    Leave a comment:


  • enigmatheatre
    replied
    I had a quick look and I have set this as a global setting for all boards so if you add "Baud" to Settings in the ini it should work.

    Greig.

    Leave a comment:


  • gdyrdave
    replied
    Just tried it, it stays at 115200.

    4/26/2014 8:18:00 AM Arduino Connecting to Arduino Board 1 on Com Port=14 baud= 115200 Parity= 0 DataBits= 8 stopBits= 1
    4/26/2014 8:17:46 AM Arduino Connecting to Arduino Board 1 on Com Port=14 baud= 115200 Parity= 0 DataBits= 8 stopBits= 1

    The ini file:


    [Settings]
    Logging =0
    No of Boards=1



    [Board1]
    Com port=14
    Baud=57600

    Board Address=1
    Board Code=D1
    No Of Inputs=0
    No Of Analogue=0
    No Of Outputs=0
    No Of PwmOutputs=0


    Lcd Width=16
    Lcd Hight=2
    Lcd Clear=1

    RomAddress,28D9158D05000093=D9
    RomAddress,28E2218D0500101D=D2

    Leave a comment:


  • gdyrdave
    replied
    We'll give it a try. Thanks Greig.

    Leave a comment:


  • enigmatheatre
    replied
    Sorry gdyrdave I think there was a problem when I compiled the code as I am a little rusty with HS2 now.
    Try the attached version.

    Greig.
    Attached Files

    Leave a comment:


  • enigmatheatre
    replied
    Originally posted by gdyrdave View Post
    Thanks Greig. I did not see that in the HS2 manual I have. I'll look again. Any idea about the error message on the version you sent me. I am testing it now with the earlier version at 115200 directly connected.
    Not to sure why the error is there I will see what I can do.

    Greig.

    Leave a comment:


  • gdyrdave
    replied
    OK...Egg on my face...I found it in the manual. I guess I was too excited on getting the Ph to read into HS2. Sorry about that.

    Leave a comment:


  • gdyrdave
    replied
    Thanks Greig. I did not see that in the HS2 manual I have. I'll look again. Any idea about the error message on the version you sent me. I am testing it now with the earlier version at 115200 directly connected.

    Leave a comment:


  • enigmatheatre
    replied
    Originally posted by gdyrdave View Post
    How do you write to an lcd. Event??? Script???

    Leave a comment:


  • gdyrdave
    replied
    How do you write to an lcd. Event??? Script???

    Leave a comment:


  • gdyrdave
    replied
    More progress. I went back to the original vben file and configured the sketch for 115200. I directly connected it to the HS computer. Didn't see the Ph reading it was transmitting. So I changed the arduino sketch so the ph value was transmitted like the one wire devices. I changed the output string to transmit Rom instead of Ph1 and put an arbitrary Hex address field. Low and behold I have the Ph reading in Homeseer. Now if we can get the baud rate script working I am home free. Well for a while....lol

    Mrhappy, I think I may have a use for your samples you posted.


    dave

    Leave a comment:


  • gdyrdave
    replied

    Leave a comment:


  • gdyrdave
    replied
    I replaced the .vben file, edited the ini file added Baud=57600. When HS starts up I get an error that says Running script arduino.vben : method not found. here is the ini file:


    [Settings]
    Logging =0
    No of Boards=1



    [Board1]
    Com port=15
    Baud=57600

    Board Address=1
    Board Code=D1
    No Of Inputs=0
    No Of Analogue=0
    No Of Outputs=0
    No Of PwmOutputs=0


    Lcd Width=16
    Lcd Hight=2
    Lcd Clear=1

    RomAddress,2810D38C050000AB=D7
    RomAddress,28E2218D0500001D=D8
    RomAddress,28D9158D05000093=D9

    Leave a comment:


  • gdyrdave
    replied
    Thanks Greig. I'll let you know.

    Dave

    Leave a comment:

Working...
X