Announcement

Collapse
No announcement yet.

Arduino Script Testing. (Enigmatheatre)

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • #61
    Connect them to GND.

    I add a pullup resistor because they tend to tease, but it should not be necessary.

    Regards
    Morten

    Comment


    • #62
      Setting pin to ground makes no difference

      I have the same status when I connect the pin to ground (0 volt). I have no pullup resistor though... Thought I would see some kind of reaction in status on fiddeling with 0 and 5 volt on the input...?

      Comment


      • #63
        That's strange. The only thing I can think of is, do you remember to refresh the status page?

        Try looking at the log.

        The pullup resistor isn't needed unless you get a lot of on/off changes.

        Comment


        • #64
          Originally posted by FredrikKan View Post
          Hi again!
          Output pins are working, 1-wire is working - now it's time for the next option!
          I have assigned three pins for input;

          Connected to Board 1 on Com port 6
          Board 1, Input 3, Value = Off
          Board 1, Input 2, Value = Off
          Board 1, Input 1, Value = Off

          I then apply 5 volt to one (or any) of the input pins and check for result in Homeseer.
          After trying several times I have now concluded that the input pins I have
          assigned does not trigger a status change on the corresponding devices in Homeseer.

          Status of one of the devices after applying 5 volt;
          <TABLE border=1 cellSpacing=0 cellPadding=0 width="100%"><TBODY><TR><TD class=tableroweven align=left>Reference ID</TD><TD class=tableroweven colSpan=9 align=left>4482</TD></TR><TR><TD class=tablerowodd align=left>Status</TD><TD class=tablerowodd colSpan=9 align=left>17 = Unknown</TD></TR><TR><TD class=tableroweven align=left>Value</TD><TD class=tableroweven colSpan=9 align=left>1 = "Off" </TD></TR><TR><TD class=tablerowodd align=left>String</TD><TD class=tablerowodd colSpan=9 align=left></TD></TR><TR><TD class=tableroweven align=left>Supports Status</TD><TD class=tableroweven colSpan=9 align=left>False</TD></TR><TR><TD class=tablerowodd align=left>Dimmable</TD><TD class=tablerowodd colSpan=9 align=left>False</TD></TR><TR><TD class=tableroweven align=left>Misc Settings</TD><TD class=tableroweven colSpan=9 align=left>Status Only</TD></TR></TBODY></TABLE>

          Any tips are appreciated!

          Fredrik
          Hi Fredrik

          Can you send me your ino and ini and I will see if I can solve your strange problem.

          Greig.
          Zwave = Z-Stick, 3xHSM100� 7xACT ZDM230, 1xEverspring SM103, 2xACT HomePro ZRP210.
          X10 = CM12U, 2xAM12, 1xAW10, 1 x TM13U, 1xMS13, 2xHR10, 2xSS13
          Other Hardware = ADI Ocelot + secu16, Global Cache GC100, RFXtrx433, 3 x Foscams.
          Plugings = RFXcom, ActiveBackup, Applied Digital Ocelot, BLDeviceMatrix, BLGarbage, BLLAN, Current Cost, Global Cache GC100,HSTouch Android, HSTouch Server, HSTouch Server Unlimited, NetCAM, PowerTrigger, SageWebcamXP, SqueezeBox, X10 CM11A/CM12U.
          Scripts =
          Various

          Comment


          • #65
            Fredrik,

            Is there anything in the log when you change the inputs?
            I have just read over your post again and the script will not change the device status as it changes the Value and not the status because this is being removed in HS3.
            Is the Value changing?

            Greig.
            Zwave = Z-Stick, 3xHSM100� 7xACT ZDM230, 1xEverspring SM103, 2xACT HomePro ZRP210.
            X10 = CM12U, 2xAM12, 1xAW10, 1 x TM13U, 1xMS13, 2xHR10, 2xSS13
            Other Hardware = ADI Ocelot + secu16, Global Cache GC100, RFXtrx433, 3 x Foscams.
            Plugings = RFXcom, ActiveBackup, Applied Digital Ocelot, BLDeviceMatrix, BLGarbage, BLLAN, Current Cost, Global Cache GC100,HSTouch Android, HSTouch Server, HSTouch Server Unlimited, NetCAM, PowerTrigger, SageWebcamXP, SqueezeBox, X10 CM11A/CM12U.
            Scripts =
            Various

            Comment


            • #66
              I add a Lcd 16x2 and now when the temp change on any temp sensor this value is displayed
              Great script !

              Comment


              • #67

                Comment


                • #68
                  Hi Fredrik,

                  My e-maill address is in the user manual if you cant attach the files to the post as you may need to have posted more than you have to be alowed.

                  Greig.
                  Zwave = Z-Stick, 3xHSM100� 7xACT ZDM230, 1xEverspring SM103, 2xACT HomePro ZRP210.
                  X10 = CM12U, 2xAM12, 1xAW10, 1 x TM13U, 1xMS13, 2xHR10, 2xSS13
                  Other Hardware = ADI Ocelot + secu16, Global Cache GC100, RFXtrx433, 3 x Foscams.
                  Plugings = RFXcom, ActiveBackup, Applied Digital Ocelot, BLDeviceMatrix, BLGarbage, BLLAN, Current Cost, Global Cache GC100,HSTouch Android, HSTouch Server, HSTouch Server Unlimited, NetCAM, PowerTrigger, SageWebcamXP, SqueezeBox, X10 CM11A/CM12U.
                  Scripts =
                  Various

                  Comment


                  • #69
                    Thanks Greig,
                    I've sent the files to you now!
                    Best Regards,
                    Fredrik.

                    Comment


                    • #70

                      Comment


                      • #71
                        I just stumbled across this. Great project! I've been trying different solutions for putting some I/O around the house but this is exactly what I wanted. If you ever get the Ethernet working it will be even better.

                        A quick question - I have a need to read a fair number of analog (0-5V) inputs. Which of the supported boards would be best for that?

                        Comment


                        • #72
                          Looking at the Arduino Mega 2560 R3

                          It has 16 analog inputs. Should that board work?

                          Glenn

                          Comment


                          • #73
                            Originally posted by acromion View Post
                            Looking at the Arduino Mega 2560 R3

                            It has 16 analog inputs. Should that board work?

                            Glenn
                            Yes I have a mega as my main board and a nano for my onewire bus.

                            Greig.

                            Sent from my Nexus 7 using Tapatalk HD
                            Last edited by enigmatheatre; May 14th, 2013, 06:25 PM.
                            Zwave = Z-Stick, 3xHSM100� 7xACT ZDM230, 1xEverspring SM103, 2xACT HomePro ZRP210.
                            X10 = CM12U, 2xAM12, 1xAW10, 1 x TM13U, 1xMS13, 2xHR10, 2xSS13
                            Other Hardware = ADI Ocelot + secu16, Global Cache GC100, RFXtrx433, 3 x Foscams.
                            Plugings = RFXcom, ActiveBackup, Applied Digital Ocelot, BLDeviceMatrix, BLGarbage, BLLAN, Current Cost, Global Cache GC100,HSTouch Android, HSTouch Server, HSTouch Server Unlimited, NetCAM, PowerTrigger, SageWebcamXP, SqueezeBox, X10 CM11A/CM12U.
                            Scripts =
                            Various

                            Comment


                            • #74
                              anemometer!

                              Hello,
                              *** I would like to connect to the Arduino an anemometer.
                              This could be a solution:

                              Code:
                              volatile byte count;
                              
                              unsigned int duration;
                              
                              unsigned long timePrevious;
                              
                              float windSpeed = 0;
                              
                              int windVein = 0; 
                              
                              void setup()
                              {
                                Serial.begin(9600);
                                attachInterrupt(0, arduino_anemometer, RISING);
                              
                                count = 0;
                                duration = 0;
                                timePrevious = 0;
                              }
                              
                              void loop()
                              {
                                
                                windVein = (analogRead(windVein));
                                if (count >= 1) { 
                                  duration = (millis() - timePrevious);
                                  timePrevious = millis();
                                  count = 0;
                                  windSpeed = (1492/duration);
                                  Serial.print(windSpeed,DEC);
                                  Serial.print(" MPH");
                                  Serial.print(",");
                                  Serial.println(windVein);
                                }
                              }
                              
                              void arduino_anemometer()
                              {
                                count++;
                              I'd like to include this part of code in your sketch.
                              Do you think that could work?
                              How do I "connect" the result value of arduino to your plugin and visualize data on HomeSeer?

                              Thanks!

                              Cris

                              Comment


                              • #75
                                Originally posted by khriss75 View Post
                                Hello,
                                *** I would like to connect to the Arduino an anemometer.
                                This could be a solution:

                                Code:
                                volatile byte count;
                                
                                unsigned int duration;
                                
                                unsigned long timePrevious;
                                
                                float windSpeed = 0;
                                
                                int windVein = 0; 
                                
                                void setup()
                                {
                                  Serial.begin(9600);
                                  attachInterrupt(0, arduino_anemometer, RISING);
                                
                                  count = 0;
                                  duration = 0;
                                  timePrevious = 0;
                                }
                                
                                void loop()
                                {
                                  
                                  windVein = (analogRead(windVein));
                                  if (count >= 1) { 
                                    duration = (millis() - timePrevious);
                                    timePrevious = millis();
                                    count = 0;
                                    windSpeed = (1492/duration);
                                    Serial.print(windSpeed,DEC);
                                    Serial.print(" MPH");
                                    Serial.print(",");
                                    Serial.println(windVein);
                                  }
                                }
                                
                                void arduino_anemometer()
                                {
                                  count++;
                                I'd like to include this part of code in your sketch.
                                Do you think that could work?
                                How do I "connect" the result value of arduino to your plugin and visualize data on HomeSeer?

                                Thanks!

                                Cris
                                HI,Cris,

                                I can add this to the script but there is a very very long list of requests from people that would like lots of different devices. I think I may need to add a ad Hoc area to the script that people can modify with there own devices and update homeseer.
                                I will need to look in to this and I also still need to work on the Ethernet interface but i have so much work and so little time.

                                Greig.
                                Zwave = Z-Stick, 3xHSM100� 7xACT ZDM230, 1xEverspring SM103, 2xACT HomePro ZRP210.
                                X10 = CM12U, 2xAM12, 1xAW10, 1 x TM13U, 1xMS13, 2xHR10, 2xSS13
                                Other Hardware = ADI Ocelot + secu16, Global Cache GC100, RFXtrx433, 3 x Foscams.
                                Plugings = RFXcom, ActiveBackup, Applied Digital Ocelot, BLDeviceMatrix, BLGarbage, BLLAN, Current Cost, Global Cache GC100,HSTouch Android, HSTouch Server, HSTouch Server Unlimited, NetCAM, PowerTrigger, SageWebcamXP, SqueezeBox, X10 CM11A/CM12U.
                                Scripts =
                                Various

                                Comment

                                Working...
                                X