Announcement

Collapse
No announcement yet.

World Tides

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • #46
    Hello again!

    I had an error in the site location. When I cut and pasted the location, it truncated the last 8 characters for some reason.

    Everything works great now!!!

    Best regards,
    -Todd

    ____________________________________________________________ ________________
    HS2Pro: 2.5.0.81 :: HS3Pro (beta) || Plugins:| SmartHome PowerLinc USB, Global Cache, BLBackup, DooCPU Monitor, DooMotion, BLOutlook, BLIcon, BLOutgoingCalls, OutgoingCalls, ROC-Rnd, HSTouch iPhone, UPS Monitor, DooMenuBar, BLSpeech, HSTouch Server, WAF AB8SS, mcsTemperature, VWS, BLChart, RFXCOM, ISY Insteon, iAutomate RFID, iTunes, NetCAM, DSC Security, Nest

    Comment


    • #47
      Good. Thanks for letting me know. I will have to see about trapping that error though.
      Wow! Only .3 feet difference between low and high tides. Here we get 14 meters.
      Real courage is not securing your Wi-Fi network.

      Comment


      • #48
        Just spent two hours working on an HS3 version, when I realized I'd already done it.
        Working for everyone?
        Real courage is not securing your Wi-Fi network.

        Comment


        • #49
          When I upgraded my HS3 test machine to v3.0.0.147 I discovered a change had been made from v3.0.0.143 which made locating the Tides device inoperative, generating log errors and terminating the script. v1.4.2 of the script corrects the problem under HS3. No change is required if running HS2, although this version is still compatible.
          Also, added optional configuration of graphics files to be used.
          Only the script file needs to be replaced. If you're happy with the graphics as is, no other action is required. To change this, see the addendum.txt file.
          Real courage is not securing your Wi-Fi network.

          Comment


          • #50
            The site, 'tbone.biol.sc.edu', seems to have gone down last night (Christmas Eve); bound to happen sooner or later. I'm hoping this is temporary, but if not, I think there are alternatives and I should be able to adjust the script in time.
            Last edited by Wadenut; December 25th, 2015, 05:25 AM.
            Real courage is not securing your Wi-Fi network.

            Comment


            • #51
              v1.5.1 is available.
              The site tbone.edu went down sometime around December 24th 2015. This required a bit of a re-write which also enabled a few improvements to the operation of the script and presentation of data.
              Note that the configuration procedure has changed so it is advisable to disable the existing event during the reconfiguration process. In addition it might be advisable to delete your existing data file to avoid any possible errors. The documentation has been updated to aid in the installation/transition process.

              Note that the new site may or may not provide Sun and Moon Rise/Set times for a given location.

              Enjoy.
              Real courage is not securing your Wi-Fi network.

              Comment


              • #52
                Hi Wadenut,
                Thanks for your work on this. I'm running HS2 and I think I'm having issues with the translation. I'm getting error messages telling me the defined device name doesn't exist.

                My old config fiile was:
                [Config]
                Site = http://tbone.biol.sc.edu/tide/tidesh...=f&type=mobile
                Device= V18
                ShowNum =6
                ShowPrevious = True
                ShowTimeTo = True
                Graphic = True
                SunRiseDev = W6
                SunSetDev = W7
                MoonRiseDev = W8
                MoonSetDev = W9
                [Data]
                Units=feet
                LDL=12/30/2015 8:20:08 AM

                My new config file is:
                [Config]
                Site = 1384
                DLInt =24
                ShowMax = 6
                Device=Cotuit Highlands Tides
                SunRiseDev = w6
                SunSetDev = w7
                MoonRiseDev = Almanac MoonRise Time
                MoonSetDev = Almanac MoonSet Time
                ShowTimeTo = True
                Graphic = False
                [Data]
                Units=meters

                I get errors both using Cotuit Highlands Tides and v18 for the device. I also get errors for sun and moon rises:
                <TABLE cellSpacing=2 cellPadding=0 width="100%" border=0> <TBODY> <TR> <TD class=LOGDateTime0 noWrap align=left>12/30/2015 9:08:46 AM </TD> <TD class=LOGType0 colSpan=3 align=left>WorldTides </TD> <TD class=LOGEntry0 colSpan=8 align=left>Error: Defined Device Name 'Almanac MoonSet Time' does not exist</TD></TR> <TR> <TD class=LOGDateTime1 noWrap align=left>12/30/2015 9:08:46 AM </TD> <TD class=LOGType1 colSpan=3 align=left>WorldTides </TD> <TD class=LOGEntry1 colSpan=8 align=left>Error: Defined Device Name 'Almanac MoonRise Time' does not exist</TD></TR> <TR> <TD class=LOGDateTime0 noWrap align=left>12/30/2015 9:08:46 AM </TD> <TD class=LOGType0 colSpan=3 align=left>WorldTides </TD> <TD class=LOGEntry0 colSpan=8 align=left>Error: Defined Device Name 'w7' does not exist</TD></TR> <TR> <TD class=LOGDateTime1 noWrap align=left>12/30/2015 9:08:46 AM </TD> <TD class=LOGType1 colSpan=3 align=left>WorldTides </TD> <TD class=LOGEntry1 colSpan=8 align=left>Error: Defined Device Name 'w6' does not exist</TD></TR> <TR> <TD class=LOGDateTime0 noWrap align=left>12/30/2015 9:08:46 AM </TD> <TD class=LOGType0 colSpan=3 align=left>WorldTides </TD> <TD class=LOGEntry0 colSpan=8 align=left>Error: Defined Device Name 'Cotuit Highlands Tides' does not exist.</TD></TR></TBODY></TABLE>


                Any idea what I should do? Thanks and happy new year
                Jono

                Comment


                • #53
                  You may as well remove the references to the Moon Rise and Set Device for the time being. That information isn't provided by the site. I left the code in place in case the data ever does become available.

                  The script will be looking for a device "Cotuit Highlands Tides" where the Location 1/Room will be "Cotuit" and the device name "Highlands Tides".
                  I think you need to include the actual room/location for your device. Thus the config entry will look like "MyRoom Cotuit Highlands Tides".

                  Your Sunrise/SunSet devices need to be similarly named in the config. Device Code will not work. Also note that unless your location provides Sun data, no data will be available.
                  Real courage is not securing your Wi-Fi network.

                  Comment


                  • #54
                    thanks, that fixed it!

                    Comment


                    • #55
                      Originally posted by jono View Post
                      thanks, that fixed it!
                      Great. Actually I would have preferred to have used House/Unit codes. I had to compromise to make the script compatible with HS2 & HS3 simultaneously.
                      Real courage is not securing your Wi-Fi network.

                      Comment


                      • #56
                        v1.5.2 uploaded. A change to the website around January 1 broke the previous version. Fixed.
                        Real courage is not securing your Wi-Fi network.

                        Comment


                        • #57
                          Looks like a fun script. I'm getting this error:

                          Running script C:\Program Files (x86)\HomeSeer HS3\scripts\WorldTides.vben :Exception has been thrown by the target of an invocation.String was not recognized as a valid DateTime.

                          My .ini:


                          [Config]
                          Site = 678
                          DLInt =24
                          ShowMax = 30
                          Device= Unknown Almanac Tide Times
                          SunRiseDev =
                          SunSetDev =
                          MoonRiseDev = Unknown Almanac Moon Rise Time
                          MoonSetDev = Unknown Almanac Moon Set Time
                          ShowTimeTo = True
                          Graphic = True
                          [Data]
                          LDL=1/4/2019 12:58:39 PM
                          Units=Feet

                          The floor is "Unknown" and the device names are "Almanac Moon Rise Time", etc. The tieds device isn't getting populated but the moon rise times are. Funny, they got populated before I added the floor name. That naming part of the instructions was a little unclear to me until I read through this thread.
                          Originally posted by rprade
                          There is no rhyme or reason to the anarchy a defective Z-Wave device can cause

                          Comment


                          • #58
                            Originally posted by Wadenut
                            Did you have this problem prior to running this current version?
                            Can you try Site = 3799 and see if the problem persists there I'm hoping there isn't inconsistency in the data format between sites.
                            The issue I had was that previously, the data had included the Day Of Week. It's been omitted now, but may not be in your area as yet.
                            If this is the case, I may have some more work to do.

                            If the error just began showing up after upgrading, and your data file contained current data, it is possible it may work itself out once any current data has expired and a new download occurs.
                            I set it to 3799 and I get the same error. I have never tried to use this script before today so it's highly likely that I have something screwed up.
                            Originally posted by rprade
                            There is no rhyme or reason to the anarchy a defective Z-Wave device can cause

                            Comment


                            • #59
                              If this just began when you upgraded to this version, you may need to clear your data file.

                              Disable your event

                              In Notepad, open \Config\WorldTides.ini
                              There'll be a line similar to : LDL =1/4/2019 12:48:57 PM
                              Change the year, 2019 to 2018 to force an immediate download.
                              Save the file

                              Similarly, edit \Data\TideTables\WorldTideTable.csv (Be sure to use Notepad).
                              Delete all of the data and save the empty file.

                              Re-enable the event.
                              It will take up to 12 hours for Current Tide Level to be calculated, but the rest of the data should populate.

                              I'll be able to try your site sometime tomorrow.
                              Real courage is not securing your Wi-Fi network.

                              Comment


                              • #60
                                OK. I just changed the year to 2018, ran the event and didn't get the error. The WorldTideTable.csv had nothing in it. It was completely blank. That's using notepad.

                                Just to be clear, I have never used this script before today. I'll keep you updated as to anything odd that may be occurring.

                                Thanks!


                                EDIT: Immediately upon making that change the Almanac Tide Times device is populated! The moon rise and set have changed as well. Looks like it rises and sets a little earlier up there.

                                EDIT 2:

                                Just changed the side back to 672 (or whatever it was), ran the event and no error.


                                EDIT 3:

                                Nope. I changed everything back. For some reason it got set to meters instead of feet in the .ini; not sure how that happened. I set it to feet and it displayed that same number but said feet not meters. So I deleted everything from the .csv, changed the year to 2018 again, ran the event and got 2 errors. The same one as before and a new one. There is now no .csv in the data directory, which I find odd.

                                Running script C:\Program Files (x86)\HomeSeer HS3\scripts\WorldTides.vben :Exception has been thrown by the target of an invocation.Argument 'Length' must be greater or equal to zero.
                                Attached Files
                                Originally posted by rprade
                                There is no rhyme or reason to the anarchy a defective Z-Wave device can cause

                                Comment

                                Working...
                                X