Announcement

Collapse
No announcement yet.

Can not control simple device using 'Immidiate Script Command'

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Can not control simple device using 'Immidiate Script Command'

    I am experimenting how to control one of my devices using the 'Immidiate Script Command'-function in HS2 (and in a later stadium put these lines in a script).

    When I put the text <!--StartFragment -->{&hs.SetDeviceStatus "[1", on} (without {/}) in the textbox and I click the 'Execute command'-button, an error like 'running script; init errir: syntaxisfout' appears.

    When i put in the text {&hs.SetDeviceStatus "[1", off}, I don't get an error, but nothing happend as well.

    Can someone please tell me what i'm doing wrong?

  • #2
    Originally posted by Jaco View Post
    I am experimenting how to control one of my devices using the 'Immidiate Script Command'-function in HS2 (and in a later stadium put these lines in a script).

    When I put the text <!--StartFragment -->{&hs.SetDeviceStatus "[1", on} (without {/}) in the textbox and I click the 'Execute command'-button, an error like 'running script; init errir: syntaxisfout' appears.

    When i put in the text {&hs.SetDeviceStatus "[1", off}, I don't get an error, but nothing happend as well.

    Can someone please tell me what i'm doing wrong?
    Is this HS3? If so it's a known issue. Bug 1949. Add your name to it and it might get some attention.
    Originally posted by rprade
    There is no rhyme or reason to the anarchy a defective Z-Wave device can cause

    Comment


    • #3
      No, it's on HS2....

      Comment


      • #4
        Setdevicestatus only accepts 2,3,4 and 17 for second parameter. IIRC 2 is on,3 is off, 4 is dim and 17 is unknown.
        My Plugins:

        Pushover 3P | DoorBird 3P | Current Cost 3P | Velleman K8055 3P | LAMetric 3P | Garadget 3P | Hive 3P |
        Yeelight 3P | Nanoleaf 3P

        Comment

        Working...
        X