Announcement

Collapse
No announcement yet.

IP / Serial Plugin for HS3 (by "drule") - Discussion Thread

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • thoughts in the back of my silly mind tell me I no longer need the GCIR plug-in and can operate direct
    Ubuntu on the Intel NUC ( 8i5BEK ), 32 G, 250G SSD, V4 Pro

    Comment


    • trying SONY..
      Attached Files
      Ubuntu on the Intel NUC ( 8i5BEK ), 32 G, 250G SSD, V4 Pro

      Comment


      • Here's me trying to make connections to my
        Sony ( RS-232 thru GC-100 )
        Onkyo's ( Living Room, Master B/R ) ( IP )

        all show connected, log shows onkyo's not
        Attached Files
        Ubuntu on the Intel NUC ( 8i5BEK ), 32 G, 250G SSD, V4 Pro

        Comment


        • If your Onkyos support native IP, why do you need the GC-100 at all? I am sure that you need a port for all IP connections, so that's probably why they aren't connecting. I have a Pioneer Elite receiver and I can connect directly to it via the plugin and fire simple text commands at it. See the example .ini file in the Zip in the release thread on how it is configured. Unfortunately I don't know how the Onkyo IP control works.
          cheeryfool

          Comment


          • I think you are right... working backwards
            orig config = serial software = gc-100= TWA plug-in = Onkyo (serial)

            now new receivers are ip.. looks like I don't need anything but plug-in !!

            GC-100 will be for serial to SONY TV
            Attached Files
            Ubuntu on the Intel NUC ( 8i5BEK ), 32 G, 250G SSD, V4 Pro

            Comment


            • Originally posted by gearyt View Post
              I think you are right... working backwards

              orig config = serial software = gc-100= TWA plug-in = Onkyo (serial)



              now new receivers are ip.. looks like I don't need anything but plug-in !!



              GC-100 will be for serial to SONY TV

              That looks better. Hopefully the commands are simple and not wrapped in some ugly protocol like the Sammy TVs
              cheeryfool

              Comment


              • found the Onkyo Code and Spec spreadsheet

                http://files.remotecentral.com/downl...eiver.zip.html
                Attached Files
                Ubuntu on the Intel NUC ( 8i5BEK ), 32 G, 250G SSD, V4 Pro

                Comment


                • we will see if this works !! Note: Different Onkyo Models have different EOL's
                  Attached Files
                  Ubuntu on the Intel NUC ( 8i5BEK ), 32 G, 250G SSD, V4 Pro

                  Comment


                  • Originally posted by gearyt View Post
                    we will see if this works !! Note: Different Onkyo Models have different EOL's
                    If those don't work, try what I use for my Pioneer:

                    Type = C-Escaped
                    Carriage Return = \r

                    So your standby command would read:

                    !1PWR00\r

                    Hopefully it's as simple as this, but this thread (perhaps for a different model) suggests it might be more complex

                    Please post all your model numbers of the various components that you still need to automate
                    cheeryfool

                    Comment


                    • As a beginner to com-port commands I have some questions which I hope you can help me out.

                      I've tried this plugin to send commands to my Russound Cam 6.6. This is connected via a direct serial cable (that used to work under HS2). In the plugin I've put type as Serial, Client, address at 3 (reflecting com3) and leave port blank. Are these the right settings?

                      The documentation of Russound shows that the com-port should be 19200 baud, 1 start bit, 1 stop bit, no flow control, no parity. So I set the serial ports in the plug-in to: 19200, 8, 1, none, none, 1...

                      One of the commands I tried to send was to open Zone 1, the HEX codes were:

                      F0 00 00 7F 00 00 70 05 02 02 00 00 F1 23 00 01 00 00 00 01 12 F7

                      I've tried to send these commands as all formats (Raw, Binary, URL and C-escaped) by running an event.

                      Unfortunately the lights on my Russounds stay red (where Zone 1 should be turning green).

                      Could you help this com-port starter?
                      Last edited by ABL; May 31st, 2015, 10:29 AM.

                      Comment


                      • Originally posted by ABL View Post
                        As a beginner to com-port commands I have some questions which I hope you can help me out.

                        I've tried this plugin to send commands to my Russound Cam 6.6. This is connected via a direct serial cable (that used to work under HS2). In the plugin I've put type as Serial, Client, address at 3 (reflecting com3) and leave port blank. Are these the right settings?

                        The documentation of Russound shows that the com-port should be 19200 baud, 1 start bit, 1 stop bit, no flow control, no parity. So I set the serial ports in the plug-in to: 19200, 8, 1, none, none, 1...

                        One of the commands I tried to send was to open Zone 1, the HEX codes were:

                        F0 00 00 7F 00 00 70 05 02 02 00 00 F1 23 00 01 00 00 00 01 12 F7

                        I've tried to send these commands as all formats (Raw, Binary, URL and C-escaped) by running an event.

                        Unfortunately the lights on my Russounds stay red (where Zone 1 should be turning green).

                        Could you help this com-port starter?
                        Did you try
                        Code:
                        0xF0 0x00 0x00 0x7F 0x00 0x00 0x70 0x05 0x02 0x02 0x00 0x00 0xF1 0x23 0x00 0x01 0x00 0x00 0x00 0x01 0x12 0xF7
                        as a binary string?

                        Comment


                        • Thanks for this suggestion. I tried this but unfortunately didn't work. I've attached my setup screens (maybe I'm overlooking something).

                          I thought that maybe my serial ports weren't functioning properly, so I performed a loopback test (Hyperterminal). This worked so that shouldn't be a problem...
                          Attached Files

                          Comment


                          • You've probably tried both, but you currently have your connection setup as a host. It should be a client connection to send to your Russound. A host connection would be used to consume any feedback provided from the Russound
                            cheeryfool

                            Comment


                            • Indeed, tried both. But when set to Client I'm not able to enable the connection (red cross at the right)...

                              Comment


                              • To verify that your RussSound is receiving commands from your PC and responding to them, can you try sending them from another app? I recommend you try RealTerm (http://realterm.sourceforge.net/). You will need to close the connection from the plugin first.

                                -David

                                Comment

                                Working...
                                X