Announcement

Collapse
No announcement yet.

IP / Serial Plugin for HS3 (by "drule") - Discussion Thread

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Originally posted by morrisdlx View Post
    Thank you for the quick response. I was able to install the .exe and ... well I now realize the size of my knowledge gap.... Please take a moment to look at the attached document and tell me if this plug-in is the correct solution for sending RS232 instructions to an HTD Lyn6 whole house audio system via an IP to Serial gateway...

    I do not want to waste your time with nubie questions.

    If this has potential I will dive into learning RS232 commands.

    Thank you for your help.
    It should work well!

    -David

    Comment


      UPDATE: Got it all working now :-) - Thanks for your help.

      Hi drule,

      can you maybe send me your ini file, I am having a hard time finding out how to send to the units with or without scripts:-)

      Best regards Martin
      Last edited by twister5800; February 4, 2016, 02:15 AM.

      Comment


        Sending socket message back

        Hello,

        I have a tcp device talking to HS3 via drhsIpPlugin.


        I want to be able to respond to incoming messages via the tcp connection

        I see you need a script to do this, thus I have ... HouseStatus.vb, see below. I thought the "Ext_Send_Command" line would send a text value back to the sending client, in this case the one I have called RemoteFob.

        Is this the correct way to send a packet back to the incoming connection?

        Also is there any API documentation, that would help please...

        John

        Sub Main(param() As Object)
        Dim ConnectionName As String = param(0)
        Dim FromIp As String = param(1)
        Dim AsciiData As String = param(2)

        hs.WriteLog("Pass-thru 0", ConnectionName)
        hs.WriteLog("Pass-thru 1", FromIp)
        hs.WriteLog("Pass-thru 2", AsciiData)

        hs.PluginFunction("drhsIpPlugin", "", "Ext_Send_Command", New Object() {"RemoteFob", "Test Command"})

        End Sub

        Comment


          Originally posted by JohnneyBoy View Post
          Hello,

          I have a tcp device talking to HS3 via drhsIpPlugin.


          I want to be able to respond to incoming messages via the tcp connection

          I see you need a script to do this, thus I have ... HouseStatus.vb, see below. I thought the "Ext_Send_Command" line would send a text value back to the sending client, in this case the one I have called RemoteFob.

          Is this the correct way to send a packet back to the incoming connection?

          Also is there any API documentation, that would help please...

          John

          Sub Main(param() As Object)
          Dim ConnectionName As String = param(0)
          Dim FromIp As String = param(1)
          Dim AsciiData As String = param(2)

          hs.WriteLog("Pass-thru 0", ConnectionName)
          hs.WriteLog("Pass-thru 1", FromIp)
          hs.WriteLog("Pass-thru 2", AsciiData)

          hs.PluginFunction("drhsIpPlugin", "", "Ext_Send_Command", New Object() {"RemoteFob", "Test Command"})

          End Sub
          Your script looks OK to me. How is your connection defined?
          -David

          Comment


            Apple TV

            has anyone used this to control an Apple TV? I would love to control an Apple TV from IP
            Certified installer for HomeSeer, Control4, KNX and Eaton/xComfort

            Comment


              There is no .ini in the .zip. Will the plugin create one upon initialization?
              Originally posted by rprade
              There is no rhyme or reason to the anarchy a defective Z-Wave device can cause

              Comment


                Originally posted by S-F View Post
                There is no .ini in the .zip. Will the plugin create one upon initialization?
                Yes.

                Cheers
                Al
                HS 3.0.0.548: 1990 Devices 1172 Events
                Z-Wave 3.0.1.262: 126 Nodes on one Z-Net

                Comment


                  OK. Thanks Al.

                  So now on to the meat of all this. I am trying to send a UDP command across the LAN and I don't have the foggiest idea of how to make it work. There is apparently no documentation? I'm trying to send anything at all to 192.168.1.145:3333.

                  Help?
                  Originally posted by rprade
                  There is no rhyme or reason to the anarchy a defective Z-Wave device can cause

                  Comment


                    Originally posted by S-F View Post
                    OK. Thanks Al.

                    So now on to the meat of all this. I am trying to send a UDP command across the LAN and I don't have the foggiest idea of how to make it work. There is apparently no documentation? I'm trying to send anything at all to 192.168.1.145:3333.

                    Help?
                    No problem. It's been a while since I played with it as I' m currently not using it. You need to add a connection on the Connections page. The entries there should be pretty self-explanatory. Then on the Commands page, define something that you want to send. Once that's done, create an event and there will be options for drhsIpPlugin listed as one of the actions. Pick the one related to sending a command and then pick the connection and command you want to send. HTH.

                    Cheers
                    Al
                    HS 3.0.0.548: 1990 Devices 1172 Events
                    Z-Wave 3.0.1.262: 126 Nodes on one Z-Net

                    Comment


                      Originally posted by sparkman View Post
                      No problem. It's been a while since I played with it as I' m currently not using it. You need to add a connection on the Connections page. The entries there should be pretty self-explanatory. Then on the Commands page, define something that you want to send. Once that's done, create an event and there will be options for drhsIpPlugin listed as one of the actions. Pick the one related to sending a command and then pick the connection and command you want to send. HTH.

                      Cheers
                      Al

                      Great. You've got me heading in the right direction. On the connections tab what are Multicast Group, Proxy and Script? I filled out the Name, Type, Host/Client and Port fields but when I go to create an event the connection dropdown has nothing in it.... ? Do I need to restart the plugin or something?
                      Originally posted by rprade
                      There is no rhyme or reason to the anarchy a defective Z-Wave device can cause

                      Comment


                        Originally posted by S-F View Post
                        Great. You've got me heading in the right direction. On the connections tab what are Multicast Group, Proxy and Script? I filled out the Name, Type, Host/Client and Port fields but when I go to create an event the connection dropdown has nothing in it.... ? Do I need to restart the plugin or something?
                        Not sure what those are for. Have never used them and don't believe they need to be filled out. The ones you did fill out are the only ones you should need. Did you also create a Command on the Commands tab? I just tried it and did not have to restart the plugin. Which version of the plugin are you using? I have 0.0.0.21.

                        Cheers
                        Al
                        HS 3.0.0.548: 1990 Devices 1172 Events
                        Z-Wave 3.0.1.262: 126 Nodes on one Z-Net

                        Comment


                          Originally posted by sparkman View Post
                          Not sure what those are for. Have never used them and don't believe they need to be filled out. The ones you did fill out are the only ones you should need. Did you also create a Command on the Commands tab? I just tried it and did not have to restart the plugin. Which version of the plugin are you using? I have 0.0.0.21.

                          Cheers
                          Al

                          I got it! Had it set to host not client. Woops.

                          Thanks for getting me on my feet! here! Cool plugin. Documentation would be key though.
                          Originally posted by rprade
                          There is no rhyme or reason to the anarchy a defective Z-Wave device can cause

                          Comment


                            I'm seeing an enormous amount of these errors:


                            <table class="log_table_row" cellspacing="0"><tbody><tr><td class="LogType0" colspan="3" align="left">drhsIpPlugIn </td><td class="LogEntry0" colspan="8" align="left"> Method Capabilities does not exist in this plugin. </td></tr></tbody></table><table class="log_table_row" cellspacing="0"><tbody><tr><td class="LogType1" colspan="3" align="left">
                            </td><td class="LogEntry1" colspan="8" align="left">
                            </td></tr></tbody></table>Am I doing something wrong?
                            Originally posted by rprade
                            There is no rhyme or reason to the anarchy a defective Z-Wave device can cause

                            Comment


                              Example for iRule integration

                              Hi:
                              Love the plugin: works great to control all my AV equipment through a couple of GC100s via both serial and IP.

                              Now I'd like to integrate iRule, with its lovely interface, as the front end of HS. But for the life of me I can't find a clear description anywhere of exactly how to set up the receiver connection: what settings should I use for the commands? What address and port should I use for the connection? And is it possible to test from a mobile browser instead of having to resync an iRule handset?

                              A simple example, perhaps with screenshots, would do the trick, I'm sure. Or just a description. Whatever you can muster is greatly appreciated.

                              Thanks again for a great plugin.

                              Comment


                                Originally posted by S-F View Post
                                I'm seeing an enormous amount of these errors:


                                <table class="log_table_row" cellspacing="0"><tbody><tr><td class="LogType0" colspan="3" align="left">drhsIpPlugIn </td><td class="LogEntry0" colspan="8" align="left"> Method Capabilities does not exist in this plugin. </td></tr></tbody></table><table class="log_table_row" cellspacing="0"><tbody><tr><td class="LogType1" colspan="3" align="left">
                                </td><td class="LogEntry1" colspan="8" align="left">
                                </td></tr></tbody></table>Am I doing something wrong?

                                I haven't seen those before, so drule will need to comment.

                                Cheers
                                Al


                                Sent from my iPhone using Tapatalk
                                HS 3.0.0.548: 1990 Devices 1172 Events
                                Z-Wave 3.0.1.262: 126 Nodes on one Z-Net

                                Comment

                                Working...
                                X