Announcement

Collapse
No announcement yet.

IP / Serial Plugin for HS3 (by "drule") - Discussion Thread

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Originally posted by jpsavaria View Post
    Hi,
    I'm trying to communicate with my Grand Concerto and I'm not able to send any successfull commands.

    I'm using COM4 baud 57600,N,8,1 as recommended.

    If I'm using Putty (terminal emulator) on the same COM port (after stopping my connection in the plugin of course) and sending the string *Z1ON to turn on the zone, it works perfectly I'm receiving the confirmation from the Grand Concerto that the zone is on.. The string type is ASCII, I'm assuming that selecting Raw Text in the plugin is the equivalent...

    When I do the exact same thing in the plugin:
    - Setting COM4 to 57600,N,8,1
    - Creating a connection with type = serial and address = 4
    - Creating a command with raw text type sending the text = *Z1ON

    I see that the plugin sends the string (log shows successfully connected to COM4 and sending 9 bytes) I don't have any feedback and the zone stays OFF.

    Even more interesting, If I manually turn ON and OFF the zone with the keypad on the wall, I receive the feedback in the plugin!! It shows that I'm connected to the Concerto... I suspect that sending "Raw text" will modify in some way the string we are sending...

    Can someone help?

    Thanks!


    Try changing it to type C-Escaped and appending \r to the command so it looks like this: *Z1ON\r
    cheeryfool

    Comment


    • Great it's working!
      What exactly is different between sending a "CR" in raw text and "\r" in C-escaped?
      Thanks!
      Last edited by jpsavaria; May 9th, 2016, 06:24 AM. Reason: missing caracter

      Comment


      • I am trying to install this plugin, but in the zip file is only the .exe no .ini file. Is that not needed any more or do I download that from somewhere else ?

        Comment


        • Originally posted by mikee123 View Post
          I am trying to install this plugin, but in the zip file is only the .exe no .ini file. Is that not needed any more or do I download that from somewhere else ?
          It'll create it when you configure the plugin.

          Cheers
          Al
          HS 3.0.0.548: 1990 Devices 1172 Events
          Z-Wave 3.0.1.262: 126 Nodes on one Z-Net

          Comment


          • Install

            I am having a difficult time getting the plug-in to install on a HS3 windows machine. Can anyone tell me a good step by step procedure to get this installed. I have installed many "beta" plug-ins in the past, but this one is just not wanting to go. I have an old override text file - changed the names in the file, actually using the posted text file as a template.

            Any thoughts would be appreciated - or sample override file.

            Thanks.

            Comment


            • Originally posted by mlconti View Post
              I am having a difficult time getting the plug-in to install on a HS3 windows machine. Can anyone tell me a good step by step procedure to get this installed. I have installed many "beta" plug-ins in the past, but this one is just not wanting to go. I have an old override text file - changed the names in the file, actually using the posted text file as a template.

              Any thoughts would be appreciated - or sample override file.

              Thanks.
              All you need to do is drop the exe that's in the zip file in the main hs3 directory. No override file needed.

              Cheers
              Al
              HS 3.0.0.548: 1990 Devices 1172 Events
              Z-Wave 3.0.1.262: 126 Nodes on one Z-Net

              Comment


              • Originally posted by sparkman View Post
                All you need to do is drop the exe that's in the zip file in the main hs3 directory. No override file needed.

                Cheers
                Al
                Perfect! I don't know why I was making it so hard....lol.

                Comment


                • Samsung J-series TV control via serial

                  With the help of cheeryfool, I was able to control my Samsung J-Series (UN60J620D) via serial port.

                  I run HS3 on a Windows server, so I purchased a db9 to 3.5mm cable from amazon with the correct pinout to use with exlink port on the Samsung.

                  I then used Drule's serial/IP PI to create serial commands for the TV in Binary format. For example, TV onis:
                  Code:
                  0x08 0x22 0x00 0x00 0x00 0x02 0xd4
                  Since I'm using a com port on my HS3 server, I setup a serial connection with the following settings:
                  Code:
                  Baud Rate:9600
                  Data Bits:8
                  Stop Bits:1
                  Parity:None
                  Flow Control:None
                  Threshold:1
                  I call those commands via a minimote event and everything works great. I have tested the following commands work on my J-series:
                  Code:
                  TV On:0x08 0x22 0x0a 0x00 0x05 0x01 0xC6
                  TV Off:0x08 0x22 0x00 0x00 0x00 0x01 0xD5
                  HDMI 1:0x08 0x22 0x0a 0x00 0x05 0x00 0xc7
                  HDMI 2:0x08 0x22 0x0a 0x00 0x05 0x01 0xC6

                  Comment


                  • Originally posted by VickVinegar View Post
                    With the help of cheeryfool, I was able to control my Samsung J-Series (UN60J620D) via serial port.

                    Comment


                    • Thank you very much for this PI!!

                      I also want to say thank you very much for this plugin! It is a really big timesaver!

                      I'm now trying to trigger an iTach to send IR signals to an old TV of mine and for some reason, probably my own ignorance, The commands never get revived, but only when I use this plugin.

                      Firstly, I have my iTach setup with a static IP from my router. I found a list of hex codes for my TV, which I convert to GC format with iConvert, then send those to the iTach with iTest and the TV responds as it should for the given command. When I try to send those hex commands via the plugin, it does not work. I believe there could be something wrong with the way that I'm inputting the hex codes, possibly?

                      My other settings are:
                      Connections Tab:
                      Name:iTach
                      Type:TCP
                      Host/Client:Host
                      IP:192.168.x.x
                      port:4998

                      Then in my event trigger, I use these settings:
                      Connection:iTach
                      Type:Global Cache
                      LED:1:1 (I have tried them all for every test I run)
                      Repeat Count:1

                      I also tried converting the codes from pronto hex to hex and raw and tried those with the plugin and they did not work.

                      I feel like I've checked everything, but I know I'm missing something...

                      Comment


                      • Originally posted by VickVinegar View Post
                        Firstly, I have my iTach setup with a static IP from my router. I found a list of hex codes for my TV, which I convert to GC format with iConvert, then send those to the iTach with iTest and the TV responds as it should for the given command. When I try to send those hex commands via the plugin, it does not work. I believe there could be something wrong with the way that I'm inputting the hex codes, possibly?
                        You can just cut & paste the code straight from remotecentral.com. E.g., for a Samsung TV, the power command hex code would be:
                        Code:
                        0000 006C 0022 0003 00AD 00AD 0016 0041 0016 0041 0016 0041 0016 0016 0016 0016 0016 0016 0016 0016 0016 0016 0016 0041 0016 0041 0016 0041 0016 0016 0016 0016 0016 0016 0016 0016 0016 0016 0016 0016 0016 0041 0016 0016 0016 0016 0016 0016 0016 0016 0016 0016 0016 0016 0016 0041 0016 0016 0016 0041 0016 0041 0016 0041 0016 0041 0016 0041 0016 0041 0016 06FB 00AD 00AD 0016 0016 0016 0E6C
                        Cheers
                        -David

                        Comment


                        • Vick

                          This might be as simple as changing your connection to Client instead of Host. You should then see an IR Receive Type and choose one of the GC options in there. I am not sure which one, so experiment. You should also set the persist flag to on.

                          I have an IR Trans device not GC and this is what my connection config looks like



                          Let me know how you get on.
                          cheeryfool

                          Comment


                          • Originally posted by cheeryfool View Post
                            Vick

                            This might be as simple as changing your connection to Client instead of Host. You should then see an IR Receive Type and choose one of the GC options in there. I am not sure which one, so experiment. You should also set the persist flag to on.

                            Let me know how you get on.
                            Good spot cheeryfool! Yes, the host type does need to be set to client. IR Receive Type can be left at N/A, the iTach only sends IR.

                            -David

                            Comment


                            • Originally posted by cheeryfool View Post
                              Vick

                              This might be as simple as changing your connection to Client instead of Host. You should then see an IR Receive Type and choose one of the GC options in there. I am not sure which one, so experiment. You should also set the persist flag to on.
                              Hi James,

                              Indeed, that was the problem! Setting the iTach connection type to host and setting the receiver type to GC-IRE allow everything to function normally.

                              Wife is going to love this! Thank you very much for your help and for this great plugin!!

                              Comment


                              • I am trying to control a HS3 device via iRule. I think that might be possible with this plugin, but I have no idea how to. If I could trigger a HS3 event that would help too, ideally I want to be able to turn a device on or off. I have looked but what I have found either I do not understand or it doesn't work. I found a json route on the irule forum, I tried it but it did not switch the device, and did not get any response on the irule forum.
                                I am using iRule with Global Cache iTach and iTach flex.

                                Comment

                                Working...
                                X