Announcement

Collapse
No announcement yet.

IP / Serial Plugin for HS3 (by "drule") - Discussion Thread

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Originally posted by mikee123 View Post
    I am having problems getting iRule feedback to work. I have set up everything as per instructions. I have an error in the log,
    drhsIpPlugIn<table class="log_table_row" cellspacing="0"><tbody><tr><td class="LogType1" colspan="3" align="left">
    </td><td class="LogEntry1" colspan="8" align="left"> No TcpClients for iRule</td></tr></tbody></table>
    I think that might be the problem


    It sounds like iRule hasn't connected to the plugin. Do you see anything in the Homeseer log relating to that?

    -David

    Comment


      Looking through the log after opening the feedback page with my ipad i have seen the following in the log.

      Warning file does not exist c://program files (x86)/Homeseer HS3/html/skyrefresh

      Skyrefresh is what irule sends to HS3 from the entrance, which is then triggering the entrance event

      In the event i have if drhsipplugin connection irule string received Skyrefresh encoding type raw text

      Looking at the log it doesnt look as if the event has triggered

      Comment


        Originally posted by mikee123 View Post
        Looking through the log after opening the feedback page with my ipad i have seen the following in the log.

        Warning file does not exist c://program files (x86)/Homeseer HS3/html/skyrefresh

        Skyrefresh is what irule sends to HS3 from the entrance, which is then triggering the entrance event

        In the event i have if drhsipplugin connection irule string received Skyrefresh encoding type raw text

        Looking at the log it doesnt look as if the event has triggered
        It looks like you have iRule trying to connect to Homeseer as an http gateway. It needs to connect as a network gateway to whichever tcp port you specified in the Connection you defined in the plugin's config. Eg.

        Click image for larger version

Name:	IMG_1217.jpg
Views:	1
Size:	31.8 KB
ID:	1186609

        -David

        Comment


          Originally posted by drule View Post
          It looks like you have iRule trying to connect to Homeseer as an http gateway. It needs to connect as a network gateway to whichever tcp port you specified in the Connection you defined in the plugin's config. Eg.

          [ATTACH]55834[/ATTACH]

          -David
          I think I can see where my problem is. under Network, wheer you have homeseer, homeseer feedback, mine says connect devices. I click on that, and only have one homeseer device which says (in use) and I cannot select it. I do not have a homeseer feedback device either

          Comment


            Originally posted by mikee123 View Post
            I think I can see where my problem is. under Network, wheer you have homeseer, homeseer feedback, mine says connect devices. I click on that, and only have one homeseer device which says (in use) and I cannot select it. I do not have a homeseer feedback device either
            In iRule, what does the gateway config of your existing homeseer device look like?

            Comment


              Here are the screenshots. I have created a empty device homeseer feedback and attached to the network gate way as you can see, but that made no difference.
              Attached Files

              Comment


                Originally posted by mikee123 View Post
                Here are the screenshots. I have created a empty device homeseer feedback and attached to the network gate way as you can see, but that made no difference.
                That looks OK. Does your corresponding connection definition in the plugin look like this?
                Click image for larger version

Name:	Config4.png
Views:	1
Size:	8.4 KB
ID:	1186621

                Comment


                  0.0.0.0/0, means it will listen for connections from any ip address. If you want to restrict the plugin to listening only to a single ip address, you could specify that address here.

                  Comment


                    Originally posted by drule View Post
                    0.0.0.0/0, means it will listen for connections from any ip address. If you want to restrict the plugin to listening only to a single ip address, you could specify that address here.
                    I had it like that but with my iPads IP instead of 0.0.0.0/0, I have just changed it to see if it makes a difference. Will test tonight.

                    Maybe the feedback value is not configured right ? Don't think that's the problem but wasn't sure on that one

                    Setting the IP in the plugin to 0.0.0.0/0 did not make any difference. Still getting the drhsIpPlugIn No TcpClients for iRule Error
                    Attached Files
                    Last edited by mikee123; August 9, 2016, 01:14 PM.

                    Comment


                      I think the main problem is I haven't got a device to assign to the Homeseer feedback (Network) gateway. I did create a empty Homeseer feedback device but that doesn't make sense. And I cannot assign my Homeseer device as its in use.

                      Comment


                        Driver Crash

                        I ave been using this driver and it seems to work well however over the past month the driver is crashing. Any ideas what might be causing it?

                        See screen shots of alert - let me know if you need more details.

                        Thanks!
                        Attached Files

                        Comment


                          Originally posted by mlconti View Post
                          I ave been using this driver and it seems to work well however over the past month the driver is crashing. Any ideas what might be causing it?

                          See screen shots of alert - let me know if you need more details.

                          Thanks!
                          What version of the plugin are you running? From the screenshot it looks like it might be v21, in which case, try updating to v25.

                          -David

                          Comment


                            Originally posted by drule View Post
                            What version of the plugin are you running? From the screenshot it looks like it might be v21, in which case, try updating to v25.

                            -David
                            I see that. I will load that next week and see if that fixes the issue. THANKS!

                            Comment


                              Nice plugin, just installed it to try remote triggering of zoneminder and it works well. For example I can trigger a recording by sending this text...

                              2|on+20|123|motion|dectected|event

                              BTW, there a typo in the install instructions... it say place the .ini in the /data folder? should this not be the /config folder?

                              Comment


                                I seem to have somehow managed to remove all log rows from this plugin in my homeseer log - is there any tips on how to get them back or what I have done

                                Comment

                                Working...
                                X