Announcement

Collapse
No announcement yet.

IP / Serial Plugin for HS3 (by "drule") - Discussion Thread

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Originally posted by BJB View Post
    The last two are photos of the file that was saved of the screen from monitor software, first one is when using this program to operate relay 1, second is using test software that works.
    I believe the address in the connections tab should be COM3, other than that, the settings look good. You may need to add the 0x0 in front of the commands as well. This thread should have some examples of other serial type connections.
    HS 3.0.0.548: 1970 Devices 1149 Events
    Z-Wave 3.0.1.262: 123 Nodes on one Z-Net

    Comment


    • Made those changes but no luck so far. Adding the x0x just added more hex Numbers to the group in front. When trying to get the terminal software to work on this board, it started working when picking the option: "Parse XXHEX CODES" . Maby there is a comand to add that here. Thank you for looking at it, I will search the previous examples as you suggested.

      Comment


      • Originally posted by BJB View Post
        Made those changes but no luck so far. Adding the x0x just added more hex Numbers to the group in front. When trying to get the terminal software to work on this board, it started working when picking the option: "Parse XXHEX CODES" . Maby there is a comand to add that here. Thank you for looking at it, I will search the previous examples as you suggested.
        It is sending your hex codes in asci code.
        F = 46 in hex....

        Verstuurd vanaf mijn SM-G935F met Tapatalk

        Peter

        http://ohh.pcgsm.nl

        Comment


        • peterpcpeterpc

          Thank you for your reply Peter, do you know how to fix this?

          Comment


          • Well, just finished going back over this entire 739 post to try and make sure the problem i'm having is not already discussed and resolved, but was not able to find anything.
            I have a 8 relay board as shown in https://forums.homeseer.com/forum/ho...rd-with-hs3pro
            Just trying to operate the relays, Post #734 is the screen shots of where I'm at now trying to operate the first relay, if you can help resolve i sure would appreciate it.

            Comment


            • Originally posted by BJB View Post
              Well, just finished going back over this entire 739 post to try and make sure the problem i'm having is not already discussed and resolved, but was not able to find anything.
              I have a 8 relay board as shown in https://forums.homeseer.com/forum/ho...rd-with-hs3pro
              Just trying to operate the relays, Post #734 is the screen shots of where I'm at now trying to operate the first relay, if you can help resolve i sure would appreciate it.
              What other "types" have you tried under commands?
              HS 3.0.0.548: 1970 Devices 1149 Events
              Z-Wave 3.0.1.262: 123 Nodes on one Z-Net

              Comment


              • When I was experimenting I realize now that keeping records is important. Most of the trials were before I had the program that lets me see what information is being sent, so I will try again some of the other types to see what happens. What I have seen so far is if I add a "," or "\n" or "\r" that the list of numbers to the left is just added too. I believe peterpc said that its the HEX equivalent being sent. I can't find a command to make that list not be sent.

                Comment


                • Originally posted by BJB View Post
                  When I was experimenting I realize now that keeping records is important. Most of the trials were before I had the program that lets me see what information is being sent, so I will try again some of the other types to see what happens. What I have seen so far is if I add a "," or "\n" or "\r" that the list of numbers to the left is just added too. I believe peterpc said that its the HEX equivalent being sent. I can't find a command to make that list not be sent.
                  The spaces may need to be removed as well
                  HS 3.0.0.548: 1970 Devices 1149 Events
                  Z-Wave 3.0.1.262: 123 Nodes on one Z-Net

                  Comment


                  • When using the test software, this is data that operated relay 1, HEX view and ASCII view
                    Attached Files

                    Comment


                    • I maybe have a related problem that someone knows a fast answer to?
                      I am bridging between VeraPlus and HS3 with this plugin triggering events on raw text messages received over tcp.

                      I get the impression that sometimes the plugin does not flush out the triggering text properly or fast enough and I thereby get double events or/and lost events.

                      Question: should the raw text be terminated in some way? With a CR or CRLF?

                      The problem could be on the sender side as well where I use this code:
                      Code:
                      function VeraAlert(host, port, Msg)
                        local socket = require("socket")
                        local tcp = socket.tcp()
                        tcp:settimeout(3)
                        if (tcp:connect(host, port)) then
                           if (tcp:send(Msg)) then
                           else
                          luup.log("Error Sending Msg")
                           end
                        else
                           luup.log("Error Opening Socket")
                        end
                        tcp:close(socket)
                      end
                      
                      VeraAlert("192.1.1.120", 6000, "MyMsg")

                      Comment


                      • Hi I’ve got your ip / serial plugin setup with a global cache gc2sl. Sending commands works but can’t figure out receiving feedback to set a device to on example if I send command MO\r\n the device sends a return of MUT0 how do I get that to turn a device on or off

                        Comment


                        • Hi,

                          First time user of this plug-in. I'm wondering how do I display the data received by the plug-in into a script? I see that here is an event action for doing this, but how should the script look that receives the data? My goal is to have a script that parse the data string received and based on the data trigger events.

                          Comment


                          • Originally posted by huntley1 View Post
                            Hi,

                            First time user of this plug-in. I'm wondering how do I display the data received by the plug-in into a script? I see that here is an event action for doing this, but how should the script look that receives the data? My goal is to have a script that parse the data string received and based on the data trigger events.
                            Does this help?

                            Code:
                            Sub Main(Param() as Object)
                            
                            hs.writelog("irule connector",Param(0).ToString)
                            hs.writelog("irule ip address",Param(1).ToString)
                            hs.writelog("irule data",Param(2).ToString)
                            
                            
                            End Sub

                            Comment

                            Working...
                            X