Announcement

Collapse
No announcement yet.

Thrag's Echo Plugin Discussion Thread

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Originally posted by Korim View Post
    I think I found a solution for this problem. In my case the OCELOT plugin EXE file is located as usual in HomeSeer main folder only. This plugin doesn't have .config file and it seems to be not visible for ASPX script. After I copied (duplicated) HSPI_OCELOT.exe file into HomeSeer\html\bin folder, the issue is solved and the ASPX script finishes successfully.

    I'll just need to remember to manually update this file in html\bin location every time when the plugin gets update in HomeSeer main folder.

    I hope this will help also in case of the Global Cache plugin.

    Thanks,
    Korim
    Awesome! Thanks for letting me know. This has been bugging the hell out of me. Glad to know the solution was so simple, though I simultaneously feel a little dumb knowing it was that simple. I've been searching for windows/IIS settings and the like.

    Comment


    • Plugin and bridge problem

      I'm in the process of setting up this plugin & the HA Bridge. The plugin seems fine.

      As per the directions at, https://github.com/bwssytems/ha-bridge, I'm executing the following line:

      java -jar -Dupnp.config.address=192.168.1.111 -Dserver.port=80 -Dvera.address=E.F.G.H -Dharmony.address=W.X.Y.Z -Dharmony.user=myself -Dharmony.pwd=passwd -Dupnp.Strict=true -Dtrace.upnp=false ha-bridge-1.3.7.jar

      I get back:

      Exception in thread "main" java.lang.UnsupportedClassVersionError: com/bwssystem
      s/HABridge/HABridge : Unsupported major.minor version 52.0
      at java.lang.ClassLoader.defineClass1(Native Method)
      at java.lang.ClassLoader.defineClass(Unknown Source)
      at java.security.SecureClassLoader.defineClass(Unknown Source)
      at java.net.URLClassLoader.defineClass(Unknown Source)
      at java.net.URLClassLoader.access$100(Unknown Source)
      at java.net.URLClassLoader$1.run(Unknown Source)
      at java.net.URLClassLoader$1.run(Unknown Source)
      at java.security.AccessController.doPrivileged(Native Method)
      at java.net.URLClassLoader.findClass(Unknown Source)
      at java.lang.ClassLoader.loadClass(Unknown Source)
      at sun.misc.Launcher$AppClassLoader.loadClass(Unknown Source)
      at java.lang.ClassLoader.loadClass(Unknown Source)
      at sun.launcher.LauncherHelper.checkAndLoadMain(Unknown Source)

      Windows XP sp 3, Java 1.7.0.79

      192.168.1.111:80 is HomeSeer 3.

      Am I doing something wrong or is Java out of date? (I tried updating but Oracle says I need to update Windows first.)

      Comment


      • The HA-Bridge is compiled with Java 1.8. You are getting this error because you are running it under Java 1.7.

        You will need to install Java 1.8 or you can also try to recompiled the HA-Bridge from its source code with Java 1.7. This can work if the developer is not using any specific features of Java 1.8.

        To compile the source code with Java 1.7 you will need to edit pom.xml file of that project and specify that you want to use JDK 1.7 instead of 1.8.

        I hope this will help.

        Korim

        Comment


        • Thanks!

          Comment


          • Originally posted by lor View Post
            Hi Thrag,

            I'm trying to install your Plugin according to instructions. I dropped the files where you say (I'm running HS3 ZEE S2 v 3.0.0.208 where that's /usr/local/HomeSeer/Config and /html). On running the aspx I get a compile error (see the screenshot). The cutoff text reads as below.

            -Lor
            I'm having the same issue as Lor. Running HS3 full on a raspberry pi under Raspbian.

            Code:
            Description: Error compiling a resource required to service this request. Review your source file and modify it to fix this error.
            Details: : Unhandled Exception:
            Error origin: Compiler
            Error source file: /HS3EchoPlugin.aspx
            Exception stack trace:
              at System.Web.Compilation.AssemblyBuilder.BuildAssembly (System.Web.VirtualPath virtualPath, System.CodeDom.Compiler.CompilerParameters options) [0x00000] in <filename unknown>:0 
              at System.Web.Compilation.AssemblyBuilder.BuildAssembly (System.Web.VirtualPath virtualPath) [0x00000] in <filename unknown>:0 
              at System.Web.Compilation.BuildManager.GenerateAssembly (System.Web.Compilation.AssemblyBuilder abuilder, System.Web.Compilation.BuildProviderGroup group, System.Web.VirtualPath vp, Boolean debug) [0x00000] in <filename unknown>:0 
              at System.Web.Compilation.BuildManager.BuildInner (System.Web.VirtualPath vp, Boolean debug) [0x00000] in <filename unknown>:0

            Comment


            • My C# script doesn't seem to work under unix. Someone earlier in the thread had mentioned they translated things to vb which does work and offered to share the code, but I don't think they have done so unfortunately. So I hate to say it but currently there doesn't appear to be a way to run this on a unix system.

              Comment


              • I'm trying the bridge but whenever I try to Test a device i get this in the console

                [qtp10958890-15] WARN com.bwssystems.HABridge.hue.HueMulator - Error on calling
                url to change device state: http://IP:80/JSON?request=controldev...f=561&value=On

                I'm running the latest bridge version (1.3.8)

                These are the devices created by the script http://IP/HS3EchoPlugin.aspx?BridgeConfig
                Last edited by madas; February 19th, 2016, 02:25 PM.

                Comment


                • Thrag's Unofficial HS3 Echo Plug-in - Any restriction to HS3 Version number?

                  Hi, I have Thrag's Unofficial HS3 Echo Plug-in set up with the HA Bridge and it is working currently with HomeSeer Version: HS3 Pro Edition 3.0.0.208. I seem to remember that the new Homeseer beta was suggested by Homeseer to "Thrag" to try. I do not use MyHS backend and currently use PFSense for external access to HomeSeer HSTouch, etc. A question to "Thrag" I guess I want to continue to use his plug-in, and not sign up for the HomeSeer paid monthy external access. Any guideance would be great. I would support a paid "Thrag" HS3 Echo Plug-in to avoid the added monthly expense.

                  Thank you,

                  Comment


                  • I had this running correctly before I moved to a new server, now I have the Echo registered and everything functions, but I cannot get the echo to discover devices (aside from my existing Hue and LIFX bulbs). I can tell it to 'Ask Zero to do X' (Zero being the name I gave the skill) and it will work. I'm sure I'm missing something simple, anyone have any tips?
                    Edit: I'm using the lambda version. For the life of me I could not get the Apache option to work, and was using the lambda on my other server.
                    Last edited by unbwogable; May 11th, 2016, 07:45 PM.

                    Comment


                    • Originally posted by unbwogable View Post
                      I had this running correctly before I moved to a new server, now I have the Echo registered and everything functions, but I cannot get the echo to discover devices (aside from my existing Hue and LIFX bulbs). I can tell it to 'Ask Zero to do X' (Zero being the name I gave the skill) and it will work. I'm sure I'm missing something simple, anyone have any tips?
                      Edit: I'm using the lambda version. For the life of me I could not get the Apache option to work, and was using the lambda on my other server.
                      Make sure the HA bridge server is running. That's what does the connected home emulation (i.e. when you say just "turn x off" rather than "ask zero to turn x off"). If you've already migrated that and it is alive and running, you'll need to hit the bridge config page again to load it up and then ask your echo to discover devices.

                      Comment


                      • Thrag,

                        I am not sure if this is a plugin issue or a question/bug about HS3 itself but since I am running into it using your plugin...

                        My problem is that I have a bunch of devices which I have created myself and am managing via scripts. HS3 appears to have broken the device call back scripts so I am registering a global callback (using RegisterStatusChangeCB) which monitors for changes and then does the appropriate thing (using the serial plugin).

                        This works perfectly for changes made via the web interface.
                        It also works for changes made via ImperiHome (using the ImperiHome plugin).

                        However, when I make a change using ha-bridge via your plugin, I see the CAPI Control call noted in the log... E.g.

                        Device: First Floor Kitchen kitchen table lights to On (100) by/from: CAPI Control Handler

                        but the callback script never triggers and the device never physically changes (or changes in the web interface).

                        A quick Google seems to imply that CAPI control assumes a plugin is managing the device. Does that mean your plugin can't work without a plugin managing the device? I simply want you to set the device value to 0-100 and I will do the rest...

                        Any ideas?

                        Comment


                        • Perhaps put even simpler...

                          Can your plugin control virtual devices that don't have an underlying plugin managing them?

                          It appears to detect them fine but not actually control them.

                          Thanks,

                          -Jon

                          Comment


                          • Sigh. And now when I circle back to this problem (after not hearing from anybody) it is gone. Ha-bridge changes are correctly triggering my device change callback today.

                            I hate intermittent issues. But at least I understand a lot more about how this stuff is all wired together after having dug through the ha-bridge stuff in depth. It's clearly just making JSON calls into HS3 so I don't have any idea why it wasn't triggering my scripts for a while. Cest la vie.

                            So I guess Thrag can just ignore these three messages when he reads them.

                            Thanks for all the hard work.

                            Comment


                            • Hello

                              i have this up and running in no time , i first installed the echo bridge made for vera and had to configure every device manually then came across this post and the auto configuration is just perfect , I'm running the local version of the plugin not the skill because it's a lot faster and the skill is too complicated .

                              I also managed to workaround the limitations using JSON commands , so i can manage all sort of devices in homeseer and also run events which is great .

                              Just wanted to say thank you Thrag , i did this with zero programming background .

                              Comment


                              • Hi,

                                I have been using this plugin for some time now and love it. I was also able to make a custom skill based on the information given.

                                I have a question about other terms beside on/off/dim.

                                I have two garage doors that are connected to an i/o link module that can open and close with the on/off commands just fine. However, for more intuitive use I would like to say Open/Close instead. The newest HABridge states that Open/Close can be used, but I have found no way to get it to work in sequence.

                                Is this a limitation of the i/o link not being able to respond to open/close instead of on/off (even if I change labels, it stops working)?

                                Is this a limitation of the HABridge since when you edit a device it still only has the on/off/dim options?

                                Thanks for any info.
                                And thanks for a great plugin!

                                JJ

                                Comment

                                Working...
                                X