Announcement

Collapse
No announcement yet.

Thrag's Echo Plugin Discussion Thread

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • So...I am having a bit of fun with this. A few issues with my New Zealand accent though (e.g. Alexa hears 'west blind' as 'waist line').

    I have two questions:
    1) Is there a way to ignore the word 'the'? It's natural for people to say "turn on the study lights" rather than "turn on study lights". I did make an alias with the word 'the' which worked but I don't to have to make an alias for every device.

    2) How to do I add the ability to use the words 'open'and 'close'? As in "open the kitchen blinds". In HS the blinds have device value of 0 = "Closed" and 255 = "Open".

    Many thanks, Marty
    iCore5 Win 10 Pro x64 SSD

    HS3 Pro Edition 3.0.0.435 Windows

    BLOccupied:,Device History:,Yamaha:,UltraMon3:,mcsXap:,Restart:,UltraNetatmo3:, UltraM1G3:,Ultra1Wire3:,BLBackup:,Harmony Hub:,DoorBird:,UltraECM3:,Nanoleaf 3P:,UltraRachio3:,Z-Wave:,SDJ-Health:,BLGarbage:,Blue-Iris:,Chromecast:,Pushover 3P:,EasyTrigger:

    Comment


    • Your "the" and "waist line" issues are exactly why I created the alias feature. In my case it would constantly hear me saying "den lights" as "ten lights", so I just created an alias for that. You can do the same for "waist line".

      Another more generic way of handling the "the" issue is to add sample utterances that have "the" in them. Like "Turn {on|OnOff} the {den lights|Device}". If you create just a few utterances like that it should pick up no the pattern for everything else. You don't need to go overboard on the number of sample utterances like my generation code currently does.

      For open and close, that's also something you can create sample utterances for. You can add utterances with open and close in the OnOff slot. Add in something like "{Open|OnOff} the {living room blinds|Device}". I named the slot "OnOff" since I was starting with just my lights, but it can be for any command label.

      I am waiting on amazon to make some improvements to the custom slot feature they added not long ago. Right now for each custom slot you need to enter it into the skill setup page individually, which is a pain in the *** since it would make the setup involve several if not dozens of cut and pastes rather than the two there are currently for the schema and sample utterances. I am hoping they will combine the intent schema and custom slots into a single definition file so I can generate the exact command labels for each device type in one's HS system and also for each device and event name. Once I can do that it should greatly improve recognition and make the number of sample utterances required minimal.

      Comment


      • Originally posted by heatvent View Post
        I am in about the exact same spot as Olag. I found the missing "/" for location and fixed. I copied certificate.pem to server.key but kept getting errors in the Apache logs about a private key. So I copied private-key.pem to server.key and now Apache loads up fine and I can reach the .aspx page. Now, however, when I tell Alexa to launch home seer she tells me I do not have access to this skill.
        Try blanking out the userid and appid in the ini file if they exist and then register again. Recently Amazon made a change to how they generate the userID for each skill.

        Comment


        • Originally posted by The Doge View Post
          Not off to a good start with this. Whenever I download the file it save it as a php file and gives me no options to unzip it. What am I doing wrong?
          Thanks
          Dan
          If you're getting a php file that sounds like it's not really downloading the attachment but rather saving the forum page it is on. Are you perchance doing a save as on the link in the first post in this thread? You should instead click the link which will take you to a post that contains the actual zip file attachment.

          Comment


          • My apologizes for anyone who has posted here recently with setup trouble. I've been busy with work and travelling a lot recently so I haven't been monitoring the thread as actively as I'd like for the last few weeks. I'm going to remain busy for the next couple of weeks, but after that I'll finally make the corrections to the instructions that have been pointed out and finally get to work on some improvements.

            Comment


            • Thrag,

              Thanks for your help with 'open/close'. Got it working...yay! As you can guess I'm not a proficient programmer, more of a bumbling programmer.

              I'll do some work on the 'the' issue with sample utterances as you suggest.

              Thanks for investing all this time on this project. A small donation for your efforts.

              Marty
              iCore5 Win 10 Pro x64 SSD

              HS3 Pro Edition 3.0.0.435 Windows

              BLOccupied:,Device History:,Yamaha:,UltraMon3:,mcsXap:,Restart:,UltraNetatmo3:, UltraM1G3:,Ultra1Wire3:,BLBackup:,Harmony Hub:,DoorBird:,UltraECM3:,Nanoleaf 3P:,UltraRachio3:,Z-Wave:,SDJ-Health:,BLGarbage:,Blue-Iris:,Chromecast:,Pushover 3P:,EasyTrigger:

              Comment


              • I'm getting this when querying the sampleutterances url

                {"version":"1.0","response":{"outputSpeech": {"type": "PlainText","text": "Unable to find assembly 'HSPI_GCIR, Version=5.0.0.22, Culture=neutral, PublicKeyToken=null'."},"card": {"type": "Simple","title": "Echo Error","content": "Unable to find assembly 'HSPI_GCIR, Version=5.0.0.22, Culture=neutral, PublicKeyToken=null'."},"reprompt": {"outputSpeech": {"type": "PlainText",
                "text" : ""}},"shouldEndSession": "true"}}

                Any ideas? I removed this plugin temporarily to get the utterances.

                Also, I added an alias to EchoConfig.ini but in the log I see it cannot be found

                Dec-02 4:55:11 PM Warning Device not found: family room lights
                Dec-02 4:55:04 PM Info Loading alias from: family room lights to: Table Lamp; Corner Light; Bookcase Lights

                The warning comes after I ask Alexa "Alexa, Ask House, Turn Family Room Lights off"...then I get that warning. Can anyone shed some light on this? the line in echoconfig.ini is

                family room lights = Table Lamp; Corner Light; Bookcase Lights

                On the right of the = is the device names without location. These devices are unique
                Last edited by madas; December 2nd, 2015, 04:55 PM.

                Comment


                • After updating the ini file click the link to reinitialize. The aliases are loaded into memory upon initialization.

                  IIRC someone else had the same issue with sample utterances, thought I don't recall if they found a solution or just hand coded some utterances. It has something to do with the global cache plug in not liking how I loop through all devices to get all command labels for each device. I'll see if I can find a better answer for you, and later this month when I get back to development I'll make sure to put in error handling for that specific problem so at least it will just skip over the device rather than error out.

                  Comment


                  • Hi Thrag,

                    Well in the log it shows that it loaded the alias right before the error

                    Loaded alias

                    Dec-02 4:55:04 PM Info Loading alias from: family room lights to: Table Lamp; Corner Light; Bookcase Lights

                    Error

                    Dec-02 4:55:11 PM Warning Device not found: family room lights

                    So I assume this means it already initialized correctly? I also rebooted the whole HS server just incase....it still didn't find it. What am I doing wrong?

                    M

                    Comment


                    • Hmm, can you do a little testing like setting the alias to only one of the devices to see if that works, then try adding the second, etc.

                      Unfortunately I'm not home this week so I can't test things out myself right now.

                      Comment


                      • No go i'm afraid. I also changed the alias to make it really easy (david)

                        Dec-03 10:26:04 AM Warning Device not found: david
                        Dec-03 10:25:41 AM Info Loading alias from: david to: Bookcase Lights

                        from INI

                        david = Bookcase Lights

                        On the right of the equals should be the device name? or the location + device name?

                        I'm saying, "Alexa, Ask House"...then it beeps.."Turn David On"...then I see the device not found in the HS log
                        Last edited by madas; December 3rd, 2015, 10:47 AM.

                        Comment


                        • One other simple thing to double check, make sure the alias is under the device alias section not the event alias section.

                          Comment


                          • Hi,

                            It is already

                            [DeviceAliases]
                            david = Family Room Bookcase Lights ( i tried adding the room to this also, no difference)

                            [EventAliases]
                            xxx = yyy

                            Worth checking though!

                            Also - if I say

                            "Alex, Ask House, Turn bookcase lights on" - it works

                            M

                            Comment


                            • Just an idea. I had trouble with aliases if there was a space in the alias before and after the =.

                              xxx = yyy

                              should be

                              xxx=yyy

                              Worth a try.

                              Marty
                              iCore5 Win 10 Pro x64 SSD

                              HS3 Pro Edition 3.0.0.435 Windows

                              BLOccupied:,Device History:,Yamaha:,UltraMon3:,mcsXap:,Restart:,UltraNetatmo3:, UltraM1G3:,Ultra1Wire3:,BLBackup:,Harmony Hub:,DoorBird:,UltraECM3:,Nanoleaf 3P:,UltraRachio3:,Z-Wave:,SDJ-Health:,BLGarbage:,Blue-Iris:,Chromecast:,Pushover 3P:,EasyTrigger:

                              Comment


                              • Thanks for noticing that. I'll add trimming whitespace to the list of fixes I need to make.

                                Comment

                                Working...
                                X