Announcement

Collapse
No announcement yet.

Thrag's Echo Plugin Discussion Thread

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • darn - that was it - thanks. I was copying the example line

    What about multiple devices

    Family Room=Family Room Bookcase Lights; Family Room Table Lamp; Family Room Corner Light

    This still doesn't work..

    UPDATE: Its the capital letters - the alias needs to be lowercase!....perhaps add this in the same process when you do the trimming.

    family room=Family Room Bookcase Lights; Family Room Table Lamp; Family Room Corner Light

    Everything works now
    Last edited by madas; December 3rd, 2015, 04:04 PM.

    Comment


    • Glad I was able to help....the power of community knowledge eh.

      Just another word of advice.....the utterances are very useful. I'm a Kiwi so speak with a New Zealand accent. Echo often has trouble with my accent. But the utterances help solve a lot of frustration. So use sample utterances to enhance the accuracy of th echo.

      So for example I would add "family room" to my sample utterances in your case.

      Marty.
      iCore5 Win 10 Pro x64 SSD

      HS3 Pro Edition 3.0.0.435 Windows

      BLOccupied:,Device History:,Yamaha:,UltraMon3:,mcsXap:,Restart:,UltraNetatmo3:, UltraM1G3:,Ultra1Wire3:,BLBackup:,Harmony Hub:,DoorBird:,UltraECM3:,Nanoleaf 3P:,UltraRachio3:,Z-Wave:,SDJ-Health:,BLGarbage:,Blue-Iris:,Chromecast:,Pushover 3P:,EasyTrigger:

      Comment


      • New version posted. I've made some fixes to the instructions (like the correct close location tag syntax in the apache sample config). Trimming of white space was added so manually configuring aliases in the config file will be less picky. Error handling was applied to sample utterance generation to work around the problem with trying to get command labels for global cache devices.

        The only new feature is that I've added is for better sample utterance generation. Parameters for listing event groups, device locations, and specific devices to exclude form utterance generation now can be added to the ini file.

        This release is aimed at fixing issues to make setup easier based on the reported issues people have had. Unless you want to generate a more concise sample utterance set using the new exclusion parameters it is not necessary for existing users to upgrade.

        Comment


        • Major new revision! Get it in the new thread here.

          Now this script combines the power of a locally running Alexa Skill for full featured control of Homeseer with the ability to automatically configure the Alexa HA Bridge so you can control lighting and similar devices more directly (i.e. without having to say "tell home seer to" for each command).

          You can use both this Skill and the HA Bridge separately or together. Using both gives you the ability to control on/off/dim devices directly as Alexa Connected Home devices by saying just "Alexa, turn on device" with the HA Bridge, and to run events or control more complex devices like thermostats through the skill by saying "Alexa, tell (you house's name) to run event" or "Alexa, tell (you house's name) to set heating setpoint to 68".

          For new users: Get the zip file. Follow the short instructions in the readme. Then load the page and read the much longer instructions. The HA Bridge autoconfigurator is quick and easy to set up. The Skill takes longer.

          For existing users: If you want to use the HA Bridge configurator there are new configuration parameters to add to the ini file. They are listed in the instructions about setting up the bridge configurator and they are also in the sample ini file (with sample values to be replaced).

          Comment


          • I already put up a small update. For anyone who downloaded already where the instructions mention that running the bridge configuration creates new devices each time and thus may create duplicates, that is now fixed. Upon creation I store the IDs so subsequent runs will update the same devices instead of creating new ones each time.

            If you change device names in homeseer, add new devices or update configuration parameters hit the link to update the bridge, and ask alexa to discover again, and all changes should be picked up.

            Comment


            • Since copying this new aspx file in I get this error when I start HS. If I say ok to continue and try the web link i get

              Server Error in '/' Application.

              Compilation Error

              Description: An error occurred during the compilation of a resource required to service this request. Please review the following specific error details and modify your source code appropriately.

              Compiler Error Message: The compiler failed with error code -1073741511.


              Show Detailed Compiler Output:


              Version Information: Microsoft .NET Framework Version:4.0.30319; ASP.NET Version:4.0.30319.34274
              Attached Files

              Comment


              • Originally posted by madas View Post
                Since copying this new aspx file in I get this error when I start HS. If I say ok to continue and try the web link i get

                Server Error in '/' Application.

                Compilation Error

                Description: An error occurred during the compilation of a resource required to service this request. Please review the following specific error details and modify your source code appropriately.

                Compiler Error Message: The compiler failed with error code -1073741511.


                Show Detailed Compiler Output:


                Version Information: Microsoft .NET Framework Version:4.0.30319; ASP.NET Version:4.0.30319.34274
                That's very strange and I'm not sure offhand what might be causing it. Is the "Show Detailed Compiler Output" section really blank or did that just not cut and paste into the forum properly?

                The other message is really odd as well. I did add some new imports for libraries so I could make the http requests, but only system libraries that I'm pretty sure exist in .net 4.0 .System.Net ,IO and Text. The code to make the http request to the HABridge is nearly identical to the documented example for .net 4. Plus the function it is complaining about is file related (GetFileInformationByHandleEx) not network related so it's not something I'm explicitly calling myself and not something the new code would seem likely to call down the line. The only file manipulation I do is through the HS3 api for getting and setting ini file info, and those calls have been in there from the start. I'm just making a new more of them to read and store the HA Bridge related information.

                Let me do some research to try and get a clue. Not that I'm sure it makes any difference, but what OS are you running? My HS box is still WinXP. The only thing I can guess is this might be the result of IIS differences between platforms. Perhaps newer versions need some special setup to import things or allow pages to make outgoing connections or something.

                Comment


                • Yes it is blank.

                  I'm running Server 2012R2 with all the latest MS patches

                  Comment


                  • Googling around for that problem I ran across this which might help.

                    http://stackoverflow.com/questions/3...n-i-try-to-com

                    It mentions some windows updates to uninstall to unbreak the compiler. It appears to be a problem with a specific version of the .net framework.

                    Comment


                    • Originally posted by madas View Post
                      Yes it is blank.

                      I'm running Server 2012R2 with all the latest MS patches
                      Was the prior version compiling fine, but now this one won't? Or is this version the first one you've tried?

                      Comment


                      • you got it. It was a MS update that broke it. I uninstalled the updates and all versions work again

                        Thanks again

                        Comment


                        • Getting back to this i'm trying to configure the Bridge at

                          http://HS.IP/HS3EchoPlugin.aspx?BridgeConfig

                          and I get that GlobalCache error again - i thought the previous version fixed that?

                          {"version":"1.0","response":{"outputSpeech": {"type": "PlainText","text": "Unable to find assembly 'HSPI_GCIR, Version=5.0.0.22, Culture=neutral, PublicKeyToken=null'."},"card": {"type": "Simple","title": "Echo Error","content": "Unable to find assembly 'HSPI_GCIR, Version=5.0.0.22, Culture=neutral, PublicKeyToken=null'."},"reprompt": {"outputSpeech": {"type": "PlainText",
                          "text" : ""}},"shouldEndSession": "true"}}

                          Comment


                          • Originally posted by madas View Post
                            Getting back to this i'm trying to configure the Bridge at

                            http://HS.IP/HS3EchoPlugin.aspx?BridgeConfig

                            and I get that GlobalCache error again - i thought the previous version fixed that?

                            {"version":"1.0","response":{"outputSpeech": {"type": "PlainText","text": "Unable to find assembly 'HSPI_GCIR, Version=5.0.0.22, Culture=neutral, PublicKeyToken=null'."},"card": {"type": "Simple","title": "Echo Error","content": "Unable to find assembly 'HSPI_GCIR, Version=5.0.0.22, Culture=neutral, PublicKeyToken=null'."},"reprompt": {"outputSpeech": {"type": "PlainText",
                            "text" : ""}},"shouldEndSession": "true"}}
                            If you temporarily disable the GC plugin you should be able to run the sample utterances and the bridge config. They are things you only need to run once. Or at most once in a while if you change some names or add devices. Once the script sets up the bridge config there's no ongoing communication between my script and the bridge.

                            The error you are getting in the configurator is the same global cache problem you are getting in sample utterances. They both do the same loop through devices and their command labels. I thought I had put code in to catch all errors, log a warning and continue on to the next device but apparently I didn't do it right. I don't have any GC devices so I can't currently reproduce the problem and thus can't test to see if my changes really fix or work around the issue. However I am considering getting one of the flex units in the Christmas sale. If I don't I'll grab a trial of the plug in to see if I can reproduce the problem and finally fix it.

                            Comment


                            • Unfortunately disabling it doesn't help. I still get the error

                              I still get the error on the Sample Utterances as well. If you need me to test something let me know. I had to completely remove it last time which caused other issues for me

                              Comment


                              • Originally posted by madas View Post
                                Unfortunately disabling it doesn't help. I still get the error

                                I still get the error on the Sample Utterances as well. If you need me to test something let me know. I had to completely remove it last time which caused other issues for me
                                What is the device type or types for GC devices? In the hope that it is not simply getting the device but trying to access the command labels that it doesn't like, I want to put in an explicit skip for those device types before I pull command labels.

                                Comment

                                Working...
                                X