Announcement

Collapse
No announcement yet.

HSTouch Boolean element?

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • HSTouch Boolean element?

    Is there a way to use a button as a boolean for a device?
    What I want to do is have a button for door locks that will show the status of the lock and if unlocked, pressing the button will lock it. If locked, presing the same button will unlock it.

  • #2
    I think you can do status tracking which can show another element while at the same time hide the current one.
    I haven't done HStouch for while now but I think it's all there.


    Eman
    The Closer.

    Comment


    • #3
      I almost have this figured out.
      I have all the elements in place, just can't figure out how to hide/show based on the status.
      I have one element that shows status images. I'm thinking I can use that to show/hide the buttons as needed but where do I add an action based on status?

      Comment


      • #4
        I don't think it's possible to perform an action based on a device's status, but you can run an immediate script with a button press to the effect "If Locked then Unlock Else Lock". In this case you don't need to use hidden elements, only one button which displays the current status and runs the script when pressed (or released).
        Real courage is not securing your Wi-Fi network.

        Comment


        • #5
          Originally posted by Demusman View Post
          I have all the elements in place, just can't figure out how to hide/show based on the status.
          I have one element that shows status images. I'm thinking I can use that to show/hide the buttons as needed but where do I add an action based on status?
          If you assign status images to the the values of a device, you can create one button that will display the appropriate status icon. You can then run an event when you press the button. The event would perform the action.

          PS. The 'Toggle' event action is added by the EasyTrigger plug-in. (Another 'work-around', I suppose.) If I had to select one plug-in that would offer high value to any HS user, it would be that one.

          This is an event I use for a ventilator fan:

          Click image for larger version  Name:	toggle.PNG Views:	0 Size:	30.5 KB ID:	1305487
          Last edited by Uncle Michael; May 17th, 2019, 05:10 PM. Reason: Add clarification on event action.
          Mike____________________________________________________________ __________________
          HS3 Pro Edition 3.0.0.500

          HW: Stargate | NX8e | CAV6.6 | Squeezebox | PCS | WGL 800RF, Rain8Net+ | RFXCOM | QSE100D | Vantage Pro | Green-Eye | X10: XTB-232, -IIR | Edgeport/8 | Way2Call | Ecobee3

          Comment


          • #6
            That would work except for some reason the status icons don't work with the android client. Only one of the icons is displaying correctly and the other shows the system default icon.
            I've actually had to change the system default icons with my own to make it work but that's limited to very specific icons.

            Comment


            • #7
              Originally posted by Demusman View Post
              That would work except for some reason the status icons don't work with the android client. Only one of the icons is displaying correctly and the other shows the system default icon.
              I've actually had to change the system default icons with my own to make it work but that's limited to very specific icons.
              That's a puzzle. I have had no problem with status icons on my Android tablets.
              Mike____________________________________________________________ __________________
              HS3 Pro Edition 3.0.0.500

              HW: Stargate | NX8e | CAV6.6 | Squeezebox | PCS | WGL 800RF, Rain8Net+ | RFXCOM | QSE100D | Vantage Pro | Green-Eye | X10: XTB-232, -IIR | Edgeport/8 | Way2Call | Ecobee3

              Comment


              • #8
                Really?
                I've found a few posts mentioning the same so I thought it was a known bug.
                Did you have to do anything different or just select the images for each state?

                see here:
                https://forums.homeseer.com/forum/le...es#post1305225

                Comment


                • #9
                  The only thing I do is save the image in the HTML/Images folder. Below is an example of mail delivered. As you can see, I used images at vastly different resolution, and they are not stored together (one is a stock HS image, the other I copied from the web), but they are displayed reliably on Fire HD and Nexus 7 tablets.

                  Click image for larger version  Name:	status.PNG Views:	0 Size:	68.0 KB ID:	1305765
                  Mike____________________________________________________________ __________________
                  HS3 Pro Edition 3.0.0.500

                  HW: Stargate | NX8e | CAV6.6 | Squeezebox | PCS | WGL 800RF, Rain8Net+ | RFXCOM | QSE100D | Vantage Pro | Green-Eye | X10: XTB-232, -IIR | Edgeport/8 | Way2Call | Ecobee3

                  Comment


                  • #10
                    In the project I assign the device to Image Tracking Normal.

                    Click image for larger version

Name:	image.PNG
Views:	61
Size:	7.2 KB
ID:	1305767
                    Mike____________________________________________________________ __________________
                    HS3 Pro Edition 3.0.0.500

                    HW: Stargate | NX8e | CAV6.6 | Squeezebox | PCS | WGL 800RF, Rain8Net+ | RFXCOM | QSE100D | Vantage Pro | Green-Eye | X10: XTB-232, -IIR | Edgeport/8 | Way2Call | Ecobee3

                    Comment


                    • #11
                      Doesn't it save them there when you assign them? I thought it did, maybe that's what I'm doing wrong.
                      And now that I see your pics, I never saw that "edit text and graphics" page. Where is that?

                      Also, I'm using HS Touch, shouldn't they be in the skins folder?


                      You're setting images for devices. I'm talking about images for buttons that display the status of a device. Basically I have a "status Normal" button and then I have a "status active" button. The Android client only shows one of them.
                      Last edited by Demusman; May 18th, 2019, 05:58 PM. Reason: Found what you're doing...

                      Comment


                      • #12
                        I don't want to quote you yet but what I do for my buttons is edit them in Photoshop (you can use other) and impose the status on them so I have them in pairs or in some cases three. And I usually pull up (show a screen on top of the current) whole screens with other elements instead of editing for a single button. (Take care here to close screens as you move back and forward for good practice of keeping your project tidy. "Leftover screens when using Android")

                        Edit : on the right pane of HSTouch when you click on any item in your project, will expose all the properties for that item (element) for you to edit as you desire including swapping graphics. Uncle Michael 's post #10


                        Eman.
                        The Closer.

                        Comment


                        • #13
                          I'm not having problems creating the screens or editing the buttons. I've been doing this stuff for many years as I'm sure we all have, just not sure how Homeseer goes about it.
                          I'll post sceenshots to hopefully clarify. By the way, Does Homeseer support monitor these forums??

                          This is my Climate screen.

                          You can see the darker images are the "active" mode at the time.
                          This is the elements for the "Mode Off" button.


                          Note the highlights. No normal image selected and set to status track the thermostat mode.


                          This is the "collection" for the status images.
                          I have the darker image selected for the "idle" mode.
                          All the other modes are assigned the lighter "normal state" button.
                          This works perfectly on the desktop client but only displays the "active" images on Android as you can see in the link I posted in a previous post.

                          Am I doing something wrong or is it Homeseer?

                          Comment


                          • #14
                            Did you check the file types? I don't think .ico files work on Android but should work if they were .png
                            What I usually do is to put my project files in different folders (works well for backgrounds). But dump the button icons in the default one. So it could be file type.
                            One more thing though, if you source for your images from the html/images the system may try to impose default icons.==>I may be wrong on that one as well
                            Also by looking at your previous post, HSTouch designer fetches for the button icons from within the main folder (so naming is important) . Those are the ones you see on the left of the Designer. To find where they are kept, drag one in work space and you will see were they are kept and that's where you should dump your icons (mark the nomenclature!)

                            No harm will be done when you dump your files there!



                            Eman.
                            The Closer.

                            Comment


                            • #15
                              All my graphics are .png.

                              I have to ask this again, why would I use the html/images folder, I'm using HS Touch so aren't all graphics pulled from the skin folder?
                              Keep in mind, this all works perfectly in the desktop client.

                              Comment

                              Working...
                              X