Announcement

Collapse
No announcement yet.

Homeseer Oddity/Bug

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Homeseer Oddity/Bug

    Hi,

    I ran into this scenario....

    I have a webpage, that executes 2 "ExecX10" commands.
    1) sends the ON command to a lamp
    2) sends a DIM command with a percentage to dim

    so.... in this scenario...

    * The lamp is currently at 60% dim
    - homeseer web interface show 60% and the light is indeed at 60%
    * I set my webpage to:
    - send the "ON" command
    - send the dim command of 20%

    here's the code
    -----------------------------------------
    hs.ExecX10 lt, "on", 0, 0, true
    hs.ExecX10 lt, "Dim", (100 - lvl), 0, true
    -----------------------------------------

    when executed....

    * The lamp gets turned on, and dimmed to 80%
    * homeseer web interface displays a dim level of 40%

    so, any code after this... that checks the dim level of the lamp gets a wrong value from homeseer.....


    What do you think??????
    Any help on this?????

    -user
    Last edited by polive96; February 1st, 2005, 04:40 PM.

  • #2
    anybody at homeseer see this?

    anybody at homeseer see this?

    Comment


    • #3
      HOMESEER GURU's PLEASE LOOK

      hey guys,

      hadn't heard anything from ya'll on this?
      what do you think?

      -phillip

      Comment


      • #4
        Sounds like you have a problem with relatives. No not the people you are related to. Looks like a relative dim issue.

        Here is what I think happens

        lamp is at 60% dim
        you issue 20% dim

        HomeSeer thinks 60-20 = 40% dim

        You issue an ON and then a 20% dim very shortly after so I suspect that the hardware goes 100 (via ON) and then 20% dim yielding 80%

        Looks like hardware responded faster than HS could register status changes so HS ends up with a different result.

        I do not dim with commands very often but I suspect that you can just skip the ON command (for some lamps,a DIM command will turn it ON if it is OFF). If you still need the ON then separate the two hs.ExecX10 calls with a hs.WaitEvents call.

        HTH,
        Jim Doolittle

        My Twitter
        My Hardware & Software

        Comment


        • #5
          wait command worked!

          Jim,

          I tried the wait command and it seems to work for me.

          Thank you!

          -phillip

          Comment

          Working...
          X