Announcement

Collapse
No announcement yet.

Internet Access is a No Go

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Internet Access is a No Go

    I've been trying for over a week to set up my system to permit my HomeSeer software to be accessed from the internet. I have been operating for some time with no problems accessing my HomeSeer PC from other computers on my network. These are the steps I've taken to get internet access which follow the procedures in the help section of HS entitled "Using the HomeSeer with a Router" (which in my case is a D-Link 713P):

    1) I tried to change my dynamic IP to a static IP for my HS computer but my ISP (Road Runner) would not accept that mode and insisted on changing it back to dynamic.

    2) I've assigned port 80 to the dynamic IP of my HS computer.

    3) I've placed the WAN IP of a friends PC into the Trusted zone for my Zone Alarm Software. At times I've also turned off Zone Alarm while attempting contact.

    4) I obtained my WAN IP address and have given it to a friend to attempt contact with my PC.

    Each time an attempt is made to contact it is rejected with the standard ."Connection was refused when trying to connect to ..... ".

    I've run out of ideas. I have not tried other ports as I have no idea of which ones might be open. Any help is appreciated.

  • #2
    I assume that you are trying to access from the outside by typing in your ISP-provided WAN IP address. Have you set up your D-Link router to forward incoming traffic (on port 80 of the WAN address) to the HS computer's LAN IP address? This is a required step.

    Comment


    • #3
      Your assumption is correct and yes I have set up the router to forward requests for port 80 to to my HS LAN IP.

      Comment


      • #4
        Do you have the XP firewall active? If so you may need to by pass this as well.
        -Rupp
        sigpic

        Comment


        • #5
          I'm using Win 98 SE at the present on an old computer.

          Comment


          • #6
            when in doubt, ping it out

            can you ping your router from your freinds computer(assuming the discard ping from wan side is disabled on your router if available)
            If it ain't broke, don't fix it!

            Comment


            • #7
              Is it possible your ISP is blocking port 80? Try changing HomeSeer's port and your forwarded port in your router to something else. 8080 is popular, some use 81.

              Comment


              • #8
                I tried port 8080 with the same results. I'll try 81 next.

                Comment


                • #9
                  The ping worked OK indicating that my router was responding to a quiry via the internet. So it must be the port assignment (or something else). I'll try port 81.

                  Comment


                  • #10
                    LaCrow -

                    Did you already read this post?

                    http://board.homeseer.com/showthread...nternet+Access

                    Comment


                    • #11
                      Port 81 worked OK and communication to HS is established over the net. I guess I should have tried more ports from the beginning.

                      Comment


                      • #12
                        Shawn,
                        I wish I would have read the post you highlighted. It might have spurred me on to try more ports.

                        Comment


                        • #13
                          I may have crowed too soon when my friend was able to access my HomeSeer system. Although he can view everything he apparently cannot cause a change to the status of any of my X-10 modules. Each time he attempts to do so the message "Web Server Error 404, cannot serve file: C:\PROGRAM FILES\HOMESEER\html/favicon.ico" shows up in the log. I have him assigned a "Normal" access right which I assume allows limited control of unit status. Unforturnately the current HS Help section does not even include the "Normal" category. BTW, I'm using version 1.7.25 of HS. Any ideas?

                          Comment


                          • #14
                            LarCrow,

                            The message file: C:\PROGRAM FILES\HOMESEER\HTML/favicon.ico" can be ignored. There's nothing in my help file on the new normal user so I'm not sure if they are automatically granted control access or not.
                            -Rupp
                            sigpic

                            Comment


                            • #15
                              This sounds like an area the programmers need to fix. Fix the message and either fix the Normal category or get it in the Help file so we know how to use it. I guess I'll give my friend the Admin access right for the time being to complet the web check out.

                              Comment

                              Working...
                              X