Announcement

Collapse
No announcement yet.

Web Server hanging up?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Web Server hanging up?

    I don't have a lot of information to to trace the problem, but my HS web server has been hanging up for the last several days randomly. HS is running perfectly, but when I try to access the http://localhost:8080/ , from the LAN http://machinename:8080 or from the outside http://mydomainname.com:8080 , I get no response. The only fix seems to be to stop and restart HS. I have tried to disable and then enable the webserver within HS, but that does not work. My regular homepage, running on Xitami(port 80) runs along perfectly. The only thing that might have changed is that I have two 2K advanced servers on the LAN that I have been working on Active Directory lately. This setup has been runnig flawlessly for over a year!

    Has anyone else noticed random webserver stops in build 24?

    Richard Braddock

    #2
    Yes I have. It seems to be mostly related to serving ASP pages. If I leave my default page as the status page it seems to happen less often but this could just be a coincidence. When mine locks up, or appears to lock up, I continue to retry connecting and it eventually will serve a page. I have only had to shut down and restart HS a few of times.

    -Rupp
    -Rupp
    sigpic

    Comment


      #3
      There have been posts recently (1 month ago) which have indicated that if u are using UltraView 2 & weather scripts ...to serve xml pages this causes errors and eventually the HS web server dies . Check your log files for events like " unable to serve xxxx.gif" . If so you may need to mod the ultra_view2_xml.txt file and add item to detect weather devices.

      Hope this helps ...

      Scott

      MKHome

      Comment


        #4
        ScottBullock

        You may be right. Thank you for the reply. I looked in the log to see when it last stopped and found the interesting entries from different times that it had stopped:

        1/5/2002 11:49:02 AM~!~Info~!~Web Server stopped

        1/5/2002 8:15:11 PM~!~Web Server Error 404~!~Cannot serve file: D:\Program Files\HomeSeer\html/weathericons/thermos/N/A.gif
        1/5/2002 8:15:11 PM~!~Web Server Error 404~!~Cannot serve file: D:\Program Files\HomeSeer\html/weathericons/dewpoint/tN/A.gif
        1/5/2002 8:15:11 PM~!~Web Server Error 404~!~Cannot serve file: D:\Program Files\HomeSeer\html/weathericons/wind/.gif

        1/6/2002 5:27:44 AM~!~Info~!~Web Server Error: 24048 Specified address is already in use

        Richard Braddock

        Comment

        Working...
        X