Announcement

Collapse
No announcement yet.

Icons not working on IR web page

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Icons not working on IR web page

    I am trying to use .bmp icons to replace the standard buttons on my IR web page. I have entered the correct address for the new buttons. The web page on the host machine works fine. But on my client pc's the new images are not showing up. I am getting the x where the icons are supposed to be. If I remove the icon info the standard icons come up fine. I checked the source code on the client page and it references the new buttons correctly. What I am doing wrong?

    Help. Source is listed below. Icon problems with "DSS", MP3, Play

    <html>
    <head>
    <link rel="stylesheet" type="text/css" href="style.css">
    </head>
    <b><h3>Hifi Audio Control</h3><hr noshade><form method="post">
    <input type="hidden" name="irctref" value="39022"><input type="hidden" name="ref_page" value="irct?irct_location=Hifi&irct_name=Audio Control"><table border="0" cellpadding="0" cellspacing="0" width="0%">
    <tr></tr>
    <tr><td colspan="1" class="irbuttoncell"><input type="image" border="0" name="index=1" src="C:\Program Files\HomeSeer\html\Buttons\dss.bmp"></td><td colspan="1" class="irbuttoncell"><input type="image" border="0" name="index=3" src="C:\Program Files\HomeSeer\html\Buttons\play.bmp"></td><td colspan="1" class="irbuttoncell"><input type="image" border="0" name="index=2" src="C:\Program Files\HomeSeer\html\Buttons\mp3.bmp"></td></tr>
    <tr><td colspan="1" class="irbuttoncell"></td><td colspan="1" class="irbuttoncell"></td><td colspan="1" class="irbuttoncell"></td></tr>
    <tr><td colspan="1" class="irbuttoncell"><input class="irbutton" type="submit" name="index=4" value="Back">
    </td><td colspan="1" class="irbuttoncell"><input class="irbutton" type="submit" name="index=5" value="Stop">
    </td><td colspan="1" class="irbuttoncell"><input class="irbutton" type="submit" name="index=6" value="Next">
    </td></tr>
    <tr><td colspan="1" class="irbuttoncell"><input class="irbutton" type="submit" name="index=7" value="Jazz">
    </td><td colspan="1" class="irbuttoncell"><input class="irbutton" type="submit" name="index=8" value="Blues">
    </td><td colspan="1" class="irbuttoncell"><input class="irbutton" type="submit" name="index=9" value="RnB">
    </td></tr>
    <tr><td colspan="1" class="irbuttoncell"><input class="irbutton" type="submit" name="index=10" value="Prog">
    </td><td colspan="1" class="irbuttoncell"><input class="irbutton" type="submit" name="index=11" value="Rege">
    </td><td colspan="1" class="irbuttoncell"><input class="irbutton" type="submit" name="index=12" value="Class">
    </td></tr>
    <tr><td colspan="1" class="irbuttoncell"><input class="irbutton" type="submit" name="index=13" value="Ch-">
    </td><td colspan="1" class="irbuttoncell"><input class="irbutton" type="submit" name="index=14" value="Clear">
    </td><td colspan="1" class="irbuttoncell"><input class="irbutton" type="submit" name="index=15" value="CH+">
    </td></tr>
    <tr><td colspan="1" class="irbuttoncell"><input class="irbutton" type="submit" name="index=16" value="Vol-">
    </td><td colspan="1" class="irbuttoncell"><input class="irbutton" type="submit" name="index=17" value="Mute">
    </td><td colspan="1" class="irbuttoncell"><input class="irbutton" type="submit" name="index=18" value="Vol+">
    </td></tr>
    </table>
    </form>
    <hr>

    <p><a href="/">Home</a> | <a href="/evls">Events</a> | <a href="/stat">Status</a></p>

    <p><a href="http://www.homeseer.com"><img src="powered.jpg" border=0></a></p>
    </body>
    </html>

    Robert Silver

    #2
    Change the src for your images.
    Instead of:
    C:\Program Files\HomeSeer\html\Buttons\dss.bmp

    Use:
    /Buttons/dss.bmp

    The src for an image needs to be from the root html directory.

    Jeff Farmer
    HomeSeer user since March, 2000

    --
    Jeff Farmer
    HS 3, HSPhone
    My HS3 Plugins: CFHSExtras, Random, Restart, Tracker, WeatherXML, PanaBluRay
    Other Plugins In Use: APCUPSD, BLOnkyo, Device History, EasyTrigger, HSTouch Server, PHLocation2, Pushover, RFXCom, UltraGCIR3, UltraMon3, UltraPioneerAVR3, X10, Z-Wave

    Hardware: GoControl Irrigation Controler, Schlage Lever Lock, Schlage Deadbolt, Way2Call Hi-Phone, RFXCom RFXrec433 Receiver, WGL 800, TI-103, Z-Net, Pioneer 1120, Pioneer 1021, Pioneer LX302, Panasonic BDT-110, Panasonic BDT-210 x2

    Comment


      #3
      Jeff,

      I put the button folder in the root directory. New src is "c:/buttons/dss.bmp"

      Same result. Shows up on the local machine but not on my clients.

      Robert Silver

      Comment


        #4
        The root html directory is the homeseer/html dir. A web server treats the root html dir as its home. Then you have to tell the web server how to get to the image you want sent with the page.
        So use / as home which is the html dir.

        So put your buttons back in "C:\Program Files\HomeSeer\html\Buttons\"
        They are fine there.
        What you need to edit is where you add the buttons to the IR device. The pathway to the buttons should be entered from the html dir.
        So where you currently typed in "C:\Program Files\HomeSeer\html\Buttons\dss.bmp" change that to "/buttons/dss.bmp"

        Jeff Farmer
        HomeSeer user since March, 2000

        --
        Jeff Farmer
        HS 3, HSPhone
        My HS3 Plugins: CFHSExtras, Random, Restart, Tracker, WeatherXML, PanaBluRay
        Other Plugins In Use: APCUPSD, BLOnkyo, Device History, EasyTrigger, HSTouch Server, PHLocation2, Pushover, RFXCom, UltraGCIR3, UltraMon3, UltraPioneerAVR3, X10, Z-Wave

        Hardware: GoControl Irrigation Controler, Schlage Lever Lock, Schlage Deadbolt, Way2Call Hi-Phone, RFXCom RFXrec433 Receiver, WGL 800, TI-103, Z-Net, Pioneer 1120, Pioneer 1021, Pioneer LX302, Panasonic BDT-110, Panasonic BDT-210 x2

        Comment


          #5
          Thanks. It worked!

          Bob

          Robert Silver

          Comment


            #6
            Icons not working on Audrey or PocketPC. Now they work fine on my PC but on the PPC they don't even show up and the Audrey gives me an error. Is there a format these need to be saved in?

            Robert Silver

            Comment


              #7
              They more than likely need to be JPG or GIF's

              -Rupp
              Isn't Disney World a people trap operated by a mouse?
              -Rupp
              sigpic

              Comment

              Working...
              X