Announcement

Collapse
No announcement yet.

Problem setting SSL server

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Problem setting SSL server

    Attached Files

    #2
    Ports...

    I believe you are trying to start the Web server on port 84 and 443.
    I don't think HS can do both.
    also the extra subnet authorizing on 192.168.127.0, at bottom, looks fishy???
    ...JG
    HS2PRO - Ocelot, SecuIR, Secu16, Attendence Management Alarm Interface, X-10, LCD Studio VFD Display, 3 Apexis IP Cams, Custom Software Interfaces, GMQ Geiger Graphing
    HS3PRO - Testing

    Comment


      #3
      Thanks Jebus. I tried disabling the "normal" server with same results. I agree the extra subnet doesn't look right, but I don't know what should be there. I appreciate your help.

      Comment


        #4
        Try changing the secure port from 443 to something else like 8443, I would bet IIS or some other web server is listening on that port before Homeseer gets to it. You would then address it in your browser as https://yourservername:8443 I have both secure as well as non-secure running at the same time with no issues.

        As far as the subnet goes if you look closely what you are seeing is 192(dot)168(comma)127(dot)0 which actually means any starting with 192.168 and any subnet starting with 127.0

        I believe that is the default setting on a clean install.


        Matt

        Comment


          #5
          That worked matthewb. Thanks! You have good eyes, there is indeed a comma between the two subnets. Two for two.

          Comment


            #6
            Similar Problem

            Power failure the other night. Everything comes back up except for Web Server. Everything else loads and works fine. I can't log onto HS but the startup log is visable. Below is a clip from that log. Please help me get things back, I'm starting to get gitters from not checking things
            Thanks
            Dave Everson









            6/20/2007 06:39:10 PM - Info - Local IP address is: 192.168.1.8/24
            6/20/2007 06:39:10 PM - Info - The web server has been bound specifically to IP address 192.168.1.2
            6/20/2007 06:39:10 PM - Info - Web Server started on IP Address 192.168.1.2, port 80
            6/20/2007 06:39:10 PM - Warning - Web Server Stopped
            6/20/2007 06:39:13 PM - Info - The SSL web server has been bound specifically to IP address 192.168.1.2
            6/20/2007 06:39:13 PM - Info - SSL Web Server started on IP Address 192.168.1.2, port 443
            6/20/2007 06:39:13 PM - Error - SSL Web Server could not start: The requested address is not valid in its context
            6/20/2007 06:39:13 PM - Warning - SSL Webserver Stopped
            6/20/2007 06:39:22 PM - CADDX Alarm - Garage Door Opened
            6/20/2007 06:39:25 PM - CADDX Alarm - Garage Door Closed
            6/20/2007 06:39:49 PM - Error - Web Server connections are blocked. Check firewall and anti-spyware
            6/20/2007 06:39:49 PM - Info - Creating ASP.NET application host...
            Last edited by deverson1; June 20, 2007, 07:19 PM. Reason: No signiture

            Comment


              #7
              Temporarily stop IIS (IISRESET /STOP in a command window). Restart HS and change the SSL port from 443 back to what you had before. Start IIS back up (if you need it - IISRESET /START).

              Looks like maybe HS is losing the web server port number configuration?

              Comment


                #8
                Originally posted by deverson1 View Post
                Power failure the other night. Everything comes back up except for Web Server. Everything else loads and works fine. I can't log onto HS but the startup log is visable. Below is a clip from that log. Please help me get things back, I'm starting to get gitters from not checking things
                Thanks
                Dave Everson

                6/20/2007 06:39:10 PM - Info - Local IP address is: 192.168.1.8/24
                6/20/2007 06:39:10 PM - Info - The web server has been bound specifically to IP address 192.168.1.2
                6/20/2007 06:39:10 PM - Info - Web Server started on IP Address 192.168.1.2, port 80
                6/20/2007 06:39:10 PM - Warning - Web Server Stopped
                6/20/2007 06:39:13 PM - Info - The SSL web server has been bound specifically to IP address 192.168.1.2
                6/20/2007 06:39:13 PM - Info - SSL Web Server started on IP Address 192.168.1.2, port 443
                6/20/2007 06:39:13 PM - Error - SSL Web Server could not start: The requested address is not valid in its context
                6/20/2007 06:39:13 PM - Warning - SSL Webserver Stopped
                6/20/2007 06:39:22 PM - CADDX Alarm - Garage Door Opened
                6/20/2007 06:39:25 PM - CADDX Alarm - Garage Door Closed
                6/20/2007 06:39:49 PM - Error - Web Server connections are blocked. Check firewall and anti-spyware
                6/20/2007 06:39:49 PM - Info - Creating ASP.NET application host...
                It appears that you pulled a new IPaddress when you lost power and HomeSeer was bound to the old address. Do a search on your old IPaddress in your settings.ini file (in the config directory) and replace that with your new IPaddress.
                -Rupp
                sigpic

                Comment


                  #9
                  This is a copy of my settings.ini file. I can't find where HS sets the IP address except for the 192.168.127.0
                  I know I'm probably in the wrong settings.ini but this is the only one I found.
                  It was in the config subdirectory.
                  Thanks
                  Dave Everson






                  [Settings]
                  restore=0
                  gLogName=HOMESEER.LOG
                  gWebLinks=26559
                  gSelectedLocationWeb=All Locations
                  gSelectedGroupWeb=All Groups
                  gSelectedGroup=All Groups
                  smtp_from=user@HomeSeer
                  smtp_def_subj=HomeSeer Event
                  gWebSubnets=192.168,127.0
                  gWebPageTitle=HomeSeer Web Control
                  ack_string=yes sire
                  ignoreack_string=ignoreack_string
                  att_string=computer
                  gLastShutdownOK=False
                  gFirstTimeRun=False
                  gLogSpeech=1
                  security_mode=0
                  gLogShowBalloon=0
                  last_event_time=6/22/2007 06:31:00 AM

                  Comment


                    #10
                    Try shutting down HS and then backing up and then deleting your settings.ini file, then restart HS and reset the SSL information.
                    -Rupp
                    sigpic

                    Comment


                      #11
                      OK, one problem down, one to go. HS loaded sample.mbl. How do I find out which file I was using before the outage?
                      Thanks again
                      Dave Everson

                      Comment


                        #12
                        All is good in the neighborhood!!! Spent a few hours cursing and changing and resetting and it apprears everything is back to "normal".
                        Thanks to all
                        Dave
                        I hope that guy from Batavia comes home pretty soon!!!

                        Comment

                        Working...
                        X