Announcement

Collapse
No announcement yet.

APCUPSD HS3 Pro Sel AP9619

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • MarvD
    started a topic APCUPSD HS3 Pro Sel AP9619

    APCUPSD HS3 Pro Sel AP9619

    I am trying to configure an APC UPS with a network management card AP9619. I have the HomeSeer Pro Sel Unix Cube. If the instructions are here someplace, please direct me. Otherwise I would appreciate any assistance.


  • MarvD
    replied
    I toyed with this a bit more. After searching the web a bit, I ran across this:

    Set the default start flag.
    Set ISCONFIGURED to yes in /etc/default/apcupsd

    # Defaults for apcupsd initscript

    # Apcupsd-devel internal configuration
    APCACCESS=/sbin/apcaccess
    ISCONFIGURED=yes

    Mine was set to "no"

    After making this change to "yes". I get a successful restart
    homeseer@hometrollerSEL:/etc/default$ sudo service apcupsd restart
    Stopping UPS power management: No process in pidfile '/var/run/apcupsd.pid' found running; none killed.
    apcupsd.
    Starting UPS power management: apcupsd.

    When I used pcnet I kept getting "Communication Lost"

    I changed it to the following:

    UPSTYPE snmp
    DEVICE 192.168.10.246:161:APCrivate

    I get the attached result screen... with the attached homeseer screen.

    Now for the next part, how do I get it configured for the other 4 UPSs?

    Thanks for all your help, I hope this is helping others.




    Leave a comment:


  • zwolfpack
    replied
    Still a couple issues with your configuration file

    - 2nd photo, last line, which starts with "pcnet" ... this line is part of descriptive text and isn't meant to be uncommented. Restore it to the original by adding back the # character at the start of the line.

    - 3rd photo where you have

    UPSTYPE apcsmart
    DEVICE 192.168.10.246:apc:apc:3551

    change to

    Code:
    UPSTYPE pcnet
    DEVICE 192.168.10.246:username:passphrase
    where username and passphrase are replaced with what you use to log into the UPS web interface.

    Leave a comment:


  • MarvD
    replied
    I am still trying to get this to work, now when I go to do a restart i get an error. There are also five screen shots of the apcupsd.conf.
    Again, thanks for your help.

    Leave a comment:


  • zwolfpack
    replied
    In the first picture, UPSTYPE should be 'pcnet' rather than 'net'.

    Leave a comment:


  • MarvD
    replied
    I tried changing it to the first attachment.

    Same error as before "ComLost"

    I tried changing it to the SNMP

    Same error as before "ComLost"
    It could be something I have done wrong, not a Unix person here so crash coarse in VI to edit the file.

    Tried rebooting the device and now I get the final black attachment

    I also included a screen shot showing SNMP on the APC is at default and enabled.

    Leave a comment:


  • zwolfpack
    replied
    Do you have a username/password to login to the UPS webpage? If so, the configuration suggestions I gave in post #3 may not be appropriate. Instead, in your /etc/apcupsd/apcupsd.conf, try the following

    - find line starting with UPSTYPE - change to UPSTYPE pcnet
    - find line starting with DEVICE - change to
    Code:
    DEVICE ipaddress:username:passphrase
    where ipaddress is the UPS IP address and username, passphrase are what you use to login to the webpage
    - restart apcupsd service

    Code:
    sudo service apcupsd restart
    - check for success

    Code:
    apcaccess
    Note: this idea from http://nuclear.unh.edu/wiki/pdfs/apcupsd-manual.pdf page 32.

    Leave a comment:


  • MarvD
    replied
    First, thank you all for your help. I think I am making headway; however, I think I still got something wrong.
    See attached.

    Leave a comment:


  • zwolfpack
    replied
    Let's back up a bit, as what the plugin author wrote in post #2 and I amplified on in post #3 may have missed the mark.

    This APCPSD plugin does not interface directly with your network management card. Instead, the plugin communicates with a program called APCUPSD, which in turn interfaces with various UPS models.

    What I wrote in post #3 is the instructions to install and configure APCUPSD on a Linux system (in your case, the SEL). Once APCUPSD is talking to the UPS, you configure the plugin to point to the running APCUPSD, rather than the network management card as you now have.

    In order to perform the installation, you will need to gain access to the Linux command line. This can be done by connecting a monitor and keyboard to the SEL unit, or you can use a program called PuTTY to remote in from another PC.

    Leave a comment:


  • MarvD
    replied
    This is the HomeSeer Unit I have
    Attached Files

    Leave a comment:


  • MarvD
    replied
    All of my UPSs are connected via ethernet, not USB / serial.

    Leave a comment:


  • MarvD
    replied
    The first screen is taken from the network management card in the UPS.

    Leave a comment:


  • zwolfpack
    replied
    What is the program running in the first screenshot? Is that running on the SEL or somewhere else? What did you do to set that up?

    I don't have a SEL - does it have an attached monitor+keyboard+mouse, or do you remote in from another computer?

    It isn't necessary to stop HS3 to do other things on the SEL. You can run multiple sessions simultaneously. You'll want to start a new session.


    Leave a comment:


  • MarvD
    replied
    Am I understanding correctly that you have to Exit HomeSeer3 to the Unix OS of the HomeSeer Pro Cube and make the changes above? Here are some screenshots if that helps.
    Attached Files

    Leave a comment:


  • zwolfpack
    replied
    http://nuclear.unh.edu/wiki/pdfs/apcupsd-manual.pdf page 59.

    Then install apcupsd on the Linux system:

    Code:
    sudo apt-get update
    sudo apt-get -y install apcupsd
    You'll need to edit the configuration /etc/apcupsd.conf

    - find line starting with UPSTYPE - change to UPSTYPE net
    - find line starting with DEVICE - change to DEVICE ipaddress:3551 where ipaddress is the IP address assigned above.
    - find line starting with NISIP - change to NISIP 0.0.0.0
    - restart apcupsd service
    Code:
    sudo service apcupsd restart
    - check for success
    Code:
    apcaccess
    Should return something like this
    Code:
    APC      : 001,035,0896
    DATE     : 2019-03-19 17:31:02 -0700
    HOSTNAME : Z-Not
    VERSION  : 3.14.14 (31 May 2016) debian
    UPSNAME  : hometroller
    CABLE    : Ethernet Link
    DRIVER   : NETWORK UPS Driver
    UPSMODE  : Stand Alone
    STARTTIME: 2019-02-20 22:14:29 -0800
    MASTERUPD: 2019-03-19 17:31:02 -0700
    MASTER   : hometroller:3551
    MODEL    : Back-UPS ES 550G
    STATUS   : ONLINE SLAVE
    LINEV    : 122.0 Volts
    LOADPCT  : 13.0 Percent
    BCHARGE  : 100.0 Percent
    TIMELEFT : 57.7 Minutes
    MBATTCHG : -1 Percent
    MINTIMEL : 1 Minutes
    MAXTIME  : 0 Seconds
    SENSE    : Medium
    LOTRANS  : 92.0 Volts
    HITRANS  : 139.0 Volts
    BATTV    : 13.5 Volts
    LASTXFER : Automatic or explicit self test
    NUMXFERS : 0
    TONBATT  : 0 Seconds
    CUMONBATT: 0 Seconds
    XOFFBATT : N/A
    STATFLAG : 0x05000408
    SERIALNO : 4B1532P13962
    BATTDATE : 2015-08-06
    NOMINV   : 120 Volts
    NOMBATTV : 12.0 Volts
    FIRMWARE : 904.W1 .D USB FW:W1
    END APC  : 2019-03-19 17:31:14 -0700
    Last edited by zwolfpack; March 19th, 2019, 09:31 PM. Reason: Added change to NISIP setting

    Leave a comment:

Working...
X