Announcement

Collapse
No announcement yet.

APCUPSD for HS4

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    APCUPSD for HS4

    will this plugin be updated for HS4? i know you can still run it but was hoping to have a clean setup interface. lookin to upgrade to HS4 now.

    #2
    The current plugin is running with HS4. In terms of new version built on top of HS4, maybe but not sure when and really if. When the HS4 SDK and Alpha versions came out initially I tested the current plugin for compatibility and looked at building a new version on top of the HS4 SDK. Due to multiple changes in the HS4 SDK versus HS3 SDK including architectural changes, the effort became much bigger than initially hinted and I stopped any work.

    Comment


      #3
      I was using this under HS4 but had to turn it off due to some HTML compatibility issue.

      Basically, at least when in grid view, the APCU block caused the following block to have links back to APCU stuff, as though the APCU block is not properly closed and the following block gets its texted wrapped in acpu status links.

      Additionally going to the status/graphics page for APCU and then selecting the UPS you find it has many items linked, for example if you try to edit the row or col number of the graphics, those numbers are actually linked to the UPS status page. Even the save / delete icons are links back to the status page of the plugin (/apcupsd_ups?ups=1) making them unusable.

      I reported this a bug to homeseer as well.

      Comment


        #4
        Just to close this out, after waiting months for HS development to get to this one, here is the *cough* detailed response I got.

        Tyler Manson resolved this as Declined. Please update to the most recent build of HS4 and if the issue continues please reach out to the developer
        Well at least it did not suggest I reboot my computer as well.

        Last time I tried the plugin it has the same issue, I've removed it and would suggest since HS nor the Plug Dev seem inclined to fix this, then do not spend any money on this if you intend to use it on HS4.

        Comment


          #5
          Thank you - I literally installed it on Saturday but did not get round to trying to configure it however based on this thread, I have removed it now
          It is a shame as it seemed to be exactly what I needed

          Comment


            #6
            I checked with HS4 4.1.8.0 (Windows) displaying the devices for an APCUPSD in grid and list view. The « Start Time » device has an unexpected link when clicking on the icon (not the device name) to navigate to the plugin status page (/apcupsd_ups?ups=1) to show additional details and a chart. Clicking on the other icons displayed the « Features » pop up in grid view and no action in list view. The device string value of the « UPSx Name » device is the only one that should have such an html link to navigate to the ups page (/apcupsd_ups?ups=1) ; the text of the hyperlink has a value of « hostort is Enabled » or « hostort is Disabled ». In HS3 this works all as intended and looks like the HS4 page renderer has issues propagating that hyperlink (/apcupsd_ups?ups=1) defined for one device value to other areas for no reason. I don’t recall seeing this in early versions of HS4 during initial testing of the plugin. I had opened a ticket for other Web Browser compatibility issues (for another plugin). I understand HS4 should support HS3 plugins and provide compatibility.

            Comment


              #7
              That is the behavior I was/am seeing as well. Homeseer has deferred this to the developer to fix, till then its pretty much not workable in HS4

              Comment


                #8
                I posted Beta version 3.3.2.2 that will not include the hyperlink in the device. To ensure HS device status pairs are updated to remove the hyperlink:
                - shutdown the apcupsd plugin,
                - update the plugin installation to version 3.3.2.2 (it should be marked BETA in HS4 and in Beta section in HS3)
                - edit the hspi_apcupsd.ini file (in the config sub-directory of the HS3 or HS4 installation), remove the line that starts with "gIconSet=" and save the ini file
                - start the apcupsd plugin
                - check the devices and the navigation when clicking on names or icons in the grid or list view

                Comment

                Working...
                X