Announcement

Collapse
No announcement yet.

Configuration help for new HS4 install

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Configuration help for new HS4 install

    I installed APCUPSD as per the APCUPSD instrunctions on a new HomeTroller Pro HS4 system and APCUPSD is working fine (see attached), the tray icon shows current data and is updating

    Then I installed the Plugin version 3.3.2.3 but am not seeing any data (see attached).

    The only configuration item that seems relevant is the port designation however this is an APC Back-UPS 1500 with the USB interface so there is noo assigned comm port in Windows.

    TIA

    Best Regards

    edit: I found the devices, they had been build without a Floor designation, but there is still no data displayed.
    Attached Files

    #2
    Solved.

    The default APCUPSD configuration for a USB interface appears to require the comm port designation to be 3551.

    The only (very) little issue is a missing image for the Battery Charge device.


    Click image for larger version

Name:	APC 4.jpg
Views:	70
Size:	5.5 KB
ID:	1520781
    Best Regards

    Comment


      #3
      And just to be thoroughly OCD, there are actually 5 missing png images for the battery level device. The files are present but are of size 0.

      Best Regards
      Attached Files

      Comment


        #4
        Actually the missing PNG files are a bit of a nuisance, every callup of the device throws non-fatal errors into the log file. I found some silmilarly named PNG files in the images\apcupsd\classic directory and substituted them albeit they have a different 'look'

        Best Regards
        Attached Files

        Comment


          #5
          Upon startup, the plugin runs a shell script to build the icons based on the style used in HS3 configuration (don’t recall / know if this ui style config still exists in HS4; I m still using HS3). To install the icons, a (dos) schell script is executed and located in the contemporary or classic directory. Many icons are copied from the contemporary or classic directory to the status directory that HS3 uses at runtime. Some icons files are the default HS3 icons (in html/images/HomeSeer/status directory rather that plugin specific ones) and instead of physically copying these files on disk to html/images/apcupsd/status a s’y boric link is created by the install-icons.txt script (script specific to each style). Unfortunately it appears that script is not executed in an HS4 setup compared to a HS3 setup. You can check the script for your style and manually copy the files where the line starts with mklink from html/images/HomeSeer/status to html/images/apcupsd/status

          Comment


            #6
            Yeah, I found those and copied so everything looks good on HS4. Now registered as well. Thanks!

            Best Regards

            Comment

            Working...
            X