Announcement

Collapse
No announcement yet.

Support for networkupstools?

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Support for networkupstools?

    Is there any chance that this plugin could be extended to connect to a nut (network ups tools) server? I have several Eaton Powerware UPS's and I would like to monitor them with HS3.

  • #2
    I will have to look at it. Actually looked at it a bit way back but did not write any code. From what I recall, nut does not send all the information apcupsd is sending

    Comment


    • #3
      Originally posted by pcp View Post
      I will have to look at it. Actually looked at it a bit way back but did not write any code. From what I recall, nut does not send all the information apcupsd is sending
      Well, at least the important stuff like load, output current, input voltage, online status and so on is sent by nut. That would be enough for me. If you integrate nut support you would gain at least one more customer .

      Comment


      • #4
        My NAS uses NUT well... Gives me additional incentives to look at this at some point

        Comment


        • #5
          Originally posted by kkkk View Post
          Well, at least the important stuff like load, output current, input voltage, online status and so on is sent by nut. That would be enough for me. If you integrate nut support you would gain at least one more customer .
          Make that 2.
          My nas and Xenservers use nut also.

          Comment


          • #6
            I posted an updated version of the plug-in (V3.1) with support for NUT. Give it a try if still interested.

            Comment


            • #7
              Originally posted by pcp View Post
              I posted an updated version of the plug-in (V3.1) with support for NUT. Give it a try if still interested.
              I'm definitely interested but it doesn't work on my Linux HS3. All I get is:

              Code:
              Plugin: APCUPSD Instance:  starting...
              Connecting to server at 127.0.0.1...
              Disconnected from server - client
              Cannot connect(2): Object reference not set to an instance of an object
              and in the HS3 log I see:

              Code:
              03:49:19:8728:[Error]->Cannot load plugin APCUPSD, no license or trial expired
              03:49:19:8739:[Info]->Plugin APCUPSD has connected. IP:127.0.0.1:58276
              Error sending over stream: Write failure
              BTW, I'm getting the same behavior with other plugins if I try to run them either locally on the Linux HS3 or remotely on a Windows box and connecting to the Linux box. For instance, I tried that with the Harmony Hub plugin and the Airplayspeak plugin and they all show that "no license or trial expired" in the log as soon as they connect. I don't even get a chance to put in my license code. To me it looks like some generic incompatibility between the Windows and Linux licensing. But, I have two plugins running on HS3 Linux which require a license and they work properly, so there must be a way to make licensed plugins work on Linux.

              Comment


              • #8
                I have never tried and tested the plugin with HS3 On Linux, nor even tried HS3 on Linux. So no the plugin has not been developed to work on Linux, but I assume running it on Windows and connecting it to an HS3 running on Linux should work but do not have any experience with this. Have you posted in the HS3 forum as well to check if there is any issue?

                Comment


                • #9
                  The apcupsd does require a license or trial period to run, maybe they expired.

                  Comment


                  • #10
                    Originally posted by pcp View Post
                    The apcupsd does require a license or trial period to run, maybe they expired.
                    It was the first time I ever installed or started the plugin, so the trial period shouldn't be expired. I suspect some incompatibility between Windows and Linux licensing code because I can see the same behavior with at least 2 other plugins. And for these 2 other plugins I have a valid license installed on the Windows side.

                    I'm not sure where to ask about that on the forum. HST obviously won't fix the issue because it are 3rd party plugins. But I also have 2 3rd party plugins which require a license running fine on Linux, RFXCOM and iTunes DAAP.

                    Comment


                    • #11
                      I think I found a clue in the following thread http://forums.homeseer.com/showthrea...ight=licensing

                      Apparently, HS3 needs a copy of the plugin on the Linux side. Now, if I provide that with the apcupsd plugin it doesn't work because Linux is case-sensitive. I have to rename it or link it to the name HSPI_apcupsd.exe instead of hspi_apcupsd.exe, otherwise it's not recognized at all. But now, HS3 complains:

                      Code:
                      03:01:06:3106:[Error]->Error, Class not found in plugin EXE, maybe namespace is not correct,? Note filename is case sensitive!: HSPI_apcupsd.exe Class: HSPI_apcupsd.HSPI->
                      I hope that gives you some idea of what is wrong with your plugin.

                      Comment


                      • #12
                        Just installed this plugin on HS3 Linux. Getting the same error as above.

                        Code:
                        02:46:32:7143:[Error]->Error, Class not found in plugin EXE, maybe namespace is not correct,? Note filename is case sensitive!: HSPI_apcupsd.exe Class: HSPI_apcupsd.HSPI->
                        ...
                        02:47:08:4682:[Warning]->Plug-in apcupsd is set to load but was not found, removing from settings.
                        02:47:08:4720:[Error]->(1) Unable to initialize interface apcupsd :Either no license or trial has expired
                        02:47:08:4724:[Plug-In]->Finished initializing plug-in apcupsd
                        Kind of suprised it's in the updater when it won't run at all.

                        Comment


                        • #13
                          Originally posted by jowens14 View Post
                          Just installed this plugin on HS3 Linux. Getting the same error as above.

                          Code:
                          02:46:32:7143:[Error]->Error, Class not found in plugin EXE, maybe namespace is not correct,? Note filename is case sensitive!: HSPI_apcupsd.exe Class: HSPI_apcupsd.HSPI->
                          ...
                          02:47:08:4682:[Warning]->Plug-in apcupsd is set to load but was not found, removing from settings.
                          02:47:08:4720:[Error]->(1) Unable to initialize interface apcupsd :Either no license or trial has expired
                          02:47:08:4724:[Plug-In]->Finished initializing plug-in apcupsd
                          Kind of suprised it's in the updater when it won't run at all.
                          Works fine on Windows! Linux is not supported, never tested it with Linux and only supported on Windows.

                          Comment


                          • #14
                            If your intend is to run the plugin on Windows and HS3 on Linux, there appears to be an issue in HS3 as described in http://forums.homeseer.com/showthrea...ight=licensing ; you might want to open or update a bugzilla to see if HS can fix it.

                            Comment


                            • #15
                              Originally posted by pcp View Post
                              If your intend is to run the plugin on Windows and HS3 on Linux, there appears to be an issue in HS3 as described in http://forums.homeseer.com/showthrea...ight=licensing ; you might want to open or update a bugzilla to see if HS can fix it.
                              No windows involved here. Everything is running on linux.

                              I guess this would be a question for the HS team, but why is the plugin in the HS3 Linux updater if its not tested and not working?

                              Comment

                              Working...
                              X