Announcement

Collapse
No announcement yet.

Device codes... not adjacent

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Device codes... not adjacent

    Guys

    Has anyone found that the HS CC plugin does not seem to allocate adjacent device codes for "grouped" devices?

    I have two IAMs now along with the basic meter itself (obviously) and the IAM codes are not grouped in adjacent numbering making reading down them somewhat tedious.

    Also, I would expect (this was on a fresh install of the plugin) that you would get the first so many device codes allocated to the main unit, then IAM 1, then IAM2 etc... oh no... IAM1 is first up, then main unit, then IAm2... with a few misplaced devices for good measure... UGH!?!?!?

    This is *really* annoying - anyone else found that?

    Even more annoying is that you cannot change the device house/unit codes from the device properties screen...

    David
    ---------------------------------------------------http://weather.penicuik.org

  • #2
    I've just acquired a current cost and some IAMs. With a fresh installation it has allocated sequential device codes to each sensor parameter and they seem to be in the same order, but the sequence of sensors is apparently random.

    What has astonished me is the number of devices that it's created. 150 for 7 sensors! I think I might abandon this plugin and investigate MrHappys' script.

    Comment


    • #3
      In total agreement,

      I moaned about this in the first early threads, but Rick didn't understand what I was trying to point out, I think at the time he had only the main unit to play with

      The plug in looks OK with this one main sensor but I have 8 sensors, and a lot of house codes (over 180 ! Just counted them !), non sequentaily allocated, what a mess it looks, and more anoyingly 8 house codes (1 per sensor) all displaying the temperature reading from the one in the main unit.... I still can't understand that one.
      Last edited by stevepyle; October 19th, 2010, 04:10 PM. Reason: Just finished counting

      Comment


      • #4
        Originally posted by stevepyle View Post
        In total agreement,


        The plug in looks OK with this one main sensor but I have 8 sensors, and a lot of house codes (over 180 ! Just counted them !), non sequentaily allocated, what a mess it looks, and more anoyingly 8 house codes (1 per sensor) all displaying the temperature reading from the one in the main unit.... I still can't understand that one.
        I agree.... looks a mess... but at least they are there

        Glad I am not alone re ordering...

        It would perhaps be nice to have the option to select which values/counters for each device you want to display as we have overkill right now.

        As an aside.. wonder when this plugin leaves beta... is there a to-do list with respect to features not there yet (graphing of IAMs, filtering of displayed devices/values, adding icons to the devices) and bugs (ordering of devices and high utilisation)?

        David
        Last edited by Bestgear; October 20th, 2010, 05:18 AM.
        ---------------------------------------------------http://weather.penicuik.org

        Comment


        • #5
          Originally posted by Bestgear View Post
          I agree.... looks a mess... but at least they are there

          Glad I am not alone re ordering...

          David
          Couldn't be bothered to re order the house codes, to be honest I rarely use the HS home screen, just use mainlobby via touch screens, but putting a simple power meter sceen has been a pain to do with what seems random house code allocations.

          You should be able to get the other sensor graphs by typing in ?sensor=1 see the IAM thread you posted in

          Steve

          Comment


          • #6
            Hi Steve

            MANY THANKS for that tip re the other sensors...works a treat!

            David
            ---------------------------------------------------http://weather.penicuik.org

            Comment


            • #7
              I just tried deleting a handful of the devices that hold duplicate information, inc. Temperature, Display Unit Time, Realtime usage all channels.

              Doesn't seem to have done any harm (yet?) anyone else done this?

              Comment

              Working...
              X