Announcement

Collapse
No announcement yet.

CurrentCost plugin beta 1.0.0.60

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • CurrentCost plugin beta 1.0.0.60

    Some fixes to the graphs in this version.

    Download the DLL here:

    This update is on hold for now.
    website | buy now | support | youtube

  • #2
    Current Cost PLug-in SQL error mesage in log

    Installed current cost plug-in yesterday, all of the data being stored looks ok and reflects correct consumption. Log is (endlessly) repeating displaying this error:

    1/13/2012 8:00:09 AM Current Cost Error, SQL Exception adding record to the Temperature table of the history database: SQLite errorno such column: Infinity, Code=Error, Link=
    1/13/2012 8:00:09 AM Current Cost An attempt to add the weather device value of Infinity failed

    Attachments contain the plug setup and the homeseer system information. Tried beta 58 and 60 no change.

    any sugesstions?

    thanks

    -rick
    Attached Files
    -Rick

    Comment


    • #3
      I set the device value divisor (using config button for the plug-in) field to 1 as the default was a 0. After a few minites the log errors stopped and have not returned for more than 30 minutes.

      To confuse things a bit I had also set the logging level to debug prior to the above so I don't know if that had anything to do with resolving the log error or not - probably not, but who knows....

      -rick
      -Rick

      Comment


      • #4
        I set my update to 2 minutes....Data for today v's yesterday looks wrong
        HS3 Pro Edition 3.0.0.435 (Windows 10 vmware)
        BLOccupied:,UltraNetCam3:,weatherXML:,RFXCOM:,Current Cost 3P:,UltraGCIR3:
        DMMQTT:,Kodi:,Z-Wave:,BLRadar:,EasyTrigger:,MySensors:,BLBackup:

        Comment


        • #5
          Originally posted by dmurphy View Post
          I set my update to 2 minutes....Data for today v's yesterday looks wrong
          Can you elaborate a bit or better yet post an image and articulate what you see as the issue?
          -Rupp
          sigpic

          Comment


          • #6
            I would delete the old database and start fresh, that is what I did. When you change the save interval it may be messing up previous calculations.
            website | buy now | support | youtube

            Comment


            • #7
              Rupp here is an example.....look at hourly 1.5 ish look at today v yesterday 4 ish....

              Rich did rename the db and restart lets see how it goes.

              thanks.

              Dan
              Attached Files
              HS3 Pro Edition 3.0.0.435 (Windows 10 vmware)
              BLOccupied:,UltraNetCam3:,weatherXML:,RFXCOM:,Current Cost 3P:,UltraGCIR3:
              DMMQTT:,Kodi:,Z-Wave:,BLRadar:,EasyTrigger:,MySensors:,BLBackup:

              Comment


              • #8
                I just switched back to previous version, even after deleting database the today vs yesterday was way too high consumption....
                HS3 Pro Edition 3.0.0.435 (Windows 10 vmware)
                BLOccupied:,UltraNetCam3:,weatherXML:,RFXCOM:,Current Cost 3P:,UltraGCIR3:
                DMMQTT:,Kodi:,Z-Wave:,BLRadar:,EasyTrigger:,MySensors:,BLBackup:

                Comment


                • #9
                  I got the same thing... I was about to attach my file - but it looks the same. When the house was using a mere .5 kwh, the pluing reported a spike of over 4 kwh...
                  HS3PRO 3.0.0.500 as a Fire Daemon service, Windows 2016 Server Std Intel Core i5 PC HTPC Slim SFF 4GB, 120GB SSD drive, WLG800, RFXCom, TI103,NetCam, UltraNetcam3, BLBackup, CurrentCost 3P Rain8Net, MCsSprinker, HSTouch, Ademco Security plugin/AD2USB, JowiHue, various Oregon Scientific temp/humidity sensors, Z-Net, Zsmoke, Aeron Labs micro switches, Amazon Echo Dots, WS+, WD+ ... on and on.

                  Comment


                  • #10
                    I am looking into it, something is obviously not correct.
                    website | buy now | support | youtube

                    Comment


                    • #11
                      It will take a little time to get this fixed up, so for now, go back to the plugin that is in the updater. I will post an update when I have a fix.
                      website | buy now | support | youtube

                      Comment

                      Working...
                      X