Announcement

Collapse
No announcement yet.

HSTouch charts?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • HSTouch charts?

    I see there are other threads about charting problems, but I think mine are different. I also think there is an error in the hs help file. Here is the excerpt.

    HSTouch
    To display data in HSTouch, use the HomeSee Device Association and select a Current Cost device.

    To display graphs in HSTouch add an image element and set the ImageURL property to the following:
    Day vs Yesterday: [$SCRIPT=&hs.plugin(""Current Cost"").ChartDayVSYesterdayUrl(0,now,500,100)]
    Day: [$SCRIPT=&hs.plugin(""Current Cost"").ChartDayUrl(0,now,500,100)]
    Month: [$SCRIPT=&hs.plugin(""Current Cost"").ChartMonthUrl(0,now,500,100)]
    Month vs Last Month: [$SCRIPT=&hs.plugin(""Current Cost"").ChartMonthVSLastMonthUrl(0,now,500,100)]
    Last Hour: [$SCRIPT=&hs.plugin(""Current Cost"").ChartLastHourUrl(0,500,100)]

    Replace 0 with the sensor to chart (10=All 'Sensors To Add' sensors), replace ""now"" with an actual date for different days (must be mm/dd/yyyy format), replace 500 with the width of your chart and replace 100 with the height of your chart.
    I found not give any of these to work. I did find what I think is an error. I removed the extra " marks around Current Cost in the statement and now my Last Hour chart works. However, none of the other charts show any data. Today and Today vs Yesterday do not even show a chart. Month and Month vs. Last Month show the chart but no data.

    Since the help file was wrong, I want to make sure its not something simple like that. Any help is appreciated.
    -Tim

    HSPro - 3.XXX - Dell mini W7 x32
    Way2 Call
    Elk M1 Gold
    UPB HAI switches
    HAI RC2000 Thermostat

  • #2
    Put in a bug help desk ticket on this please.
    -Rupp
    sigpic

    Comment


    • #3
      Originally posted by Rupp View Post
      Put in a bug help desk ticket on this please.
      Thanks Rupp. I don't know that it's a bug though.
      -Tim

      HSPro - 3.XXX - Dell mini W7 x32
      Way2 Call
      Elk M1 Gold
      UPB HAI switches
      HAI RC2000 Thermostat

      Comment


      • #4
        I submitted a ticket. 4/29/2012

        Call ID: 23576

        I'll post back once resolved.
        -Tim

        HSPro - 3.XXX - Dell mini W7 x32
        Way2 Call
        Elk M1 Gold
        UPB HAI switches
        HAI RC2000 Thermostat

        Comment


        • #5
          Originally posted by email68 View Post
          I submitted a ticket. 4/29/2012

          Call ID: 23576

          I'll post back once resolved.
          Was this resolved? The idea of having graphs on my touchscreen sounds cool...

          Comment


          • #6
            What I tend to do is when going to a page, just run an event. I don't like using [$Script] since it seems to be something you need to use sparingly due to processor loading, since it is re-executed over and over.

            Then on the client, I only need to point to an image, served from HS itself.

            --Dan
            Tasker, to a person who does Homeautomation...is like walking up to a Crack Treatment facility with a truck full of 3lb bags of crack. Then for each person that walks in and out smack them in the face with an open bag.

            Comment


            • #7
              Originally posted by drozwood90 View Post
              What I tend to do is when going to a page, just run an event. I don't like using [$Script] since it seems to be something you need to use sparingly due to processor loading, since it is re-executed over and over.

              Then on the client, I only need to point to an image, served from HS itself.

              --Dan
              I think some clarifcation on these [$SCRIPT] commands would be nice, full credit to HST for giving us this option as I then used it in a number of plugins but I don't know how it is actually performing.

              When I used a [$SCRIPT=&Rnd()] command then every second it would give me a random number in the box, but if I did a [$SCRIPT=&hs.plugin(xxxxxxxx)] call then it only seemed to run once. Checking the debug logs only showed the download of the image done once which I thought meant that the procedure was just called on page load. If they ran every second for plugin calls I would imagine there could be issues with HS - so do some [$SCRIPT calls run at different intervals?

              Because the command only returns a URL you can also use a simple script to download the image to your html directory, then in HSTouch you just need to put 'http://localhostort/image.png' in the text field. This is sort of script I am talking about...

              Code:
              Dim Full As String = hs.plugin(""Current Cost"").ChartLastHourUrl(0,500,100)
              
              Act = Full.Replace("http://chart.apis.google.com", "")
              
              Result = hs.getURLImageEx("http://chart.apis.google.com", Act, hs.getapppath & "\html\images\cheat.png", 80)
              
              If Result <> "" Then
              
              hs.writelog("D/Image", "Image Error: " & Result)
              
              End If
              My Plugins:

              Pushover 3P | DoorBird 3P | Current Cost 3P | Velleman K8055 3P | LAMetric 3P | Garadget 3P | Hive 3P |
              Yeelight 3P | Nanoleaf 3P

              Comment


              • #8
                Originally posted by GadgetBoySI View Post
                Was this resolved? The idea of having graphs on my touchscreen sounds cool...
                Ever resolved? FYI, it's not working for me either.

                Comment

                Working...
                X