Announcement

Collapse
No announcement yet.

HS3PRO Current Cost Envi 3.0.0.14 - high cpu, no charts?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • HS3PRO Current Cost Envi 3.0.0.14 - high cpu, no charts?

    So I've kinda ignored my Current Cost Envi after porting to HS3 this year.

    Today while finishing the install of an EZFlora device, I noticed that the Current Cost plugin was eating 45% cpu on my core2 HS3 production machine. I fixed this by stopping the plugin, deleting the parent device which removes all child devices, restarting the plugin which recreated all the devices and now it seems much happier/quieter. I did not restart HS3. Guess only time will tell if this really fixed it or not.

    Next I went looking for the charts I used to have under HS2. What, no charts? Reading other threads it appears the HST HS3 plugin for current cost envi logs to the Energy API and that's it? So this is a collection only plugin now that produces no usable output (i.e. charts) on its own?

    I found what I think is the Energy API database under HS3\Data\Energy\Energy.hsd. On my production machine it's almost 15Mb. Are there planned enhancements to get data out of that and into some usable charts?
    HS 3.0.0.435 (PRO)
    Hardware: Napco GEM-P9600 | VenstarT1800 w/Insteon 2441V adapter | Insteon PLM
    Plugins HS3: Napco Gemini (mine) | Insteon Thermostat (mine) | Insteon Plug-in (mnsandler) | HSTouch Server (HST)
    Platform: Windows 10 Pro 64bit, core2 duo 2.0Ghz, 4GB memory
    http://www.kazteel.com/

  • #2
    Ok, I may have spoke too soon about the high cpu being fixed. Checking back in today, looks like the HST Current Cost Envi plugin is back to 48% cpu on my core2 machine running windows 7 64 bit.

    As mentioned in my last post, the Energy.hsd is about 15Mb. Is this too large? do I need to do some cleaning? I've only been running HS3 with this plugin since December.
    HS 3.0.0.435 (PRO)
    Hardware: Napco GEM-P9600 | VenstarT1800 w/Insteon 2441V adapter | Insteon PLM
    Plugins HS3: Napco Gemini (mine) | Insteon Thermostat (mine) | Insteon Plug-in (mnsandler) | HSTouch Server (HST)
    Platform: Windows 10 Pro 64bit, core2 duo 2.0Ghz, 4GB memory
    http://www.kazteel.com/

    Comment


    • #3
      I am having the same issue...weaker PC so the current cost.exe file is kicking my CPU usage up to about 90%!!! Disabling the plugin returns things to normal. Maybe needs to be reported as a bug?

      Comment


      • #4
        100% cpu

        enabling the current cost plugin causes the cpu utilization to jump to 100% and hs3 to become unusable. hight cpu utilization jumpts back and forth between the HS3 process and the plugin process. it seemed to run ok for a couple of days then this behavior started. restarting the plugin, HS or the entire system does not solve the problem.

        Disabling the plugin puts the HS3 process right back to 1-2% utilization. Nothing interesting in the logs

        Granted it is an older laptop but something is wrong.

        HS3: 3.0.0.96
        current cost: 3.0.0.14

        plugin disabled:
        Current Date/Time: 7/11/2014 12:58:38 PM Pacific Daylight Time
        HomeSeer Version: HS3 Pro Edition 3.0.0.96 (Windows)
        HomeSeer: Is Registered
        Operating System: Microsoft Windows 7 Professional - Work Station
        OS Version: 6.1.7600 Service Pack: 0.0
        System Uptime: 0 Days 0 Hours 30 Minutes 33 Seconds
        User Name and Access Level: default (Admin)
        LAN IP Address: xx (homeseer-PC)
        Client IP Address:
        External IP Address: xx
        Network Adapter: HomeSeer Adapter -> Realtek PCIe FE Family Controller IP: 10.10.10.250/24 MAC: 00:26:9E:C5:90:4C
        Network Adapter: HomeSeer Adapter -> Loopback Address (localhost) IP: 127.0.0.1
        Web Server Port/SSL Port: 1998 / 443
        Number of Devices: 209
        Number of Events: 226
        Event Last Ran: Security : AST check for all doors closed, Ran at 7/11/2014 12:10:14 PM
        Number of unique event scripts used: 0
        Plug-Ins Enabled: DSC Security:,X10:,Z-Wave:,UltraSMTP3:,weatherXML:,UltraNetCam3:,HSTouch Server:
        Processor Type and Speed: AMD64 Family 16 Model 6 Stepping 2 at 1.96 GHz
        Modules/Threads: 120 Modules, 72 Threads
        System Processes/Load: 74 Processes, 5% Load
        Free / Total Physical Memory: 945.39 MBytes / 1.75 GBytes (53% free)
        Free / Total Virtual Memory: 2.13 GBytes / 3.49 GBytes (61% free)
        HomeSeer Memory Used: 77 Mbytes
        Plug-In Memory Used: 7 EXE Plug-Ins using 134 Mbytes

        Plugin enabled:
        Current Date/Time: 7/11/2014 1:01:15 PM Pacific Daylight Time
        HomeSeer Version: HS3 Pro Edition 3.0.0.96 (Windows)
        HomeSeer: Is Registered
        Operating System: Microsoft Windows 7 Professional - Work Station
        OS Version: 6.1.7600 Service Pack: 0.0
        System Uptime: 0 Days 0 Hours 33 Minutes 11 Seconds
        User Name and Access Level: default (Admin)
        LAN IP Address: xx (homeseer-PC)
        Client IP Address:
        External IP Address: xxx
        Network Adapter: HomeSeer Adapter -> Realtek PCIe FE Family Controller IP: 10.10.10.250/24 MAC: 00:26:9E:C5:90:4C
        Network Adapter: HomeSeer Adapter -> Loopback Address (localhost) IP: 127.0.0.1
        Web Server Port/SSL Port: 1998 / 443
        Number of Devices: 209
        Number of Events: 227
        Event Last Ran: hvac : house vent system timed, Ran at 7/11/2014 1:00:00 PM
        Number of unique event scripts used: 0
        Plug-Ins Enabled: DSC Security:,X10:,Z-Wave:,UltraSMTP3:,weatherXML:,UltraNetCam3:,HSTouch Server:,Current Cost:
        Processor Type and Speed: AMD64 Family 16 Model 6 Stepping 2 at 1.96 GHz
        Modules/Threads: 120 Modules, 76 Threads
        System Processes/Load: 76 Processes, 100% Load
        Free / Total Physical Memory: 881.58 MBytes / 1.75 GBytes (49% free)
        Free / Total Virtual Memory: 2.04 GBytes / 3.49 GBytes (58% free)
        HomeSeer Memory Used: 115 Mbytes
        Plug-In Memory Used: 8 EXE Plug-Ins using 219 Mbytes

        Comment


        • #5
          I'm experiencing the same issue with CPU and the current cost plugin, the difference being I'm on plugin 3.0.0.35.

          Was there ever a resolution to the issue?

          Comment


          • #6
            Still not working under HS3 ?

            It's been a year since I looked at my Current Cost Envi. I had to go put new batteries in the sender unit. good new is sender and display are now happy again.

            I am on HS3.0.0.181 I used the updater for this plugin to 3.0.0.33.

            Confirmed COM3 is correct. Nothing happening. Turned logging to debugging. Nothing. Played with the COM ports and was finally able to filter the Log and see a complaint when I switched from COM3 to COM8 (know COM8 isn't correct but was testing) Switched back to COM3. Nothing new.

            Rebooted HS3. Everything starts but nothing in log or devices. At least (so far) the plugin isn't eating high CPU yet...

            I deleted my old Current Cost devices and used the Config page to recreate. Shiny new HS3 devices. All saying 0. Still nothing in the log.

            Is there anything I can do with this plugin that I paid for back when I bought my Current Cost Envi under HS2 ? Seems it just never worked under HS3 ?
            HS 3.0.0.435 (PRO)
            Hardware: Napco GEM-P9600 | VenstarT1800 w/Insteon 2441V adapter | Insteon PLM
            Plugins HS3: Napco Gemini (mine) | Insteon Thermostat (mine) | Insteon Plug-in (mnsandler) | HSTouch Server (HST)
            Platform: Windows 10 Pro 64bit, core2 duo 2.0Ghz, 4GB memory
            http://www.kazteel.com/

            Comment


            • #7
              Any resolution for this issue?

              I'm on HS3 linux.
              Had to use the beta ver 3.0.0.35 of the plugin because the production
              plugin doesn't seem to support the new currentcost that runs at 57600 baud.
              It's like not stated anywhere. So disappointed

              Comment


              • #8
                Bump up.

                No resolutions?
                My current cost is sitting idle.

                Comment

                Working...
                X