Announcement

Collapse
No announcement yet.

Stopped Updating

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • rascasse
    replied
    Originally posted by fuzzysb View Post
    rascasse the energy history is because an incorrect value has been written due to issue and troubleshooting. you either need to open the energy DB (Energy.hsd file located in the Data\Energy folder within the Homeseer install directory) with https://sqlitestudio.pl/index.rvt and delete the values showing extremely large values (make sure you stop the homeseer whilst making the change) or just stop homeseer and delete the file, and a new one will be created starting from afresh.
    I deleted the DB again and the values look correct thanks.

    Leave a comment:


  • Mobileum
    replied
    Progress! Now the value stick to the INI-file included correct currency, but it is not updated in HS. Still have the wrong value here from the last trials (1,2).

    Here is the INI:

    [EFERGYENGAGE]
    access_token=xxxxx
    [EFERGYCOST]
    per_kw_cost=kr 1,20

    Dont know if this is correct, but when I enter the value in the Config with a period, and then look at it in the INI-file, it has replaced the dot with a comma. Here is a paste from HS:

    Click image for larger version

Name:	hs.png
Views:	15
Size:	32.6 KB
ID:	1282018Click image for larger version

Name:	hs.png
Views:	28
Size:	32.6 KB
ID:	1282019

    Leave a comment:


  • fuzzysb
    replied
    Mobileum ok i've just released v1.0.0.129 Beta, if you input the value with a decimal (.) it will save it as your currency, after you quit and restart the plugin you should see it hopefully displayed correctly in your currency.

    rascasse the energy history is because an incorrect value has been written due to issue and troubleshooting. you either need to open the energy DB (Energy.hsd file located in the Data\Energy folder within the Homeseer install directory) with https://sqlitestudio.pl/index.rvt and delete the values showing extremely large values (make sure you stop the homeseer whilst making the change) or just stop homeseer and delete the file, and a new one will be created starting from afresh.

    Leave a comment:


  • rascasse
    replied
    Mine looks to be working, just the issue with the Energy history....Click image for larger version

Name:	Capture5.JPG
Views:	18
Size:	27.2 KB
ID:	1281888

    Leave a comment:


  • Mobileum
    replied
    I think the problem is how you use decimal separator. When I in, the ini-file, put in a .(dot), the "Tariff-field" shows "1,2", and when I put in a ,(comma), the result is "120". Neither is working so far.

    Leave a comment:


  • fuzzysb
    replied
    Ok just try using the value. Leave the special character before the 0.00 in place and just set your value in the ini directly. I will in tandem troubleshoot why is it's doing you updating via the gui
    .

    Leave a comment:


  • Mobileum
    replied
    [EFERGYENGAGE]
    access_token=xxxxxxx
    [EFERGYCOST]
    per_kw_cost=¤0.00

    Should I update it here?

    Leave a comment:


  • fuzzysb
    replied
    It should be fine. What does your ini file now show?

    Leave a comment:


  • Mobileum
    replied
    Installed, but the cost will not be updated, and revert to zero as soon as I exit Config. I am using "kr" as currency.

    Leave a comment:


  • fuzzysb
    replied
    rascasse ok the new beta is up, you now just goto your settings and enter your cost per KWH to match the same as in your Efergy Engage Settings and this will ensure that this now works again uploading values to the HS3 Energy DB, it will prevent this error occuring even if the issue persists on the EfergyEngage platform returning a null entry. so now it uses the value from Efergy, but if that fails, like it has been for the last few weeks it will use the value below.

    Leave a comment:


  • fuzzysb
    replied
    Ok let me work on a new beta version tomorrow. I will have to prompt you in the settings for your tariff price and if this issue persists or happens again it will fall back to that value. Then it should all work consistently

    Leave a comment:


  • rascasse
    replied
    Mine also working thanks - but no device is appearing in the Energy DB though...

    Click image for larger version

Name:	Capture 4.JPG
Views:	107
Size:	63.7 KB
ID:	1281024

    Leave a comment:


  • fuzzysb
    replied
    yes the estimates are dependant on the Tariff information, which is the current issue with the Engage platform as this returns a null response

    Leave a comment:


  • Mobileum
    replied
    I am now Online. Good. But all "Estimates" are empty, and I know nothing about how to check the Energy DB input.

    And "Root Device" is Off...

    Leave a comment:


  • fuzzysb
    replied
    rascasse Mobileum The issue was caused by an error in the Efergy Engage API as the Tariff request returns a null response. I sent a message to them asking them to resolve. it's exactly the same issue that occured the week after i initially released the plugin. and they fixed after roughly 2 weeks, however they still haven't fixed this, so to work around this i have release v1.0.0.109 Beta, which is in the beta section of the updater. please update the version and try.

    You will not see the tariff updating, but if you had a value there, then it will work i think without issue, but if not, please check the Energy DB input as i don't know what the impact will be, does it still set the value or not?

    Leave a comment:

Working...
X