Announcement

Collapse
No announcement yet.

Control Plugwise devices by 'toggle'

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Control Plugwise devices by 'toggle'

    Now that the plugin is working I can control my 'circles' via 'View' -> 'Device management'.
    When I try to control them from HS-touch with separate on- and off buttons everything works fine, but when I try to 'toggle' the devices this won't work.

    I've found several threads on the forum, but they have dead-ends or they are not clear for me (to technical).

    Is there a way to control Plugwise devices by 'toggle'?

    Jaco
    Last edited by Jaco; December 20th, 2014, 03:13 AM.

  • #2
    Originally posted by Jaco View Post
    Now that the plugin is working I can control my 'circles' via 'View' -> 'Device management'.
    When I try to control them from HS-touch with separate on- and off buttons everything works fine, but when I try to 'toggle' the devices this won't work.

    I've found several threads on the forum, but they have dead-ends or they are not clear for me (to technical).

    Is there a way to control Plugwise devices by 'toggle'?

    Jaco
    Strange I have that too now. I will have to investigate...

    Can you tell me which version of HS, HSTouch server, HStouch client, HStouch designer etc you are using...

    Thanks
    Regards,

    Rien du Pre
    The Netherlands
    Using:
    Homeseer PRO 3.0.0.500 and latest HS4 BETA on MacOS - Running a Mac Mini
    Plugin's:
    RFXCOM, Caddx, BLShutdown, BLLogMonitor, BLRadar, BLBackup, Log2Text, BLLAN, Z-Wave

    Comment


    • #3
      Can you tell me which version of HS, HSTouch server, HStouch client, HStouch designer etc you are using...
      Sure I can;

      Plugwise Source: 2.24
      Plugwise Server: 2.24<O</O
      HS3 Pro Edition 3.0.0.149 (Latest Beta)<O</O
      HS3Touch Version 3.0.19 (Latest Beta)

      Thanks in advance.

      Jaco

      Comment


      • #4
        I just ran into "toggle" problems..

        One of the reasons could be:

        I toggle based on the device value (0=off, >0=on)
        device-value = 0 then: (off, have to switch on)
        hs.CAPIControlHandler(hs.CAPIGetSingleControl(Cint(theDevice ),true ,"on",false,true))
        device-value > 0 then: (on, have to switch off)
        hs.CAPIControlHandler(hs.CAPIGetSingleControl(Cint(theDevice ),true ,"off",false,true))

        > deviceVALUE=8960
        > deviceSTATUS=8960 (??)
        > deviceSTRING="On 89.60W"

        So far so good. When running these toggle commands the value > 0 so it switches the device off. That works.

        The device is now switched off but the deviceVALUE and deviceSTATUS won't update until the plugin does the next "poll".

        Same with ON. I switch the device ON but can't switch it OFF until it hits the next 60 seconds poll. Only THEN the device info is updated and the script knows which command to send.


        With my own Plugwise scripts in HS2 I had a special "toggle" script that send the command to the Plugwise source PLUS it immediately changed the device status/string/value to make sure it's up to date.

        What do you think?

        DJ

        Comment

        Working...
        X