Announcement

Collapse
No announcement yet.

Startup Error

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Startup Error

    Can you help with this error? I downloaded the plug in and it does not load.

    Starting up....

    10/8/2020 5:41:53 PM HomeSeer~!~Error~!~Warning, Cannot load EXE file (possibly missing dependencies) HSPI_TeslaPowerwall.exe: Unable to load one or more of the requested types. Retrieve the LoaderExceptions property for more information.Warning, Error details with EXE HSPI_TeslaPowerwall.exe: Could not load file or assembly 'System.Net.Http, Version=4.2.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a' or one of its dependencies. The system cannot find the file specified.Warning, Error details with EXE HSPI_TeslaPowerwall.exe:

    #2
    Windows or Linux? If Windows, try updating .NET Framework (4.7.2 or later). If Linux, try updating mono.

    Comment


      #3
      Thanks for the quick reply! I'm up and running. Now I have to get my Powerwall connected to my network. They set it up with cellular even though my router was four feet away...

      Comment


        #4
        "It's got cellular anyway, why hook it up to wifi..."

        Comment


          #5
          Okay, After connecting yhe Powerwall to my home network, I have my phone connected to the Powerwall @192.168.0.43 on my home network successfully. When I go type in the IP address into the Powerwall plugin setup and save it, I receive no errors but it seems to hang up there showing "Initializing...". The plugin does not create any devices. I have checked all filters.

          The Plugin Setup Shows:
          Status (refresh to update)
          INFO: Initializing... (this will not change after an hour even after I left the setup page and returned)
          Backup Gateway LAN IP: 192.168.0.43
          Log File Entries:
          10/9/2020 5:24:38 PM
          HomeSeer Plug-In Finished initializing plug-in Tesla Powerwall
          10/9/2020 5:24:38 PM HomeSeer Starting Plug-In Tesla Powerwall loaded in 440 milliseconds
          10/9/2020 5:24:38 PM HomeSeer Starting Plug-In Plugin Tesla Powerwall started successfully in 115 milliseconds
          10/9/2020 5:24:38 PM Tesla Powerwall Info Attempting to connect to Gateway at IP "192.168.0.43"
          10/9/2020 5:24:38 PM HomeSeer Starting Plug-In Initializing plugin Tesla Powerwall ...
          10/9/2020 5:24:38 PM HomeSeer Info Plugin TeslaPowerwall with instance Tesla Powerwall has connected. IP:127.0.0.1:56649

          My System is as follows:
          Hometroller S6 with
          HS4 Pro Edition 4.1.8.0 (Windows)
          OS Microsoft Windows Embedded Standard - Work Station
          OS Version 6.1.7601

          Free/Total Memory 846.39 MBytes / 3.40 GBytes (24% free)
          Free/Total Virtual Memory 4.09 GBytes / 6.80 GBytes (60% free)
          HomeSeer Memory Used 1 Gbytes
          Plugin Memory Used 9 EXE Plug-Ins using 366 Mbytes
          Plugins Installed:
          drhsIpPlugIn 0.0.0.26,DSC Security 3.0.0.56,HSBuddy 3.18.721.0,LutronRA2 3.0.0.120,MyQ 1.2020.705.1301,SolarEdge 4.0.9.0,Tesla Powerwall 2.0.7584.9521,Tesla Vehicles 1.5.2.0,UltraTivo3 3.0.7180.32876,UltraWeatherWU3 3.0.7392.20535

          Any helpful ideas would be appreciated!!

          Comment


            #6
            It sounds like the plugin is crashing for some reason. Can you please try installing this version? Just disable the plugin, drop HSPI_TeslaPowerwall.exe into your HS4 folder (should be under C:\Program Files\HomeSeer HS4), and then re-enable it from HS4. Then let me know what the status tells you.

            Also, which .NET version are you running? It still sounds like you're not quite running 4.7.2 which is the minimum this will support.

            Comment


              #7
              I'm getting a 404 page not found error on the Github link.

              Comment


                #8
                Interesting, I didn't realize that GitHub made you sign in to download build artifacts. Here it is.
                Attached Files

                Comment


                  #9
                  So, I followed your instructions to install the new plugin and had the same issue. I had installed .NET 4.8 yesterday and thought that may have been the issue so I uninstalled it and installed .NET 4.7.2. Turned off the Powerwall Plugin, shut down and restarted my Hometroller and the reactivated the Powerwall Plugin. It still hangs at the same place.

                  How does the Plugin sign in to the Powerwall? I have a Chrome Browser active and signed in on my Hometroller so I know that I'm logged in to the Powerwall. Although, everytime I log into the Powerwall Gateway from a Device I have to select "Customer" and enter my 5 digit Password!?

                  Is there anything else I need to update in my Microsoft Windows Embedded Standard OS on my Hometroller?

                  Click image for larger version

Name:	IMG_5361.jpg
Views:	27
Size:	146.0 KB
ID:	1425266

                  Log File Data:
                  10/10/2020 1:39:58 PM
                  HomeSeer
                  Plug-In
                  Finished initializing plug-in Tesla Powerwall
                  10/10/2020 1:39:58 PM
                  HomeSeer
                  Starting Plug-In
                  Tesla Powerwall loaded in 499 milliseconds
                  10/10/2020 1:39:58 PM
                  HomeSeer
                  Starting Plug-In
                  Plugin Tesla Powerwall started successfully in 180 milliseconds
                  10/10/2020 1:39:57 PM
                  Tesla Powerwall
                  Info
                  Attempting to connect to Gateway at IP "192.168.0.43"
                  10/10/2020 1:39:57 PM
                  HomeSeer
                  Starting Plug-In
                  Initializing plugin Tesla Powerwall ...
                  10/10/2020 1:39:57 PM
                  HomeSeer
                  Info
                  Plugin TeslaPowerwall with instance Tesla Powerwall has connected. IP:127.0.0.1:50044
                  Attached Files

                  Comment


                    #10
                    That's weird. Can you install this debug build instead which has additional logging?

                    The plug-in doesn't need to sign into the Gateway since the energy data is available without a login.
                    Attached Files

                    Comment


                      #11
                      This doesn't look good... It looks like my Powerwall isn't playing nice.
                      If that is the case, it may be because I was an early adopter.


                      10/10/2020 6:17:26 PM Tesla Powerwall Trace [Report:50] Analytics report: NoContent
                      10/10/2020 6:17:13 PM HomeSeer Plug-In Finished initializing plug-in Tesla Powerwall
                      10/10/2020 6:17:13 PM HomeSeer Starting Plug-In Tesla Powerwall loaded in 540 milliseconds
                      10/10/2020 6:17:13 PM HomeSeer Starting Plug-In Plugin Tesla Powerwall started successfully in 142 milliseconds
                      10/10/2020 6:17:12 PM Tesla Powerwall Trace [GetApiContent:94] Requesting https://192.168.0.43/api/site_info/site_name
                      10/10/2020 6:17:12 PM Tesla Powerwall Info [CheckGatewayConnection:112] Attempting to connect to Gateway at IP "192.168.0.43"
                      10/10/2020 6:17:12 PM Tesla Powerwall Trace [Initialize:27] Initialize
                      10/10/2020 6:17:12 PM HomeSeer Starting Plug-In Initializing plugin Tesla Powerwall ...
                      10/10/2020 6:17:12 PM HomeSeer Info Plugin TeslaPowerwall with instance Tesla Powerwall has connected. IP:127.0.0.1:49701


                      Summary from Gateway:

                      SITE NAME Home Energy Gateway
                      BACKUP CAPABILITY Backup Capable
                      MODE Backup-only
                      BACKUP RESERVE 52.5%
                      GRID CODE 60Hz_240V_s_IEEE1547:2003
                      TIME ZONE America/Los_Angeles
                      CUSTOMER VERSION 1.49.0
                      NETWORK Wi-Fi, CELLULAR
                      POWERWALL 1 PartNumber: 1092170-03-E Serial: T17F000xxxx
                      2 PartNumber: 1092170-03-E Serial: T17F000xxxx

                      Comment


                        #12
                        Can you load https://192.168.0.43/api/site_info/site_name in your browser and copy-paste what you get here?

                        Comment


                          #13
                          I found a bug that would explain why the plugin is crashing. Please try this version. It won't fix your problem connecting to the Gateway, but it should at least give us an error message we can work with.
                          Attached Files

                          Comment


                            #14
                            https://192.168.0.43/api/site_info/site_name

                            Returns this:
                            {"site_name":"Home Energy Gateway","timezone":"America/Los_Angeles"}

                            Comment


                              #15
                              New Debug Build Installed:

                              10/11/2020 12:18:55 PM Tesla Powerwall Error [CheckGatewayConnection:136] Cannot get site master from Gateway 192.168.0.43: One or more errors occurred. [An error occurred while sending the request.] [The request was aborted: Could not create SSL/TLS secure channel.]
                              10/11/2020 12:18:55 PM Tesla Powerwall Trace [GetApiContent:94] Requesting https://192.168.0.43/api/site_info/site_name
                              10/11/2020 12:18:55 PM Tesla Powerwall Info [CheckGatewayConnection:112] Attempting to connect to Gateway at IP "192.168.0.43"
                              10/11/2020 12:18:55 PM Tesla Powerwall Debug [OnSettingChange:69] Request to save setting gateway_ip on page TeslaPowerwallSettings
                              10/11/2020 12:18:35 PM Tesla Powerwall Trace [Report:50] Analytics report: NoContent
                              10/11/2020 12:18:29 PM HomeSeer Plug-In Finished initializing plug-in Tesla Powerwall
                              10/11/2020 12:18:29 PM HomeSeer Starting Plug-In Tesla Powerwall loaded in 599 milliseconds
                              10/11/2020 12:18:29 PM HomeSeer Starting Plug-In Plugin Tesla Powerwall started successfully in 31 milliseconds
                              10/11/2020 12:18:29 PM Tesla Powerwall Info [CheckGatewayConnection:112] Attempting to connect to Gateway at IP ""
                              10/11/2020 12:18:29 PM Tesla Powerwall Trace [Initialize:27] Initialize
                              10/11/2020 12:18:29 PM HomeSeer Starting Plug-In Initializing plugin Tesla Powerwall ...
                              10/11/2020 12:18:29 PM HomeSeer Info Plugin TeslaPowerwall with instance Tesla Powerwall has connected. IP:127.0.0.1:62998

                              10/11/2020 12:12:58 PM HomeSeer Info Plugin Tesla Powerwall with ID: TeslaPowerwall and Instance: has disconnected
                              10/11/2020 12:12:58 PM HomeSeer Plug-In Shutting down Plug-In: Tesla Powerwall

                              Comment

                              Working...
                              X