Announcement

Collapse
No announcement yet.

Unable to Set Baud Rate; No DB Inserts (3.0.6300.28069)

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Unable to Set Baud Rate; No DB Inserts (3.0.6300.28069)

    I have an ECM-1240 recently started having some issues with the UltraECM plugin.

    At some point, I realized ECM-1240 data was no longer being updated. I am not entirely sure what change triggered this - it has been a while. After trying several things (updating HS3, updating the plugin, re-installing the plugin, etc.), I am still unable to get any data to show up.

    I can confirm that the device is present and functional on COM6. I am able to connect via the Interface Application without issue.

    I do notice that I am unable to get the 19200 baud rate to "stick" on the configuration page. No matter how many times I tell it to go to 19200, it will always revert to 115200 when I return to the Options tab.

    It does not appear that I can command the ECM-1240 to operate at 115200 - I thought that might be worth a try.

    That said, based upon the configuration file, it appears to be only a GUI fluke:

    Code:
    [Settings]
    Version=3.0.6300.28069
    [Options]
    PacketBuffer=1
    PostDataType=0
    PostDataInterval=30
    PostDataURL=http://api.smartenergygroups.com/sites/
    UnitType=0
    TempDegreeUnit=True
    TempDegreeIcon=True
    GEMBaudRate=19200
    ECMBaudRate=19200
    LogLevel=7
    [Rate]
    DefaultCost=0.12
    [WEBUsers]
    AuthorizedRoles=15
    From the logs, I see this shortly after enabling the plugin (reading bottom to top):

    Code:
    Apr-19 9:45:30 PM Informational Brultech ECM Device connection established to COM:6. 
    Apr-19 9:45:30 PM Plug-In Finished initializing plug-in UltraECM3
    Apr-19 9:45:29 PM Info Plugin UltraECM3 has connected. IP:127.0.0.1:54891
    Then, I start to see periodic messages that indicate a watchdog timeout:

    Code:
    Apr-19 9:58:36 PM Warning Watchdog Timer indicates No response response from the Brultech device 'COM:6' for 786 seconds.. Attempting to reconnect ...
    Not sure where to go from here. Let me know if you need more information or if there is anything I can try...?
    Attached Files

  • #2
    I have the exact same issue. I switched to windows 10 machine just in the past 2 weeks and looked back when it stopped and was at the time of the update for the change to the new data base type i guess. (i still have the old hard drive, so I plugged it back in to look)
    is there a place, you can suggest to learn more as to how the database works, i know very little about managing data bases such as the type used in this case or what is needed to make it work. I'm unclear about how we are to use the built in Homeseer energy data base. There is a lot taken for granted in the pre-knowledge using the energy monitor options in Homeseer if that is what is being done now.

    Comment


    • #3
      I am sorry, I completely missed your questions. Are either of you still experiencing an issue getting your ECM-1240 connected via a serial connection?

      Regards,
      Ultrajones
      Plug-ins: UltraMon, UltraM1G, UltraCID, Ultra1Wire, UltraLog, UltraWeatherBug, UltraPioneerAVR, UltraGCIR

      Comment


      • #4
        I can't get it to read or connect. The brultech software for configuration is reading just fine. Followed the instructions but I'm not sure if there is more I need to do.

        Comment


        • #5
          I am checking with Brultech to see if they have a loaner ECM-1240 I can use to troubleshoot the issue you reported. I'll let you know if I can acquire one.
          Plug-ins: UltraMon, UltraM1G, UltraCID, Ultra1Wire, UltraLog, UltraWeatherBug, UltraPioneerAVR, UltraGCIR

          Comment


          • #6
            I have a Brultech ECM 1240 arriving on Monday. I'll be able to get this issue tested and resolved within a week. I am sorry for the delay.

            Regards,
            Ultrajones
            Plug-ins: UltraMon, UltraM1G, UltraCID, Ultra1Wire, UltraLog, UltraWeatherBug, UltraPioneerAVR, UltraGCIR

            Comment


            • #7
              That is good news. The hot summer here I did not want to look at all the cooling costs. Somethings are better unknown ...eh
              Thank you for the update

              Comment


              • #8
                Please download and install UltraECM3 HSPI version 3.0.6444.32929. I had to set the baud rate to 19200 for mine to work. So, try installing the update, then setting the ECM-1240 Serial Baud Rate to 19200, then restarting the plug-in.

                Regards,
                Ultrajones
                Plug-ins: UltraMon, UltraM1G, UltraCID, Ultra1Wire, UltraLog, UltraWeatherBug, UltraPioneerAVR, UltraGCIR

                Comment


                • #9
                  Originally posted by Ultrajones View Post
                  Please download and install UltraECM3 HSPI version 3.0.6444.32929. I had to set the baud rate to 19200 for mine to work. So, try installing the update, then setting the ECM-1240 Serial Baud Rate to 19200, then restarting the plug-in.

                  Regards,
                  Ultrajones
                  That fixed it, thanks! No worries about the delay - but it's certainly nice to have it working again.

                  Comment

                  Working...
                  X